[SOLVED] Wrong local time. How to change?

Raspberry 4

[15:30:50] openhabian@openhab:~$ timedatectl status
Local time: Mon 2020-01-20 15:31:00 GMT
Universal time: Mon 2020-01-20 15:31:00 UTC
RTC time: n/a
Time zone: Europe/London (GMT, +0000)
System clock synchronized: yes
NTP service: active
RTC in local TZ: no

Hi again,

I wanted to start with rules, but first of all my time is wrong. In putty using “timedatectl” gives me local time GMT whereas Berlin/GMT+1 would be correct. In paper UI/configuration/system/regional the correct time zone is set. I tried different zones, none is changing the time.

Try adding "-Duser.timezone=Europe/Berlin" to the options line beginning with EXTRA_JAVA_OPTS in /etc/default/openhab2

is what I found here but I have no clue in which file to put the lines.

There was something aboute start_runtime.sh. But I cannot locate this file either.

How can I change the local time?
Do I need the ntp binding?


[15:22:08] openhabian@openhab:~$ timedatectl set-timezone “Europe/Berlin”
==== AUTHENTICATING FOR org.freedesktop.timedate1.set-timezone ===
Authentication is required to set the system timezone.
Authenticating as: root

tried this. Not working.

Just a guess

Have you tried

sudo timedatectl set-timezone “Europe/Berlin”


There are 2 places to set. OS level & openHAB.OPenHAB is in Configuration -> System in PaperUI.

1 Like

Thank you for the quick reply. sudo timedatectl set-timezone “Europe/Berlin” followed by a reboot solved the problem so far.

Still no idea about, ntp, start_runtime.sh and so on but happy with this solution so far.

1 Like

sudo timedatectl set-timezone “Europe/Berlin”
does not work . gives out :
Failed to set time zone: Invalid time zone ‘“Europe/Berlin”’
what to do?

That is not an openHAB command. Ask in a Raspbian forum? openHABian images are basically Raspbian with raspi-config removed,

Не помогает . Выдает :
Failed to set time zone: Invalid time zone ‘“Europe/Berlin”’
Какие ещё варианты ?

I solved the problem of time on the R.PL4 team
sudo timedatectl set-timezone Europe / Kiev
sudo dpkg-reconfigure tzdata
Interestingly, the time of the logs is still not correct. Does not account for UTC.
Paper UI set correctly.
Any ideas?

How are you viewing the logs? directly or using some other application?

Corrected. I think reboot helped.

This is corect

corect is
timedatectl set-timezone Europe/Berlin