[SOLVED] Xiaomi Philips Wifi Lamp

I got the Xiaomi Philips Wifi Lamp ( https://www.gearbest.com/flush-ceiling-lights/pp_633589.html ) from China and can control it with the MiHome App.

Is there a Binding for it?

There you are:


I have installed this binding from about 1 month, but I don’t see this lamp. This is wifi lamp, it can work without Xiaomi Gateway.

this is properly binding: https://github.com/syssi/philipslight
… but fir Home Assistant, Is exists similar binding for OpenHab?

You need to add the marketplace to the list of bindings

and then use:

Did that work for you?

No, becouse I have troubles with getting token.

lumi.gateway.v3 - Mi Control Hub - -
philips.light.ceiling - Philips connected ceiling - -
hhcc.plantmonitor.v1 - Flower Care - -
lumi.sensor_86sw2.v1 - Wireless switch (wall-mounted - -
lumi.sensor_ht.v1 - Mi Temperature and Humidity Se - -

I tried to downgrade mi home to version 5.0.29, but I still getting logs like above…

version mi-home-5-0-6.apk (from https://mi-home.en.uptodown.com/android/old ) works, now I have token - where I should place them?

I successfully added lamp as thing.

Can someone give me example how to turn on lamp in default.rules file?

Click on the power thing and link to a new item
name the item philipsLamp or whatever name you want

How do you want to turn on the lamp?
Do you have a sitemap setup?

OK everything is working:


Switch item=PhilipsCeiling

Slider item=PhilipsCeilingBright
Slider item=PhilipsCeilingCCT
Text item= PhilipsCeilingScene
Switch item=PhilipsCeilingSwitchScene
Switch item=PhilipsCeilingToggle


Switch PhilipsCeiling “PhilipsCeiling” { channel=“miio:generic:be858737:power” }
Number PhilipsCeilingBright “PhilipsCeiling brightness [%.0f]” { channel=“miio:generic:be858737:brightness” }
Number PhilipsCeilingCCT “PhilipsCeiling color temp [%.0f]” { channel=“miio:generic:be858737:cct” }
Number PhilipsCeilingScene “Scene [MAP(scene.map):%s]” { channel=“miio:generic:be858737:scene” }
Switch PhilipsCeilingSwitchScene “SwitchScene” { channel=“miio:generic:be858737:switchscene” }
Switch PhilipsCeilingToggle “Toggle”{ channel=“miio:generic:be858737:toggle” }

Maybe my post helps someone in future :slight_smile:


Hi to all, I’ve tried to binding this lamp but I cannot find it. If I add a new device I can only add it manually. I have tried all the combination (base, unsupported, vacuum) but I cannot binding this light.
I’have installed iot market but in binding tab I ca only find “Xiaomi Mi IO Binding” and “Xiaomi Mi Smart Home Binding”
Could someone help me?

I successfully added lamp as thing.
Can someone give me example how to turn on lamp in default.rules file?

Talib how did you get this screen?

I have installed those bindings:

you shoulkd get token from lamp (I used this topic Xiaomi Robot Vacuum Binding )

Hi talib can you send me a picture of the next step that you have done after installing that 2 bindings.
I also have seen a difference from mine, you have xiaomi mi smart home binding v.2.2.0 instead I have snapshot 2.3.0

Look at this:

hi talib, thanks for the picture. I have another question in the first of the two picture when you only insert ip address and token or do you insert other information? I’m asking this because when I put that information and add thing I don’t have the second picture with modelid philips.light.ceiling.
waiting for your kindly reply

Second picture is only like “additional advice”, I don’t remember what happend when I click “done” on first screen. Do you have correct token (do you know that you have different)?

I have used the same token of the vacuum robot but it doesn’t work

every device has own unique ID/token. You have to get token from your lamp. I used for this thing:
mi-home-5-0-6.apk (on phone)
MiToolkit 1.6 (on PC)

All right now it works

Hi, can someone give me example ot .thinks file for Philips ZhiRui bedside lamp?
I tryed

Thing miio:lumi-gateway-v3_miio80945609:0444589 “Philips ZhiRui bedside lamp” [ host=“192…”, token=“xxx” ]

Thing miio:generic:0444589 “Philips ZhiRui bedside lamp” [ host=“192…”, token=“xxx” ]

but seems not working …


Thing miio:unsupported:0444589 “Philips ZhiRui bedside lamp” [ host=“192…”, token=“xxx” ]

1 Like