[SOLVED] Z-Wave: cannot remove "phantom" devices

Tags: #<Tag:0x00007fe04f5298b0>

(First Last) #1

While playing with a Z-Wave device I have removed and re-added it a couple of times. Now the real node ID is 18, but I keep getting its “phantom”, obsolete, copies as nodes 14 and 17 in my inbox. This happens every time I run thing discovery.

I tried to delete them while the Z-Wave controller is in the exclusion mode, but it didn’t help.

How can I remove them permanently (without having to “Ignore” them)?

[SOLVED] Trouble removing (deleting, excluding) previous ZWave devices that I paired to Nortec HUSBZB-1 USB controller
(Angelos) #2

check this recent post:

There is also the Zensys tool for more advanced stuff: http://docs.incontrolha.com/home/remove-a-failed-device

(First Last) #3

Thanks, it looks indeed what I was looking for. But I did what Rich suggested, this doesn’t seem to work. After clicking on “Remove device from controller”, I get an error popup:

Then I delete the thing manually as per the advice, but after discovery it’s again in my Inbox. Arghhh.

This thing is Windows only I guess?

(Scott Rushworth) #4

There were issues with the Inbox that have been corrected, but I’ve also had yhis happen on a recent snapshot. It does not look like these nodes are on your controller, so you won’t be able to exclude/remove them. You could try restarting OH and/or clearing the cache, IIRC, mine stopped being discovered after updating to another nightly build, which clears the cache.

(Antares2001) #5

I’m facing the same issues that @ncwekjn describes. My only solution was in the end to put up a Domoticz instance and delete the devices using the OpenZWave console there. But that’s very tedious if you have many devices and doesn’t work reliable in all cases.

(Angelos) #6

The Zensys tool (only Windows) is very, very effective in cleaning up old Z-Wave nodes from the Controller (the USB Stick)

Even Aeon Labs uses it :slight_smile: Ref: Zensys zwave tool & zwave issues

(Antares2001) #7

If it just weren’t Windows… :wink: I don’t even have a copy of it. My computers all come without it.

(First Last) #8

Upgraded to the latest milestone release (2.4.0~M7-1), cleaned the cache, even removed nodes’ XMLs from /var/lib/openhab2/zwave/, they’re still coming back upon discovery. Removal from the controller action in HABmin still fails:

2018-12-07 11:43:52.228 [ERROR] [message.RemoveFailedNodeMessageClass] - NODE 14: Remove failed node failed as node not found

Will try digging some Windows box to run Zensys on it…

(Ole Morten Rønning) #9

Been there.

(First Last) #10

Phew. They’re finally gone, with the help of Zensys tools. What I have done:

  1. Stop my OpenHAB service
  2. Extract the UZB stick from my Raspberry Pi
  3. Spin up a Windows 7 VM in Virtual Box on another machine
  4. Insert my UZB stick into an USB port
  5. Connect the “Sigma device” to the VM in its device settings
  6. Install the usb.inf driver from z-wave.me website.
  7. Follow the steps from this how-to.
  8. Reinsert the UZB stick into my Raspberry Pi
  9. Start the OpenHAB service
  10. Manually remove the “phantom” Z-Wave things