[SOLVED] Z-wave stick in docker container on a synology

Thx for your reply @mpuff

Just stopping and starting the container works for me.
But after each DSM restart I have to execute the chmod command again.
So I think I have to start looking for some config to make this persistent. Maybe udev rules are a way to go…

So just for reference, this is what works for my setup now for several hours with some restarts

Hi all,

I am also struggling with the Aeotec Gen5 USB stick.
chmod 777 /dev/ttyACM0 helps for me; but doing that after each restart is not a solution.

The udev rule is great - but somehow it is not working for me. After each restart the stick is still dev/ttyACM0 and not “USBzwave”
I did not create the homeautomation group and therefore removed the “GROUP=homeautomation” part in the rules-file.

Is this necessary? If yes; how do I add user root the group? Any other hints what I might do wrong?

Thanks in advance

I probably have the same problem that was solved here a year and a half ago.
Unfortunately my technical understanding is at the level that is assumed here.
Perhaps I may go back and check again (ah, I forgot to say that I am trying out Openhab3/Mileston 2 in the container):

Basically I don’t know how I can enter the CMOD command in the Docker App in the DSM? It looks like this for me:

on my Raspberry (= openhab2 productive system) I go in via Putty … but here on the Synology I can’t find the right port … if it is one of these … it wouldn’t work:


I am stuck as “stuck”

are you passing it through to the container? you need to have the permissions set via ssh on the Syno not the docker.

then SSH to your syno and be sure the /dev/ttyACM is owned by the user that the docker openhab runs as:

ll /dev/ttyACM0
crwxrwxrwx 1 docker-rw openhab 166, 0 Nov 20 19:58 /dev/ttyACM0

my docker containers run as docker-rw (probably the same for you)

Mmmh, still have problems … I have now logged in with the user who also has docker permission

But CMOD still won’t work:

its “chmod”

oh, silly me … but no difference:

are you root?
do a reboot with the stick attached and try again

its ttyACM0 not AM0

Okay, now it works … i’ve walked this path:

1a) give “high priority” zu Container:
1b) be sure that the Openhab-Admin-User have has the correct permissions on the Synology:

1c) restart synology NAS
2) SSH to NAS with a AdminUser with appropriate access rights to the “Docker” folder:
2a) the user should look like this

2b) SSH to NAS with a AdminUser like this:

  1. a) Try to find the Thing and create:

b) entry for “serial port” added and saved

Thing created and here we go:


is the stick online if you restart the container or do you need to restart to synology?
this was also a problem the time i used it, when i have done some changes and need to reboot openhab (container), than zwave was not working anymore

quite honestly - I can’t put my finger on it … I have tried -zig times around … and at some point it worked. In EVERY case, however, the step “2b)” must be carried out - otherwise nothing works.

Hi @mpuff, quick question on this one: I’m currently having a similar issue (my Aeotec Z-Wave Gen5+ Stick sometimes stays offline after I reboot my Raspi, and only re-deploying the container solves the problem, see here). Is this similar to what you experienced / have you found a solution to that?

hello, sounds like a similar problem yes, i have installed zwave2mqtt on another raspberry in docker, this was working really good.

Just fyi: In the meantime there’s been some discussion around this problem, and the following fix solved it for me at least symptom-based. The root cause seems to be an unsolved bug.

Fixed in 3.3.0

If I read this post correctly, isn’t the problem still persistent in 3.3.0? This would also be in line with my experience (am also running 3.3.0 and perceive the same problem).

Wouter built a fork of the library and applied a fix
see here for info
The fix is in 3.3.0-SNAPSHOT build #2849 or newer.
If you still think you are having an issue, try to reproduce it and report on github
There is a link to the issue on github somewhere in that thread

Thanks a lot.

I would be really happy to help / contribute. However, since I’m not that much of a pro, and am very happy that my current setup is somehow running stable (except for this problem with frequent Raspi disconnect problems but which appears to be a Raspi-specific problem) I am very reluctant to switch to another openHAB snapshot (if this is what would be needed from my side).

Let me know if I missed something.