[SOLVED] Z-Wave, Unknown device, 010F:0303:1000:5.0, Fibaro Roller Shutter 3 (FGR-223)

Hi folks,

it seems that the new Fibaro Roller Shutter 3 (FGR-223) is unknown in the Zwave Binding.
Device ID = 010F:0303:1000:5.0

Could someone help me to add this device to the database?

Please let me know if I could assist with some additional information, such as debug trace or whatever is necessary?!


It’s already in the database here. It’s possible that you’re running an older version of the binding that doesn’t include this device.


Ok, thanks, after updating to the Milestone-Release the device is stored correctly. Although it’s not the best way to leave the stable release path just to get a new database version, it solved my problem now. Thanks.

It’s possible to update the binding version without updating the entire release. See my post here.

While this isn’t guaranteed to work all the time (sometimes there are changes to the core and/or the binding that cause an incompatibility), it can be an effective way to minimize the risk of updating the entire openHAB version just to pick up a zwave database update.

1 Like

Hello everyone, I need help please for the same Problem.

My Hardware:

#1 Raspberry Pi 3 Modell B+ with openhabian-pi-raspbian-201908050414-gitca0976f-crc6a66b5a1.img.xz

#2 ZMEEUZB1 (Z-WAVE Controller)

#3 Fibaro Roller Shutter 3 (FGR223)

My problem is that the RollerShutter stands there as an unknown device. I read everywhere that you can expand the database on cd-jackson.com. And the device is also listed there


But how do I get this device into my database of Openhab? :cold_sweat:

I also read a lot of XML files … but dont know what i want to do with the xml file?

Can someone please tell me step by step how I can extend the database… please :pray:

Thank You!


Which OH version do you use?

EDIT: OK, I’ve overlooked it. It’s openhabian-pi-raspbian-201908050414-gitca0976f-crc6a66b5a1.img.xz
It’s the latest version. I don’t know if device is in there… Sorry.

You can find the instructions here -:

However it’s unclear if this is really your problem since you say that you have the same problem and this problem should be resolved as this device is already in the database. Can you please state exactly what your problem is?

I had the similar problem last week with the fibaro rgbw module. It was not recognized…only as fibaro. On openHABian I pulled the latest release 2.4 and the database of z-wave got updated too…try to pull latest update (with openhabian-config) maybe this helps. And of course exclude and include again

The binding & database for 2.4 are NOT the latest for zwave. There is an upgrade script for the binding that can update it though.

Hi Chris,

this is my Problem:

but if you say that this device is already in the database, then I dont know anymore :weary: Why my openhab says all the time Unknown Device.

this is the XML File from srv/openhab2-userdata/zwave folder

Thanks for answer :slight_smile:

Strange - it looks like it should be ok - certainly the device is already in the database and has been there for quite a long time (as this issue suggests).

All I can really suggest is to enable TRACE level logging and see what that shows.

… TRACE level logging … Sounds complicated

Maybe the logflies from OpenHab will help


Not really. Look here starting at “When things don’t go as planned” but use TRACE instead of DEBUG.

Ok was not complicated :slight_smile: if that’s what Chris meant.

Thank you Bruce

Could not send the zwave.log im blocked for SPAM :flushed: That’s so frustrating… why Spam?

The zwave.log is on the same Adress like events.log and openhab.log wor-design_de/openhab/zwave.log hope you can find the issue.

System Blocked me … to fast answer maybe:
" Your post was flagged as spam : the community feels it is an advertisement, something that is overly promotional in nature instead of being useful or relevant to the topic as expected."

Sometimes the zwave log viewer can help you sort trough the logs.


The log shows that the binding is not searching for your device. It looks like it doesn’t contain any new devices for the past few months, which indicates that maybe you’re running an older binding than you think?

I would suggest to check the versions using the console - ie logon to the console and list the running bindings to get their version.

1 Like

Hello Chris,

here is a Screenshot of my List

openhab-cli console bundle:stop 206
openhab-cli console bundle:start 206

was worked to, after stop was the Binding off and after start was again on.

That explains the issue :slight_smile:

You are using quite an old version of the binding and it doesn’t contain this device. The version you have is 2.4 which was released in December last year if I remember correctly.

You will need to use one of the newer 2.5 versions - 2.5M2 should be ok I think.

1 Like


The easiest way to upgrade the binding is with Scott’s script.

I dont know why but it does not seem to work anything I touch :woozy_face::sleepy:

It does not work for me.

Maybe you know a another way? Or a better image Version for Raspberry Pi with the new Version fo the Z-Wave Binding?