[SOLVED] Z-Wave unreliable in 2.5.0.M4

Tags: #<Tag:0x00007f61733d46a0>

May I ask how? I have the same problem.

Solved: Got it removed after several attempts and this:

Firstly that map does not necessarily reflect your network’s routing. It is a list of neighbours reported during a neighbour update. I ignore it as it looks nice but is not massively useful. Zwave routing is a bit more complex.

If your network is bad you can try this…

If you have a windows machine or run openHab on a windows machine. Download PC programme from silicon labs.

Take the usb stick and put it in your windows machine with the machine in exactly the same place as you normally have your openhab machine.

Open settings
image

select the port and save

you can now manage your network outside of openHab

First backup NVM
image

Now go to image

image

Now if you select Rediscovery your network will do a heal. When it is finished run a network health check. If good close down the program or look around and see what else you can do. If not this tool is good for sorting it out. Ping back if you have issues.

Take the usb out when you have finished and put it back in openHab machine and restart openHab. That little map thing will still be as useful as a chocolate teapot but if your nodes are all in range of each other and everything is working don’t worry. You can always look at the topology in PC programme.

Which is loaded from the nvm.

Enjoy

Robert

3 Likes

I’ve used this software before but I can’t find where I downloaded it to and I can’t seem to download it from Silicon Labs. Can anyone suggest where I can download it? Google isn’t helping at moment…

Problem solved! I had to agree to the SIlicon Labs terms and conditions first by downloading their SDK, this then gave my account the necessary privileges to download the PC Controller software.

Obvious… /s

Pleased you fixed it.

Remember that unless you have issues with heal in openHab it is a lot of hassle so I am not saying not to use heal in openHab. This is suggested as a workaround if it is not working.

It stopped working for me at around 120 physical devices but many things on a zwave network become interesting at that number of nodes.

I speculate it was at that point that the underlying traffic on the network from reports from devices clashed with the rate of the discover neighbours sent by openHab.

OR

Possibly also time it takes to rediscover neighbours goes up as the count of nodes goes up and it started to exceed the time openHab is set to consider too long.

Certainly started to see timeouts.

Anyway hope it works for you.

I thought I’d try this program as well, seems like a good tool for managing z-wave. I fail on the first step however. The one where I should select which port my Z-stick is in. The list is simply empty. Tried putting the stick in different USB ports, clicking the detect and refresh buttons etc, just nothing. Anyone knows what to do? Do I need to install any special drivers? It’s a Aeotec Z-stick S2.

edit: Ha! Found them! After a looong time of looking. For anyone else looking: https://www.silabs.com/products/development-tools/software/usb-to-uart-bridge-vcp-drivers

1 Like

Dumb question… can someone paste a link to this tool on the silicon labs website? I’ve downloaded a few different tools but can’t seem to find this windows utility

TIA!
Dave

@dbadia

You can find a link in this topic. (above the first picture!)

EDIT: If you want to download it directly from Silabs, then use this manual.

The latest version of Z-Wave PC Controller is 5.39 !

1 Like

Thanks for adding that link @Celaeno1

@dbadia another and longer guide is here https://forum.fibaro.com/topic/29923-tutorial-z-wave-diagnostics-with-pc-controller-and-zniffer/

1 Like

This is getting good :slight_smile:

I ran the network heal, but I didn’t see a map like this. From what I can tell in the log, it looks like the heal completed successfully.

Unrelated… when I tried to do an NVMbackup, I got this error
image

Anyone else get this error? I wondering if my stick (Aeotec Gen5 ZW090-A) is on the fritz…

The good old Aeotec. The slight odd boy among z-wave plus.

It is an older SDK and they may well not have implemented all of the options. I think Aeotec have their own utility but not definite. Someone may chip in but it may also be worth talking to them and seeing if they have a firmware that does or their own tool.

That mao is on a different tab and you need to press the reload button. This button calls the API and the controller passes the current topology to the PC Controller Program. On first visit it will be blank.

Aeotec has a backup utility. See this Link: https://aeotec.freshdesk.com/support/solutions/articles/6000108806-z-stick-gen5-backup-software.

Aeotec use an old firmware and don’t (as far as I know) have anything newer (at least last time I spoke to them about this which was a few months back now, but at that point they had no plans to update it).

1 Like

Thanks, I think I’ve actually used that in the past. Probably time for me to run another backup

With links hidden for “members only” :frowning:

Typical Fibaro. I finally lost it with them when they changed so you could not have root access other than by break.

but also they were getting so many chinese bots and also warranted and unwarranted criticism.

We do need something on this end. I will add it to my lists of things to cover. I am sure Thomas will give me permission to do a bit of cut and paste.

Does the UZB stick work with the zsniffer?

UZB3 is very well tested as a zniffer and flashes without issue. It is the same hardware (other than the colour of case) as the official zniffer that comes with the dev kit.

digikey or mouser sell but make sure if you are a
US user you buy one with -U in the product code
Ia european user you want -E inthe product code

etc etc

They will work across areas as the SAW filter only removes about 40% of signal strength between E and U but it is daft to suffer shorter reception. As they do not transmit you would not break any local regs if you used a zniffer of the wrong area in desperation.

1 Like

FYI https://z-wave.me/webinar-z-wave-network-diagnostics-with-z-way-controller/

2 Likes