[SOLVED] Z-Wave unreliable in 2.5.0.M4


Ok, thanks. :slight_smile:

It seems to be different, but the result is the same. The nodes weren’t healed.

I’ve never had this before, but after update from 1486 (02 Jan 2019) to 1731 (20 October 2019).

I have 5 Danfoss Thermostat valves … battery powered, not listening and even not frequent listening. But those valves are working correctly, I mean no errors/issues in my logs. Last heal is always as expected

What is the issue?

Then you don’t have any.

Did you make an update from xxxx to 1733 or an installation from scratch?

Last updates:

  • from 1657 yo 1712
  • from 1712 to 1731
  • from 1731 to 1733

Then I don’t know, why I have the problem since updating from 1486 to 1731. Maybe because 1486 was before reintegrating ESH into OH-Core and 1731 is after reintegrating ESH into OH-Core? Maybe the step is too big?

1 Like

I remember I had some issues upgrading from 1502 to 1524:

But a soft reset did the trick.

On the other hand, sometimes in the past I had issues with my Danfoss valves … :frowning: unfortunately.

Now it’s quite stable. Do you have a chance to rollback, backup, install from scratch the 1733, then recover the backup?

1 Like

I’ve read your topic now.

I also get REQUEST_NIF (from time to time).
I also did a soft reset, and I also removed things from PaperUI and readded them. But I gave them the same thingID. Did you take a different thingID?

better to remove from PaperUI and verify that also the file in zwave folder is removed.

Then rediscovering the thing, you’ll have a new thingID, if I well remember.

Consider that was my first approach … then in some cases I did also a hard reset (removing the thing from openHAB and also from the USB key, then including again)

Yes, that’s right, but I’ve overwrote it with the old thingID, because I didn’t want to change my .items file.

item file? you are not using PaperUI to link items to thing?

anyway I would try with a new thingID and see what happens … you did a very long jump from my perspective

1 Like

No, I use .items file.

Ok. I’m going to try it, but not today. I’ll keep you informed.

1 Like

this is another difference between our implementations … I use items only with Binding like HTTP … with Zwave I use generic items, then I link the items to thing in PaperUI

I link ALL items via .items file.

Here is my neighbor map, according to last heal (see above):
It is very strange!

node1=controller, node2=repeater
node3 und node7 are downstairs.

GREEN = sees neighbor
RED = DOES NOT see neighbor

node 8,9,10 are the “problem nodes”!

Did you delete the OH Things (except the controller) and re-add? They will keep the same IDs but get new binding information.

1 Like


Originally I just updated. After finding the problems with the healing, I have deleted all zwave things (via PaperUI), also the controller, and have added these again using the previous ThingID.

Will try the same using a new ThingID.

I now have deleted all zwave things (via PaperUI), also the controller thing, and have added these again using a new ThingID. Same result. Healing of nodes 8, 9, 10 ("non listening nodes) FAILED. The result is even worse. No manual healing is possible anymore. I could post the DEBUG.log here if anyone cares. If not, no matter.

You can’t run a heal on a node unless it has been fully initialized? Are you sure it completed initialization?

There are new xml files in zwave folder. All information inside, but “last heal time”.

All channels of the things are getting new values (motion, tamper, temperature, illuminance, battery), all OK.

Where else should I look?