[SOLVED] Zigbee not working (ember)

Tags: #<Tag:0x00007f617e930440>

Platform information:

  • Hardware: raspberrypi 3b+
  • OS: openHABian 2.5.1-2 (Release Build)
  • Java Runtime Environment: openjdk version “1.8.0_222”
  • openHAB version: openHAB 2.5.0 Release Build
  • Zigbee Binding: binding-zigbee - 2.5.1
2020-02-04 18:50:29.395 [ERROR] [converter.ZigBeeConverterSwitchLevel] - 00158D000360B10E: Error opening device level controls
2020-02-04 18:50:29.399 [INFO ] [ng.zigbee.handler.ZigBeeThingHandler] - 00158D000360B10E: Channel zigbee:device:0137F24C:00158d000360b10e:00158D000360B10E_1_dimmer failed to initialise device

Has anyone any ideo on this?

Did you follow the binding instructions for when things do not appear to be working? Debug logs posted here can help

log.txt (414.3 KB)

I put the log-file to the attachemnt. It is just to big to post. Which point do you mean in the bindings description?

Do you have any idea what the device is?

The error simply means that the binding did not receive a response when trying to configure the device.

The last one.

@Bruce_Osborne ok the last one is where I got the posted logfile from.

@chris devices:

Stick: Bitronvideo ZigBee USB Funkstick für QIVICON Home Base 1 und S
Bulb: innr RB 248 T

EDIT: maybe this helps to, it is maybe java related:

2020-02-04 11:57:39.027 [WARN ] [mmon.WrappedScheduledExecutorService] - Scheduled runnable ended with an exception: 
java.lang.NullPointerException: null
	at org.openhab.binding.zigbee.handler.ZigBeeCoordinatorHandler.initialiseZigBee(ZigBeeCoordinatorHandler.java:417) ~[?:?]
	at org.openhab.binding.zigbee.handler.ZigBeeCoordinatorHandler.lambda$2(ZigBeeCoordinatorHandler.java:535) ~[?:?]
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) ~[?:1.8.0_222]
	at java.util.concurrent.FutureTask.run(FutureTask.java:266) ~[?:1.8.0_222]
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180) ~[?:1.8.0_222]
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293) ~[?:1.8.0_222]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:1.8.0_222]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:1.8.0_222]
	at java.lang.Thread.run(Thread.java:748) [?:1.8.0_222]
1 Like

I would suggest to ensure you are using the latest binding. If the problem persists, then let’s discuss further, but I think it could be fixed if you use a new binding.

ok. I did reinstall the binding (with reboot of the reaspberry). It is still not working. The binding version is 2.5.1. I removed the bulbs, did reset them, added them again. But no reaction when I change e.g. the status of the levelcontrol.

Please upgrade to the latest version - you are still using the same 2.5.1 that you mentioned in your first post. You will need to update to the snapshot version.

1 Like

h, ok. I will do that on the weekend or maybee tomorrow. Can you tell me how I would stop the logging, mentionend in the end of the bindings description? My logfile gained 5 or 6 MB in the last 30 minutes.

You should just change the level to INFO or to ERROR - so reversing what you did to enable DEBUG logging,

Hi. Unfortunately the script skips the installation of the snapshot version after two minutes. Here is the result, any idea?

This is the current file situation:

EDIT: What I did was:

  1. uninstalled the zigbee binding 2.5.1 via openhab:8080
  2. copy the .sh file to the addons directorry
  3. chmod 777 on addons to prevent permission errors
  4. started the script by: sudo -E -u openhab bash zzManualInstaller.sh

@5iver any ideas on the script?

Run the script again using option 2 when selecting the zigbee libraries. TMK, Chris has not instructed you to use the snapshot version of the libraries, which are actually coming up with an older version 1.2.9) than the pre-openHAB release version (1.3.0).

Running the script again should resolve things, but if not, what is returned when you execute this in the console…

openhab> list -s | grep zigbee
327 x Active x  80 x 2.5.2.202001250518      x org.openhab.binding.zigbee.cc2531
328 x Active x  80 x 2.5.2.202001250519      x org.openhab.binding.zigbee.xbee
329 x Active x  80 x 1.3.0                   x com.zsmartsystems.zigbee.dongle.telegesis
330 x Active x  80 x 1.3.0                   x com.zsmartsystems.zigbee
331 x Active x  80 x 1.3.0                   x com.zsmartsystems.zigbee.dongle.ember
332 x Active x  80 x 1.3.0                   x com.zsmartsystems.zigbee.dongle.xbee
333 x Active x  80 x 1.3.0                   x com.zsmartsystems.zigbee.dongle.cc2531
334 x Active x  80 x 2.5.2.202001250519      x org.openhab.binding.zigbee.telegesis
335 x Active x  80 x 2.5.2.202001250518      x org.openhab.binding.zigbee
336 x Active x  80 x 2.5.2.202001250519      x org.openhab.binding.zigbee.ember

What do you get when you run ls -alh? Specifically, I’d like to see the file sizes.

What do you see in the openhab.log while the script was running?

2 Likes

ok, installing did work now.

gives:

gives:

I have two bulbs running. Third Innr bulb, it doesn’t find. Two aquara sensors it doesn’t recognize and two osram smart plugs it doesn’t find.

Last logentries are:

2020-02-05 15:02:17.247 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing 'zigbee:device:0137F24C:00158d00036195da' to inbox.
2020-02-05 15:09:41.204 [WARN ] [mmon.WrappedScheduledExecutorService] - Scheduled runnable ended with an exception: 
java.util.concurrent.RejectedExecutionException: Task java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask@1335e66 rejected from java.util.concurrent.ScheduledThreadPoolExecutor@10cc958[Terminated, pool size = 0, active threads = 0, queued tasks = 0, completed tasks = 46]
	at java.util.concurrent.ThreadPoolExecutor$AbortPolicy.rejectedExecution(ThreadPoolExecutor.java:2063) ~[?:1.8.0_222]
	at java.util.concurrent.ThreadPoolExecutor.reject(ThreadPoolExecutor.java:830) ~[?:1.8.0_222]
	at java.util.concurrent.ScheduledThreadPoolExecutor.delayedExecute(ScheduledThreadPoolExecutor.java:326) ~[?:1.8.0_222]
	at java.util.concurrent.ScheduledThreadPoolExecutor.schedule(ScheduledThreadPoolExecutor.java:533) ~[?:1.8.0_222]
	at com.zsmartsystems.zigbee.database.ZigBeeNetworkDatabaseManager.saveNode(ZigBeeNetworkDatabaseManager.java:271) ~[?:?]
	at com.zsmartsystems.zigbee.database.ZigBeeNetworkDatabaseManager.nodeUpdated(ZigBeeNetworkDatabaseManager.java:233) ~[?:?]
	at com.zsmartsystems.zigbee.ZigBeeNetworkManager.serializeNetworkDataStore(ZigBeeNetworkManager.java:327) ~[?:?]
	at org.openhab.binding.zigbee.handler.ZigBeeCoordinatorHandler.serializeNetwork(ZigBeeCoordinatorHandler.java:1032) ~[?:?]
	at org.openhab.binding.zigbee.discovery.ZigBeeDiscoveryService$2.run(ZigBeeDiscoveryService.java:250) ~[?:?]
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) ~[?:1.8.0_222]
	at java.util.concurrent.FutureTask.run(FutureTask.java:266) ~[?:1.8.0_222]
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180) ~[?:1.8.0_222]
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293) ~[?:1.8.0_222]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:1.8.0_222]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:1.8.0_222]
	at java.lang.Thread.run(Thread.java:748) [?:1.8.0_222]
2020-02-05 15:09:41.205 [WARN ] [mmon.WrappedScheduledExecutorService] - Scheduled runnable ended with an exception: 
java.util.concurrent.RejectedExecutionException: Task java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask@a730d5 rejected from java.util.concurrent.ScheduledThreadPoolExecutor@10cc958[Terminated, pool size = 0, active threads = 0, queued tasks = 0, completed tasks = 46]
	at java.util.concurrent.ThreadPoolExecutor$AbortPolicy.rejectedExecution(ThreadPoolExecutor.java:2063) ~[?:1.8.0_222]
	at java.util.concurrent.ThreadPoolExecutor.reject(ThreadPoolExecutor.java:830) ~[?:1.8.0_222]
	at java.util.concurrent.ScheduledThreadPoolExecutor.delayedExecute(ScheduledThreadPoolExecutor.java:326) ~[?:1.8.0_222]
	at java.util.concurrent.ScheduledThreadPoolExecutor.schedule(ScheduledThreadPoolExecutor.java:533) ~[?:1.8.0_222]
	at com.zsmartsystems.zigbee.database.ZigBeeNetworkDatabaseManager.saveNode(ZigBeeNetworkDatabaseManager.java:271) ~[?:?]
	at com.zsmartsystems.zigbee.database.ZigBeeNetworkDatabaseManager.nodeUpdated(ZigBeeNetworkDatabaseManager.java:233) ~[?:?]
	at com.zsmartsystems.zigbee.ZigBeeNetworkManager.serializeNetworkDataStore(ZigBeeNetworkManager.java:327) ~[?:?]
	at org.openhab.binding.zigbee.handler.ZigBeeCoordinatorHandler.serializeNetwork(ZigBeeCoordinatorHandler.java:1032) ~[?:?]
	at org.openhab.binding.zigbee.discovery.ZigBeeDiscoveryService$2.run(ZigBeeDiscoveryService.java:250) ~[?:?]
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) ~[?:1.8.0_222]
	at java.util.concurrent.FutureTask.run(FutureTask.java:266) ~[?:1.8.0_222]
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180) ~[?:1.8.0_222]
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293) ~[?:1.8.0_222]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:1.8.0_222]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:1.8.0_222]
	at java.lang.Thread.run(Thread.java:748) [?:1.8.0_222]
2020-02-05 15:09:41.526 [INFO ] [openhab.ui.paper.internal.PaperUIApp] - Stopped Paper UI
2020-02-05 15:09:41.576 [INFO ] [ebuilder.internal.HomeBuilderServlet] - Stopped Home Builder
2020-02-05 15:09:41.599 [INFO ] [panel.internal.HABPanelDashboardTile] - Stopped HABPanel
2020-02-05 15:09:41.699 [INFO ] [basic.internal.servlet.WebAppServlet] - Stopped Basic UI
2020-02-05 15:09:42.011 [INFO ] [.dashboard.internal.DashboardService] - Stopped Dashboard
2020-02-05 15:10:55.595 [INFO ] [thome.model.lsp.internal.ModelServer] - Started Language Server Protocol (LSP) service on port 5007
2020-02-05 15:10:58.796 [INFO ] [panel.internal.HABPanelDashboardTile] - Started HABPanel at /habpanel
2020-02-05 15:10:58.956 [INFO ] [ebuilder.internal.HomeBuilderServlet] - Started Home Builder at /homebuilder
2020-02-05 15:10:59.406 [INFO ] [openhab.ui.paper.internal.PaperUIApp] - Started Paper UI at /paperui
2020-02-05 15:16:35.057 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing 'zigbee:device:0137F24C:00158d0003a28744' to inbox.
2020-02-05 15:21:03.488 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing 'zigbee:device:0137F24C:00158d00036b4a96' to inbox.

The last two added things are the aquara things, which are recognized as unkown.

1 Like

These can be ignored. They are exceptions that are thrown when the system shuts down. It’s fine and not a problem.

1 Like

Thx, I always wanted to fix those.

Ok, so far up and running:

3x Innr bulb
2x Osram smart plug

not runinng:

aqara sensors

Is there any reason you are not using the stable 2.5.8 version?

I can’t see your previous post here, so am not sure what Null Pointer you’re referring to? :confused: Please can you post the exception you’re getting.

1 Like

That post is from 7 months ago - and not from you :confused: . Looking at the code, if you have this exact exception then you must be running an old version since the line numbers no longer tie up with this exception.

Please can you post YOUR exception and YOUR environment so we can understand your problem rather than someone elses from quite a while ago.

1 Like