[SOLVED] ZWave .things config parameters

I’m trying to setup all my zwave in things files currently (don’t ask - long story why). One issue I’m running into is setting some configuration parameters.

According to this (which is the specific device that I’m trying to setup): https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/677?layout=openhab2new

There is a parameter called ‘config_27_1’ that will set the LED indicator. I want to set that in the .things file like:

    Thing hank_hkzwso03_00_000 plug1 "ZWave HKZW_S003 Smart Plug (17)" @ "Outside" [ node_id=17, config_27_1=1 ]

However - that doesn’t seem to work (paperui doesn’t show the setting and the device certainly doesn’t reflect the change).

Any zwave experts want to chime in and tell me what I did wrong?

You do not set Config Parameters in Things.
Config parameters are optional settings sent to the device, either using HABmin or the Paper UI
The options for that device were entered poorly. Sorry about that. I have just started trying to clean up our database.

That’s what I thought but when I try to do that from PaperUI - I get a 409 conflict and even though it appears to work in HABmin, the device doesn’t change at all (the LED indicator is still the same).

Looking though the log - the ONLY (and zwave is in debug level) message I get is:

08:37:55.234 [INFO ] [est.core.internal.thing.ThingResource] - Received HTTP PUT request for update configuration at 'things/zwave:hank_hkzwso03_00_000:controller:plug4/config' for an unmanaged thing 'zwave:hank_hkzwso03_00_000:controller:plug4'.

Doesn’t look like there is any communication with the node after that (I get some polling stuff on other nodes - but I don’t see any messages being sent to the node).

FYI the first example is plug1 and this one is plug4 - all 4 are the same plugs and they all are reacting the same way

@chris or @sihui any ideas?
By the way, I just updated that database entry to add options to the parameters.

Unfortunately it is not possible to configure ZWave device parameters if you are using .things files. There is a long discussion about why somewhere, but the short answer is that the binding doesn’t know what parameters are configured in a thing file - it just gets ALL parameters. There are then two options - either the binding updates ALL parameters, on ALL devices on EVERY startup (which is a large overhead that would result in hundreds or thousands of commands being sent), or it is done through the UI. Unfortunately OH prevents configuration of devices through the UI if the thing is defined through a file, so this also doesn’t work.

1 Like

Thank you or the explanation.
That means we cannot use text files for Z-Wave things.
What is the best way of backing up Z-Wave devices? I know the network is stored on the controller but I am sure they fail sometimes too.

No - it means that if you use text files, you need to use other software to configure the devices.

I know - that’s not a nice answer, but this is a restriction imposed by the system. Somewhere there is a long discussion about this…

Don’t search for it. What are the best backup options for zwave?

I’m only aware of one, and that is an Aeon tool. There may be others out there, and I keep meaning to add backup to the binding, but it’s not something that I’ve currently implemented.

1 Like

Thanks - I was afraid of that but not really a huge issue. I have two instances of openHAB - I can use one instance to dynamically detect/configure the items and the other (production) instance with the files…

The other instance should auto discover the things. The config parameters are set on the devices and should be saved there, I believe.
There would be no need to set the config parameters on both systems.

Yep - understood.

That can be restored to my Nortek stick?

I don’t know it it works through different brands of zwave sticks and I did not try that software yet, but yes, from what I read it should work.

I’m not sure what firmware is in the Nortek stick, but there is a standard API so if it’s a reasonably new firmware it should work.

You had mentioned that my USBZB-1 had old firmware, hence my question.

That was specifically in relation to a conversation about ZigBee dongles where from memory the firmware is version 5.8 (latest firmware is 6.6) and I know there is no bootloader to update it.

I’m not sure what firmware the ZWave interface has on this dongle.

1 Like

I beleive @5iver has reported successfully backing up and restoring the Zwave on the USBZB-1 using the Aeotec software. I could be wrong on that. It requires Windows so I’ve not tried it. I’m basically operating at risk on this front, but I’ve only about a dozen zwave devices so it’s not the end of the world if my controller dies and I have to rebuild it.

But you are correct! I just did this again last week. Not everyone had success though. Make sure to install the latest driver and turn off power management. I think this thread has the most discussion on backup/restore from zstick to quickstick…