Linear HUSBZB-1


(trumee) #1

I am looking to control GE Zigbee bulbs.

This sticks seems to support Zigbee. Does this work with openhab?


HUSBZB - getting zigbee to work / openhabian
Zigbee binding
Contact sensors not appearing
Wave Dome Door Sensor Perpetually Offline
(Rich Koshak) #2

http://docs.openhab.org/addons/bindings/zigbee/readme.html

Probably not.


(Chris Jackson) #3

Yes - both ZWave and ZigBee are supported.


(Rich Koshak) #4

But that particular controller dongle is not one of the ones listed as supported by the Zigbee binding so I assumed the answer to op’s question is that no, this particular controller is no supported by OH. I’d love to be wrong. For that price, I’d replace my Zwave with this combo controller in a second if it opened my OH up to Zigbee support.

And I should have been clear, that only the Zigbee part wouldn’t work. I suspect the zwave might, though you are the expert.


(Chris Jackson) #5

Hey - todays you’re lucky day :wink: .

Well, it sort of is - it has an Ember chip inside and Ember is supported. A few people are using it (@5iver can maybe comment).

Yep - they both work ok.


(Rich Koshak) #6

:smiley: I just added it to my wishlist.

I know the Zigbee binding is still a little bit beta (I don’t know how you find the time).


Absolute new beginner
(Scott Rushworth) #7

I’ve been using one of these for over a month now, and it cost me less than a spare zstick. The zwave chip is the same as a zstick, but the firmware versions are slightly different. However, they have the same libraries, as reported by Zensys Tools. The Aeon backup software can be used with it, and I have done backups and restores across the two. After some recent fixes Chris has done, the zigbee binding is now working very well, except for a possible bug in reporting states accurately (he probably already has it fixed). I have 25 zigbee and ~85 zwave devices, and this stick seems to be able to handle the load just fine. There have been some other’s posting about them on this and other forums too, so hopefully there’ll be more reviews. But so far, it has been a solid piece.


Z-wave Controller: Trying to decide between Vera Plus & Aeotec Gen 5 USB
(trumee) #8

Do you mind listing what zigbee devices you had working with this stick?


(Chris Jackson) #9

No - sorry - I’ve not looked at this one yet (been looking at some other issues) but glad to hear that things are looking stable after the update :slight_smile: .


(Scott Rushworth) #10
  • GE Link A19 (60W)
  • GE Link BR30 (65W)
  • GE Link PAR38 (90W)
  • CentraLite 4257050-RZHAC plugin smart outlet (Smartthings)

(trumee) #11

Any idea of Xiaomi devices would work? They are supposed to be Zigbee as well.


(Scott Rushworth) #12


This thread has a lot of information on the Zigbee binding, including discussions on currently functioning devices.


(Chris Jackson) #13

No - they are not ZigBee devices. They use part of the ZigBee protocol, but don’t fully support it and this causes problems where the ZigBee stack requires certain functionality.


(Justin Huff) #14

I’ve been trying to get this to work as well.

Running the 2.2 snapshot: 2.2.0.201708292017
Seems like it’s talking with the coordinator just fine (Baud rate 57600), but the thing still shows ‘INITIALIZING’.

Here’s the debug logs (I also have these logs with AshFrameHandler set to DEBUG):


(Scott Rushworth) #15

Set com.zsmartsystems.zigbee to debug and head over here with another log from startup…


(Justin Huff) #16

Here you go:


(Scott Rushworth) #17

I bet @chris (Zigbee binding maintainer) could help with this…


(Scott Rushworth) #18

Which version of OH are you running? Have you tried setting Reset to true on the coordinator? This should apply the configuration. I haven’t been able to change settings after the initial setup, so you may want to try deleting the coordinator and starting over. There have been a lot of changes to the binding since I first tried to get my HUSBZB-1 setup, and I haven’t tried starting from scratch since, so I don’t have any personal experience with the initial setup using the current binding, but you might find some helpful info in the Zigbee thread.


(Chris Jackson) #19

I’m not really sure why it’s not creating the network. I have a theory, but I’m not really sure it’s right… I’ll probably make a small change to see if it helps and we can take it from there…


(Justin Huff) #20

@5iver 2.1, but a 2.2 snapshot for the ZigBee binding (2.2.0.201708292017). Yeah, I’ve tried several iterations of remove, restart, re-add (complete with removing the USB device too).

@chris Happy to try whatever.

Thanks!