Linear HUSBZB-1


(Scott Rushworth) #21

UDEV rules for this device can be a little tricky. Here is what worked for me (although I specified an order to them):

KERNEL==“ttyUSB[0-9]", ATTRS{interface}==“HubZ Z-Wave Com Port”, SYMLINK+=“ttyUSB-5”, GROUP=“dialout”, MODE="0666"
KERNEL=="ttyUSB[0-9]”, ATTRS{interface}==“HubZ ZigBee Com Port”, SYMLINK+=“ttyUSB-55”, GROUP=“dialout”, MODE=“0666”

Note: On Linux; the extra Java command-line property is not required if you choose a symlink name that matches a standard Linux comm port prefix and ends with a combination of numerics + non-letters. E.g. “ttyUSB-9999”.


(Mike Bagdanoff) #22

Hey,

I’ve just got one of these and though the aeotec backup/restore of my gen5 zstick seems to work. After I plug it into my OpenHAB machine, the binding only ever finds 1 node, not the 60+ nodes that are supposedly in the backup.

I downloaded the zensys tools and it only ever shows the controller node. Is there a special trick for doing the backup/restore?


(Scott Rushworth) #23

Nothing special, the backup and restore was straight forward. Hmmm… what was the process. I think I shut the backup tool down after the backup, swapped the sticks, then did the restore. Did you get the latest version of the backup software? I used ZStick G5 BackupToolSetup Ver1.0_0_9 on a Windows 10 laptop. If no nodes are showing after a restore, I would suspect the backup to be the issue. You probably don’t have a spare zstick to test it with, so maybe Aeon Labs support could test it for you to confirm the backup was successful? I’d be willing to do a restore to my spare zstick using your file to see if the devices are in there, but you’re probably and understandably not going to trust a complete stranger from the Internet with your zwave network!

I guess it’s possible Nortek updated something, but I would expect a firmware update available if they had. You could compare the version of the libraries between the zstick and quickstick in Zensys Tools. Mine were identical. This is my zstick:

image


(Mike Bagdanoff) #24

That is what my zstick looks like, the husbzb-1 has the identical libraries, but it’s z-wave device firmware is 4.05. I’ve tried the backup / restore on a different machine and it the whole process seems to succeed but the husbzb-1 is still un-restored. Does your husbzb-1 have a firmware version of 4.05?


(Scott Rushworth) #25

Yes. Did you use the Windows driver or download the one from Silabs?


(Mike Bagdanoff) #26

there doesn’t seem to be a compatible win10 driver inbox or from silabs, I had to get the one from axialcontrol.com (Zigbee binding) to and disable driver signature verification.

The silabs driver doesn’t support my devices PID (USB\VID_10C4&PID_8A2A&MI_00). I’ve tried forcing the silabs driver to install on the port, and though it works fine, the restore still does nothing.


(Michel Lesoinne) #27

I received a HUSBZB-1 stick on Friday. I also have a Zstick G5 and thus am very interested in this thread.
I will start playing with it tonight.
I do not own any PC or license to Windows (so running VMWare or such is also out of the question).
I only have a Mac desktop and laptop and a headless Intel Linux box.
Is it possible to do the backup-restore on something else than a Windows PC?


(Scott Rushworth) #28

(use the one without serial enumeration)
https://www.silabs.com/products/development-tools/software/usb-to-uart-bridge-vcp-drivers

I’m pretty sure I just manually installed the driver instead of running the setup. This is probably the same version as you’re running though. These instructions say to unplug the stick after the restore and plug it in again to initialize changes. Maybe you’re missing that step? The only other thing I can think of is that I was using a local admin account on my laptop and I’m on Win10 x64. If you can’t figure this out, you can set the quickstick up as secondary and then shift it to primary. If you use a Minimote, check out this thread…

It looks like Aeon Labs only has backup software for Windows, but you can do as I just suggested instead of doing a backup/restore. I use Zensys Tools for the primary shift, which is also a Windows app, so you will need to find some other software that can do the primary/secondary shift.


(Mike Bagdanoff) #29

those are the ones I’ve tried, just to be sure I’m redownloading and reinstalling these drivers (since the PIDs in the INF don’t match my device, I’m forcing it to install the driver.

restoring it does do something at least, though all I can see is that it changes the Network Role from RealPrimary to None.

What is the PID of the device you are using? Mine is 8a2a


(Mike Bagdanoff) #30

I do notice that when I run the zensys tool with the nortek stick, this shows up in the log:

01:20:49.057: Exception: CmdZWaveEnableSuc is not implemented in the Z-Wave Device

so I’m not sure if that is normal or a sign of a bad stick.


(Scott Rushworth) #31

I plan to add a couple devices tonight, so I’ll check once OH is offline (quickstick is in a Fedora box).

I’m pretty sure I remember that too. Will confirm.

Were you unplugging/plugging the quickstick after the restore, as the instructions instruct? In thinking through all the possibilities, I thought of two more things. There’s an enable/disable checkbox in the backup tool. I believe I read this locks the device for editing, so make sure it is unchecked for the quickstick when doing the restore. The other thing is that I’m pretty sure I had done a reset of the quickstick in Zensys Tools before doing the restore. Maybe that helped me to be able to do the restore.


(Mike Bagdanoff) #32

Yeah, unplugged it after each restore, waited about 1 second and replugged.

I think this is the best indicator that something is wrong with the stick, all that happens if I click that checkbox is an “exclamation” popup dialog that says Set Config Enable Error. I get similar errors if I try the Read Setting button as well.

I’ve tried that as well before each restore. Nothing works. I’ll probably wait until I have a day with the house to myself and go around the house repairing all my devices to the new stick, or I’ll return it.

Thanks for your help


(Mike Bagdanoff) #33

And that was the trick. I followed the steps you laid out in:

and it all seems to run correctly now, though I do get a lot of the following errors:

08:44:17.617 [ERROR] [sage.AssignSucReturnRouteMessageClass] - NODE 75: AssignSucReturnRoute command failed.
08:44:17.623 [ERROR] [sage.AssignSucReturnRouteMessageClass] - NODE 27: AssignSucReturnRoute command failed.
08:44:17.629 [ERROR] [sage.AssignSucReturnRouteMessageClass] - NODE 11: AssignSucReturnRoute command failed.
08:44:17.635 [ERROR] [sage.AssignSucReturnRouteMessageClass] - NODE 30: AssignSucReturnRoute command failed.
08:44:17.642 [ERROR] [sage.AssignSucReturnRouteMessageClass] - NODE 43: AssignSucReturnRoute command failed.
08:44:17.648 [ERROR] [sage.AssignSucReturnRouteMessageClass] - NODE 95: AssignSucReturnRoute command failed.
08:44:17.654 [ERROR] [sage.AssignSucReturnRouteMessageClass] - NODE 79: AssignSucReturnRoute command failed.
08:44:17.660 [ERROR] [sage.AssignSucReturnRouteMessageClass] - NODE 29: AssignSucReturnRoute command failed.
08:44:17.666 [ERROR] [sage.AssignSucReturnRouteMessageClass] - NODE 12: AssignSucReturnRoute command failed.
0

but everything seems to work. It was scary wiping my zstick but it looks like the backup I took did work so I’m able to swap it back in if the quickstick dies.

now on to fiddling with zigbee, I think I have a long thread to read through


(Scott Rushworth) #34

I see a lot of these too. But I also saw them on the zstick.

Other than the main Zigbee thread, there are a few threads from people trying to setup Zigbee on the HUSBZB-1.

I added a couple more devices tonight, shutdown OH, and put the quickstick in my laptop. I also get these errors, so not a sign that the stick is bad or a lead to why the restore wasn’t working.

My PID was also 8A2A.

In a support ticket from Aeon Labs, I had asked about restoring to the quickstick. In response, the tech included this in his reply “It pretty much a save state, so if the controllers NodeID is 51, thats what the backup file would have saved.” If the backup is just a memory dump of the nodes in the network, maybe the restore worked for me because I already had the quickstick in the same network (same as you have now done) when I tested the restore. Once I knew I had a good backup of the zstick, I played with so many things that it’s a little cloudy how exactly I got to the point to where I could backup/restore between the sticks. But you might have success with the restore now that it’s on the same network. Anyhow, glad you got the zwave migrated!


(Chris Jackson) #35

Can you give me a list of a few of these - I’d like to check something as I have a better understanding of the routing now…


(Scott Rushworth) #36

I posted the log in a ticket on your website.


(Chris Jackson) #37

Thanks, but…

In this case, contrary to my usual stance, I don’t think the log will tell me much more than the request failed. What I’m interested to know is if there’s anything common about the devices that fail - are they battery devices, or a specific type of mains device, or… Is it always the same devices that fail, or does it work with some devices some times and not others?

I believe that some devices will not work with this request for starters, and I probably need to stop sending it to some device types…

(I will take a look at the log when I get a chance though, but about to go on holiday for a few days on the way to the SmartHome event at the weekend).


(Scott Rushworth) #38

My files rollover about every 1.5 days. In this data set, it does not look like this affects a specific device model (some devices of a specific model got the error and some did not). However, the devices receiving this error were all mains powered devices, and it was a large percentage of them. There was also one node that is not in OH that got the error… I’ll need to check to see if it is on the stick next restart. It does not appear to be the same devices each time, but I could try to confirm this, if you’d like something more concrete.

I put this all in a spreadsheet, if it’s of any use, including the following errors (the data was filtered on ‘failed’):
Assign return routes failed.
Assign SUC return routes failed.
AssignReturnRoute command failed.
AssignSucReturnRoute command failed.
Delete return routes failed.
Delete SUC return routes failed.
DeleteReturnRoute command failed.
DeleteSUCReturnRoute command failed.
NodeNeighborUpdate FAILED


(Chris Jackson) #39

Yes, it would be really interesting to get an idea of what these nodes are to see if it ties in with my suspicions. I don’t want to ask you to do too much on this, but if it looks like it’s always/mostly the same set of devices, it would be interesting to get the list of which ones you think they are…

Thanks.


(Mike Bagdanoff) #40

Turns out no. The backup is good because I restored my ZStick after the migration procedure and its fine. I noticed that during the migration I lost node19 somehow so I tried restoring the Quickstick but it just wiped it. I redid the migration and luckily all the nodes transferred this time.