Sonos - Communication error after speaker firmware update

After i updated my Sonos Play:3 firmware to latest version, my openhab sonos-binding stops working.

System information:
OpenHab 2.4.0 Release Build
Sonos-Binding by Karel Goderis
Env: OpenHab runs as a docker-container with Java 1.8 on a Ubuntu LTS system.
Sonos-Player Firmware: 10.4 (Build 521369030)
Network: OpenHab and Sonos-Player are on same subnet and so UPnP has just 1 hop

Status of my Sonos-Thing: OFFLINE - COMMUNICATION_ERROR Der UPnP Speaker RINCON_5CAAFD561A4C01400 ist nicht registriert.

2019-10-24 10:37:10.619 [hingStatusInfoChangedEvent] - ‘sonos:zoneplayer:67897788’ changed from UNINITIALIZED to INITIALIZING
2019-10-24 10:37:10.630 [hingStatusInfoChangedEvent] - ‘sonos:zoneplayer:67897788’ changed from INITIALIZING to OFFLINE (COMMUNICATION_ERROR): Der UPnP Speaker RINCON_5CAAFD561A4C01400_MR ist nicht registriert.

I have restartet openHab, reinstall the sonos-binding and recreate the sonos-things - without success.
In the settings of the Sonos-App, media-server and upnp-server is enabled.

No idea, why the binding is no longer working with the latest sonos-firmware. Before the Speaker-Update it worked fine.

Has anybody same issues or hints to solve this?

I believe your issue is tied to this issue. I have the latest Sonos firmware updates also.

Mine still fall off the network after 24 - 48 hours.

Best, Jay

Bounty Created:

Best, Jay

1 Like

Similar Problem here, even though without Sonos upgrade.
I just updated my Raspberry and out of the blue, the Sonos binding stopped working. Error code similar to above, the UPNP device cannot be found.

It is not the dreaded TTL problem as described elsewhere, because the Sonos system is on the same subnet and when using tcpdump, I can see the upnp packets coming in. A different application on the same RasPi can communicate with the Sonos system just fine.

I tried upgrading openHab from stable to testing, to no avail. Also de- and reinstalling bindings and things and restarting both openhab and the Pi did not help.

What puzzles me is that it just stopped working without warning. Must be something in openhab that suddenly broke…

If your running the Samsung 2.5.x binding; then this is the issue causing it.

Best, Jay

The JUPnP problem is for users using the SamsungTV binding.

@Stefan_Max : what’s your Sonos version? I am still running 10.6.1 and you? I see that a new version is available.

A version 11.0 is apparently available.

I’m running the Sonos 11.0 version w/o any issues and using the Samsung 2.4 binding also w/o any issues.

I am running Sonos 11.0, I am not using any SamsungTV binding.
Just out of curiosity, I installed the patched 2.6.0 uPNP, to no avail.
As opposed to some setups, my Sonos system is not found at all. It never comes online in openhab.

I have been using a http api based on node.js which discoveres the Sonos just fine. I’ve actually been able to integrate it into openhab with http requests. :slight_smile:

Ok I can confirm the version 11.0 is ok with the binding.

@Stefan_Max: as I understand, your problem is relative to UPnP no more working in your RPI? You say you updated your RPI but not exactly if you changed OH version?

No, UPnP is working fine, other programs on my RPI can find the Sonos system just fine (see the link above).

I was running openhab stable 2.5 and did not change that when Sonos stopped working. I did, however, apt upgrade the RPI in the meantime because I installed other programs on the Pi. I assume something broke back then.

I upgraded to the latest milestone release today, hoping it might fix it, but it didn’t.

What’s puzzling me is that really only openhab in combination with Sonos is showing this strange behaviour.

Follow-up: I gave up and reinstalled raspbian-lite and openhab today. Now everything works again. Must’ve broken some setting on the pi at some point while messing around.

Another follow-up: After the Sonos binding worked nicely after my re-install, it broke again today. Only thing I changed was disabling IPv6.
Re-enabled it: Works again.

Apparently the binding needs IPv6 on a Raspi to work.

I have the same issue. How can I check if IPv6 is enabled or disabled?

I checked with ifconfig that ipv6 is active, but Sonos is not working. Do I need to install everthing from scretch?


I had the same problem as described above but found a (up until now) stable workaround.

I used to connect to sonos and then integrated it via the OH MQTT Broker & Binding back into my environment.

I’m running sonos2mqtt & OH inside docker.



Thanks for pointing me to sonos2mqtt, very nice.

How have you setup your MQTT things? Can you have tts play on the sonos devices that way?

My sonos Setup is also not found by the sonos binding on OH3…