Spirit z-wave radiator thermostat temperature reporting

zwave
Tags: #<Tag:0x00007f0142b98ad0>

(Wolfgang Rosenauer) #1

Hi,
I just installed a Spirit z-wave radiator thermostat https://eurotronic.org/wp-content/uploads/2018/08/Spirit_Z-Wave_BAL_web_DE_view_V5.pdf while I’m running openHAB 2.4.0 SNAPSHOT.
When I installed it everything seemed to work quite ok but after a day the device (or openHAB) does not communicate the current temperature or actually it probably does but not on request (aka when I update something like target temperature) and also given that it should report a temperature difference of 0.2° itself the last temperature change even was 17 hours ago and I’m sure the temperature changed more than that in the meantime.
I also enabled z-wave binding debug logging but I’m not sure what I need to look for.
Any hints?


Which Z-Wave Radiator Valves (TRVs)?
Problems/experiences with Eurotronic Spirit radiator valves
(HomeAutomation) #2

I had the same with one of my devices. I tried everything to fix it. At the end I replaced it with a new one.

What version of the firmware do you have? The bad one has firmware 0.15 the working one’s 0.16. Maybe this is the case.


(Wolfgang Rosenauer) #3

Thanks for your feedback. Firmware is 0.16 though.


(Wolfgang Rosenauer) #4

image

Settings wise everything looks ok to me. I changed the default from 5 to 2 to get a more frequent update on changes but to no avail.


(Wolfgang Rosenauer) #5

Found the earlier thread:

I will try full exclusion/inclusion cycle with removed batteries as well now.


(Wolfgang Rosenauer) #6

After I removed the thing and added it back (after removal of the batteries) it works at the moment.
I’m curious for how long though.


(Wolfgang Rosenauer) #7

The problem seems to persist.
I got three update events within the last 5 hours but the last one already three hours ago and the temperature must have changed more than 0.2° in the last three hours. So I guess I’m back again to the issue.
Really not sure where this is coming from but tend to ask the vendor and probably ask for a replacement unless anyone has an idea.


(HomeAutomation) #8

This is exactly what I have seen. If it does not work, no chance to get it work again. No battery removal or reset helps. I replaced it and the new one is working as expected.

I thought it comes from the fireware version, but you have the same as I have now. It looks like it is the device itself which got broken. Not related to firmware


(Wolfgang Rosenauer) #9

I got a second one now since I needed to replace another thermostat.
And also to compare if that one works with regards to temperature reporting. Unfortunately it shows exactly the same behaviour :frowning:
So either they are all a bit broken or something is fishy.
Can someone please confirm if there is any chance that openHAB has some part in this issue? I wouldn’t expect so since the z-wave binding does not report any report from the device so I would expect that it does not send anything?

I asked the vendor inbetween as well if they have any idea but they were just suspecting a display issue which I disagree with receiving no z-wave events in the log at all.

Any ideas/proposals what to check?


(HansB) #10

Sorry Wolfgang, I have three devices and they seem to reporting the temp just fine. I did manage to set the mode to Manual (directly controlling the valves) and this might have an effect?? I don’t no. But I also have no real use for the temperatures reports, because they are too close to the radiator. I have one that is underneath a desk, in a corner. And the temperature there gets very hot, very fast compared to the rest of the room.

I have a lot of aqara temp sensors. They are cheap, work very well (reporting temp changes) and can be placed on strategic places. So I use them to trigger the valves to open.

Edit:
I run the stable openhab 2.4 (with a slightly hacked zwave binding)


(Wolfgang Rosenauer) #11

Thanks Hans_B,
I agree that the temperature sensors directly at the valve are not perfect. I tried to get around of buying yet another sensor for the moment though.
I tried to Google aqara sensors but not sure. Do you have a pointer? I only found Zigbee sensors. Or are you referring to Zigbee?

FWIW, I found on the FHEM forum a post from someone else who found issues with temperature reporting. But it seems I cannot confirm the finding from there:
https://forum.fhem.de/index.php?topic=77598.30
And another one indicates that only a setting of 1 for the temperature reporting works for people:


So I’ve set mine back to 1 (from 2) without much hope since I was running with 1 for some weeks already.
But seems to be confirmed in yet another thread:

(Just putting references here in case others run into the same issue.)


(HansB) #12

I am indeed referring to Zigbee. It’s a chinese brand, and you need a Hub (gateway) that communicates with Openhab. (but the Hub can be blocked from using internet) But they work great, and I have a lot of buttons, door and temp sensors. So I prefer the cheap options

Here the link to the binding


(Dominik Jeziorski) #13

I remember that there was a problem reported on some german forum that only value 5 works correctly (it means report temperature only after the change by 0.5C) all other parameters were causing issues. I believe that it wasn’t OpenHab but some other tool for home automation.

In my case, the only changed properties I have is:
“6: Valve opening percentage report” set to 1
and
“1: Lifeline” set to controller

in “5: Measured Temperature report” I still have default 5.
Spirit doesn’t have a way to force push data like every 60 sec. I started to live with that one and assumed that the temperature hasn’t changed. Aquara temp monitor also works in such a way that it reports new temperature only if the change happened. Otherwise, you should assume that it is same as last reported.

The graph with such setup looks like one below. For a small bathroom, it seems to work more or less properly. I’m in the middle of grabbing the Aquara temperatures so I will know what are the real values are.