SRT321 identified as SRT323

Tags: #<Tag:0x00007fc8f9def188>

Hi,

I just started with z-wave in order to control some electrical radiators. The setup is a Z-wave.me USB controller, two Fibaro FGS-231 switches and two SRT-321 thermostats.

The FGS-231 are then connected to a three-phase relay that controls the radiators. One for the ground floor and one for the first floor.

As I understand there is a possibility to have the SRT-321 control the FGS directly (associations groups) so that it will not stop working if the controller is offline. The setup is in my vacation house, and sometimes the network goes down won’t get back up until I’m there in person…

I also want to control the SRT321 from openHAB so that I can for example increase the temperature the day before I go visiting.

I got everything setup in a lab environment, and I can connect the different devices with openHAB. The association group stuff does not work yet though…

But the first issue is that the SRT321 is identified by openHAB as SRT323. When I read the docs, it should instead be of the type HRT4-ZW.

Is there someway to change this? Everything got identified automatically and I didn’t see any option to change the type.

I did some more digging and I have a SRT-321 GEN-5. Thee seems to be a number of different versions of the SRT-321.

My device has 6 association channels, compared to 5 for HRT4-ZW and SRT-323.

One version of the manual is available here. It’s not identical to the one that came with my devices, but the contents seems similar.

Please check your xml file in your userdata/zwave folder for that device, it contains the manufacturer, thing id and device id.
You need to check the zwave database if that device is already configured, if not you can do that by following the steps from the database guide.
If you are stuck just ask and post your xml file so another user with edit access to the database may add it.

Thanks for your input. I found the same combination of manufacturer, id & type as SRT323, however it is not the same device. I’d really appriciate some help in getting this one into the database.

XML file: network_d2216334__node_4.xml (13.0 KB)

The association groups are named (in the included docs):
1 - Lifeline
2 - Thermostat Mode Control
3 - Switch Control
4 - Battery Info
5 - Thermostat Set point
6 - Air Temperature

There’s quite a lot of details in the documentation for each group, I don’t know if that’s needed as well. I could put it in the scanner and post it if requested.

If your device is a SRT321 with type and id 0001:0005, this type and id were added to the wrong device in the database (SRT323).
But we need to be careful to not break other users configs.
As the associations groups are already different I guess the configuration options are also different.

Yes, to add the device to the database we need a pdf manual and a product image.

Here’s the manual. I was not able to find the document in digital form, so it’s scanned instead.SRT 321 manual.pdf (673.1 KB)

And here’s a picture:

Thanks. The SRT321 has different associations groups compared to the SRT323, so I decided to make a new database entry for the SRT321 and remove the thing/device id from SRT 323:
https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/989
Also the default value for config parameter 1 is different.
You need to upgrade to the latest 2.5 snapshot zwave binding as soon as the database changes got merged into the binding (usually a couple of days)

Thanks!

where can I find the snapshot binding? (To keep a lookout :slight_smile:).

Right now I’m running the 2.4 testing branch on Ubuntu (which gives the current apt version as openhab2:all/testing 2.4.0-1 uptodate).
Are there any instructions available on how to upgrade to zwave 2.5 snapshot?

https://ci.openhab.org/job/openHAB2-Bundles/modules

Yes, by searching the forum :grinning:

In short: uninstall your current zwave binding, download the snapshot, put it in your addons folder, restart openHAB. Sometimes cleaning the cache and tmp folders is needed.
To be sure you are running the latest snapshot log into karaf and perform:

openhab> bundle:list | grep ZW*
249 x Active   x  80 x 2.5.0.201901051658     x ZWave Binding

Ha, ha - you got me there! :wink:

Thanks for helping me out with the SRT device; hopefully next time I go to my other house I’ll be met with a nice warm environment instead of freezing the first hours :cold_face:.

1 Like