"SSL Handshake failed" after habdroid upgrade


After my Habdroid install got updated automatically to version i’m no longer able to logon to my openhab Cloud instance using the habdroid client.

After opening the openhab App it immediately fails with error " SSL Handshake failed - maybe you need a valid client certificate".

When using wifi (local login) the app works fine, but i also worked fine remotely before the app upgrade.

Please help me in getting my HAbdroid app working again…


I’ve tried this but unfortunately this does not work for me… still the same error

did you try re-installing the app?

If yes, maybe there is an issue that should be filled in: https://github.com/openhab/openhab.android/issues

Check first for similar issues:

thats exactly what i’m running into… :frowning: currently upgrading my Diffy Heineman Parameters to 4096 to see if that helps…

1 Like

Did not make any difference… still the issue which has already been confirmed to be a bug…

I have made some research and everything seems to indicate a problem when using SNI in the server part.

But now for the million dollar question… did you get it working and if so… how :slight_smile:

Hi !

I had same issue after upgrade, then I have marked two options with ignore (hostname and certificate). It works, but each time when I connected via android app I got such notification in my log file:

2017-08-07 11:01:17.695 [WARN ] [org.eclipse.jetty.io.nio ] - javax.net.ssl.SSLException: Inbound closed before receiving peer's close_notify: possible truncation attack?

How to solve it ?


I have the same Issue since I have updated my Android phone to openhab version 2.0.0. The App is only working locally but not remotely.
The old version 1.XXX is still working on my Android tablet locally and remotely.

Ignoring the SSL certificate and/or hostname does not help.
Can anybody help me?

Best regards,

Same issue.
No remote connection of openHAB-app.
Have to do forced stop of the app, before I can connect local again.


found a solution for me here:
I have deleted the app data on my phone and now the remote access is working again :slight_smile:

Best regards,