Synology Diskstation OpenHab Installation for Dummies

I need some help with understanding the general installation.
I downloaded this file:
from this source:
Then i tryed to rename the end from .zip to .spk and install but that dosen’t work.
I then tryed to follow this, (Openhab 1.7 on Synology DS1515+)
but i don’t know what to do with the files in the folder that i unziped. I can’t install that folder as well. And i realy don’t understand where to add the .spk.
can somewone point me in the right direction?
Regards, Novski

The spk should go in your public folder.
Then try to manually install the spk via package manager.

Hi marklavercombe, please don’t get mad about my silly questions but, what is a public folder in your eyes?
I mean is it a folder accessable over WebUI, a folder with access for every user or just a folder named public like that: Volume1/public ?
I don’t see any public folder in my admin accounts File Station right now… (DS115)
And everybody here is writing about a 1.7.xy .spk but i don’t find a .spk file grater than 1.5.0 anywhere and here i only find .zip with a package.tgz inside the .zip (

I realy have no idea what to do. Can you maybe explane more detailed?
Best Regards, Novski

Hi Novski,
No problem.
I used the spk provided by Dominic Spatz ( at this post Synology DiskStation.
When you log in to your server, if you use File Station you should see a list of folders within your Volume on the left panel. This will include a folder ‘public’. This is automatically generated, and you shouldn’t have to make it. It sits alongside your ‘home’, ‘homes’, ‘web’ and other main folders.
If you transfer the spk from above into the public folder, you should then be able to manually install it using Package Center. In your browser logged into your DiskStation, click on Package Center, Manual Install, and then browse to your public folder and then install the spk.
I had trouble using Chrome browser and ended up doing this using Opera.

Hi marklavercombe
I have now made successfuly a 1.7.1 installation and also managed to connect the public folder with my config.

For others here how it finaly worked:
I downloaded the openhab synology .spk file from the link above.
Then i created a public folder by goging in the config panel of my synology.
I also added a OpenHAB and a configurations folder.
The path looked then like that: volume1/public/OpenHAB/Configurations.
Then i just whent to the Package Center and clicked on settings where i set the trust level to Any Publisher. After that i clicked on Manual Installation where i choosen the .spk from my download folder.
The Installation adds a User called openhab witch has to get access to the public folder.
I then had to add the configurations. Witch for first tests i copyed from a previous installation.
You can copy it from the /volume1/@appstore/OpenHAB/configurations if you can login with sshfs root@“YOUR SYNOLOGYS IP ADDRESS” (i can not upload .zip files here)
or another place do get the files:
Ok. but…
It did not work. - Looking in to the log (package center window openhab under the link to your openhab panel) i saw that some java bindings didn’t work. So i whent to Stop one App after the other to find out what prevented it to start and found out that after deactivateing the Webstation it suddenly work.
Allthroug i was not able to replicate that. After geting OpenHAB working i activated the Webstation again and now both work side by side… so hope it stays so…
Regards, Novski

Great! :smile:

You might want to check the Openhab scripts and see what port you have OH on, and then check your Synology settings to see what port WebStation is using.

Maybe they are both using the same port?

Hi marklavercombe
Seams like that that didn’t help. But also that the ports for a synology package are stored on a different place…?
Openhub started again with the same errors in the log.

The Package Center still shows the 8081 link. maybe its stored in a different file for a synology OpenHAB?

Yes, they are. I’m not at a position to access my server, so can’t check.
Is it Check the .sh files in that folder, I think it
might be one with runtime in the name?

I just checked my post at Synology DiskStation and can confirm it is

Hope that helps.

perfect marklavercombe it worked.
I now have access to my openHAB on my own port.
I see that all files i add or change under: volume1/public/OpenHAB/Configurations
are copyed to the path: /volume1/@appstore/OpenHAB/configurations
I didn’t find out how that is done. Im curious…
Are you able to explane how that is being done?