Synology DiskStation

synology
Tags: #<Tag:0x00007f1837c76db0>

(martiniman) #202

Sorry, i have not that error, i only point you to that conversation.


(Holger OpenhabUser) #203

I found the following explenation:
Hard floats use an on-chip floating point unit. Soft floats emulate one in software. The difference is speed.
Ok, but then both variants should work!?
:rolling_eyes:


(jan) #204

Upgrading is a bid the same as installing… Place the zip in the public en run it.
The installer script will move the old openHAB2 folder to openHAB2-bakcup_DATETIME and then install openHAB2 in a new openHAB2 folder. afterwards the script should copy the userdata folder from the bakcup to the new openHAB2 directory.
But that failed for me. so i did the copy myself and after that did a chown -hR openhab2:users openHAB2 and chmod -R u+w openHAB2/userdata
(i think the failing is because the scrip does a copy with -avr and i think the -v is giving problems, but that i have to try with the next upgrade :slight_smile:

In all upgrading is nothing more than replacing the runtime folder with a new folder.

If you have 7zip open the spk file go to the script folder and open installer.sh. search for the postupgrade() and look wat it is doing.


(jan) #205

Look at https://www.synology.com/nl-nl/knowledgebase/DSM/tutorial/General/What_kind_of_CPU_does_my_NAS_have if you’re dutch… search your DS213 and you see if has no FPU … so you need java with a software floating point system.


(martiniman) #206

One more question - i cant edit rules via habmin rule web editor, save button allways disabled, is it happens only with me?


(Holger OpenhabUser) #207

I have the:
DS213j Marvell Armada 370 88F6707 Single Core 1 Ja Armada370 DDR3 512 MB
"Ja" means, it has as Floatingpoint unit.

The installed Java version does not rally say if it is a hard or soft version:

Currently I run my Openhab on my central heating control windows PC, an old ACER One netbook.
This works during Winter time for me, but in summer I want to shut it off. Then latest I have to switch to the Diskstation.
The Acer is already heavy loaded with OH, around 50% CPU load (The Viessdata application only takes about 5%)


(jan) #208

@HolgerL, Should you not be better of with a PI3 PC this is stand alone can run of a 12V battery and has more then enough CPU power.

The DS213j is a 16bit BUS i think this has to do with your error … see http://www.synology-wiki.de/index.php/Welchen_Prozessortyp_besitzt_mein_System%3F

Read this artikel. https://pcloadletter.co.uk/2011/08/23/java-package-for-synology/ if I’m correct this will install or give you the instruction to download the correct java version.


(Holger OpenhabUser) #209

I found this site also, and this is the version I installed! :frowning:
Sure you are right with the PI3, but in the first step I tried to use a Hardware which is anyway running and consuming power. If this in then end does not work, I will add the PI3.


(jan) #210

Then I’m out of ideas what the problem can be… let us know if you solved it.


(Darrell Frappier) #211

The change log at pcloadletter https://pcloadletter.co.uk/2011/08/23/java-package-for-synology/ says:
042 07/Jan/17 – Updated to Java 8u111, fixed Armada 370/XP systems running DSM 6.0 which had switched from soft to hard float ABI

Unfortunately I find his application will only load the soft float version ejdk-8u121-linux-arm-sflt.tar.gz
I have given him feedback and hope he will be able to confirm my report and update his application.

One option I tested is to rename the Oracle package. So when I renamed ejdk-8u121-linux-armv6-vfp-hflt.tar.gz to ejdk-8u121-linux-arm-sflt.tar.gz, Java loaded and OpenHAB seems OK.

What I originally did is use the native Synology Java8 Package and loaded jdk-8u121-linux-arm32-vfp-hflt.tar.gz After install the Karaf error went away and OpenHAB worked on my DS414.


(Dries) #212

Hi,

I’ve found this topic when I had the same issue as some other people in this thread.

I already had a pretty good basic set up of OpenHab 2.0. I wanted to upgrade to OpenHAB 2.1. I’ve found the SPK file “2.1.0.003-SNAPSHOT-DSM6” on GitHub and I installed it (I didn’t uninstall the 2.0 version first).

The result was similar to several people above: all openHab files (including config) were gone, except for a few .sh files. And I didn’t make a recent backup (I know, I got myself to blame). I didn’t find the openhab-backup- folder that should have been created.

The recent (yesterday’s) SPK file (2.1.0.004-SNAPSHOT-DSM6) had the same outcome.

I’ve downloaded @levers version (OpenHAB-2.1.0.002-SNAPSHOT-DSM6-syno-noarch-0.003.spk.pdf) mentioned three days ago in this thread. This one installed OpenHAB 2.1 correctly (with putting the openhab-2.1.0-SNAPSHOT.zip in the public-folder).

Thanks, levers!

My lessons learned: backups, backups backups! (I knew that one already :frowning:)


(Christian Häussler) #213

Hi all,

I released a new version:
https://github.com/openhab/openhab-syno-spk/releases/download/2.1.0.004-SNAPSHOT-DSM6/OpenHAB-2.1.0.004-SNAPSHOT-DSM6-syno-noarch-0.001.spk
There is no difference between my and @levers package!

Try it!

Thanks,
Chris


(Dries) #214

Hi,

Using the Synology package 2.1.0.003 I have installed OpenHab 2.1.

What is the best approach to upgrade to a newer snapshot without losing your config data?


(Tino) #215

@cniweb

I am trying to get OH2 running on my DS216+II . Java is running, even OH2 is starting and I can access PaperUI.
I used: OpenHAB-2.1.0.004-SNAPSHOT-DSM6-syno-noarch-0.001 (1).spk

But starting OH2 I get following entry

In directory /volume1/@appstore/openHAB2 mounting looks ok but I can not access conf: permission denied

Any idea what I am missing ?

Thx.


(Tino) #216

I solved the issue, I had to change the owner of the openHAB2 folder to the openhab2 user
Thx


(wolf_from_the_north) #217

I did a fresh install this weekend with the 004 package and had no issue.
The only thing i did was create the folders on the public location and modified the rights to all users for public.
Openhab is running fine with java 8 from pc loadletter.

And indeed all files a’d folders need to be on openhab2 user.
I also gave openhab 2 user rights to admin group

Symlinks where autocreated on install for the conf and services.

Regards Wolf


(Alexander Warmbold) #218

Hello everybody,

I’m trying to get OH2 running on my DS216j, but until now I’ve got no luck.
Here is a brief summary of all things I’ve done by now.

  • the folder /volume1/public/openHAB2/conf and /volume1/public/openHAB2/addons exists
  • everyone has the permission to r/w for /volume1/public/ and all folders inside
  • Java SE 8 by PCLoadLetter is running
  • The Installation of OH2 (2.1.0.004-SNAPSHOT) works fine, I placed the .zip file in /public/openHAB2
  • the openhab2 user is the owner of the folder /volume1/public/
  • I also tried to copy the folders /conf and /addons by myself to /public/openHAB2

If I trie to start OH2 by clicking on the URL of OH2 in the package center, I always get the message “Safari cannot open the page” …

After trying to start OH2, I get the following:

I think the folders and the rights are all fine:

I really don’t get it, what am I missing?
Can anybody help me?

Thx


(Greg) #219

Instead of trying to install via .Zip, download the latest .SPK file here.

Then open package center in DSM and click Manual Install, load the .SPK file and it should install it as a package. Found here.

Good luck!


(Alexander Warmbold) #220

First of all thanks for the fast reply.
But I’m sorry, I forgot to tell you that I used the latest .spk file (2.1.0.004) from here (Releases openhab) for the installation.
But if I just use the .spk file the folder /volume1/@appstore/openHAB2/ was empty.

So I downloaded the .zip-file my self and placed it in the public folder.
Installation workes fine, but if I’m trying to start OH, I get the log file from above.


(Erkan Balci) #221

Alexander, it seems like the port 8443 of Openhab is used by some other service like domoticz. Go to /volume1/@appstore/openHAB2/runtime/bin folder. As root “vi setenv”. Change HTTPS_PORT=8443 line to HTTPS_PORT=8445. Save and quit. Restart openHAB service in package center.