Synology DiskStation

synology
Tags: #<Tag:0x00007f6ce9210bd0>

(jan) #182

:smile: i said NO instead of "not" .Meaning not the tar.gz file :wink:

your ls-l command for the folder /volume1/\@appstore/ should have a line like this

your ls -l command for the folder /volume1/\@appstore/openHAB2/ should look like this

if not please post a screenshot of your folder


(jan) #183

I just upgraded with the OpenHAB-2.1.0.003-SNAPSHOT-DSM6-syno-noarch-0.001.spk to build 826 and for me it worked fine, Or i know where to problems may be :sunny:


(Holger OpenhabUser) #184

nearly...
it is
and in openHAB2 it is:

The runtime, userdata folders are missing there...

What went wrong?


(martiniman) #185

Just now i try install OpenHAB-2.1.0.003-SNAPSHOT-DSM6-syno-noarch-0.001.spk - no dirs at all after install.
Then i
copy this file to/volume1/public/ so you have a files /volume1/public/openhab-2.1.0-SNAPSHOT.zip
but this doesnt help - what should i do now?


(jan) #186

did you copy the file to /volume1/public/ before you installed the OpenHAB-2.1.0.003-SNAPSHOT-DSM6-syno-noarch-0.001.spk?


(martiniman) #187

yes


(Holger OpenhabUser) #188

yes, looks like we are 2 with the same problem!


(martiniman) #189


(Holger OpenhabUser) #190


Synology and 2.0.0.002-beta2 server started but no open port
(jan) #191

strange try this spk... it should be the same as the 003 .. but i altered the 002 with the 003 alterations before the 003 was made available and i used it to install my version just tonight.

remove the .pdf from the file name

OpenHAB-2.1.0.002-SNAPSHOT-DSM6-syno-noarch-0.003.spk.pdf (65.5 KB)


(martiniman) #192

Wow, its installed, trying to start it...
@HolgerL - Yes, you right :slight_smile:


(Holger OpenhabUser) #193

aha, this makes a difference in the intallation:

but it still does not work
The protocol now shows something:


(jan) #194

Did you install java8?


(martiniman) #195

Yes, OH2 is started ok, thank you @levers
@HolgerL - your problem is in Framework and you CPU - i see it here: https://github.com/openhab/openhab-syno-spk/issues/52#issuecomment-285145191


(jan) #196

oke thank for the feedback.. now I'm curious what is different between the 2 spk files.


(Holger OpenhabUser) #197

I reinstalled Java 8 JRE, but still the same issue.


(Holger OpenhabUser) #198

It looks like a Java issue?
But Java is installed and running:

seems to be the same as this issue:
https://issues.apache.org/jira/browse/KARAF-4977?jql=project%20%3D%20KARAF
And now? wait until it is solved?


(martiniman) #199

Look at link in my previous post.

" I too got the karaf error until I switched Java to a hard float version. "

I don't know what is it, but you should try.
Best regards.


(martiniman) #200

Hi, can you please describe your upgrade?
You allready have OH2installed and place zip file in "public" and install spk file from dsm package center?
Is all settings were saved?
How to update bindings?


(Holger OpenhabUser) #201

yes, I looke into your link.... the issue there was something with "Permission denied", but I dont get that.

Can you post a link to the Java version you installed? Is that the "hard float version" ?