Synology DiskStation

synology
Tags: #<Tag:0x00007f1825c1c4d0>

(jamac) #162

OH2 is working - at least for OH2 bindings. The problem is that i’m trying to get a legacy 1.x binding to work but it requires access to the config files, which are nowhere to be found! I don’t have a @appstore folder on my NAS - just /homes/openhab2, which only contains a couple of empty files.


(Maurits) #163

Hi Jamac

In your web view the @appstore folder does not show up, but you will find the folder when you make a ssh connection to your Synology in a terminal. If you have not done that before, you need to change your configuration in synology control panel to allow ssh connections. Root password is the same as your admin password.


(jamac) #164

Thanks! I think this is the missing information I was after. I’ve used Putty to make SSH connections to other devices so should be able to work it out for my Synology.


(Mark Lavercombe) #165

@jamac
That’s great. I use WinSCP from my Windows 10 device to transfer files to the right folders etc.
Hope this means you’re sorted! :slight_smile:


(Petcu Marius) #166

Hello
OpenHAB2 version: "openHAB-2.0.0.001-DSM6-syno-noarch-0.001.spk"
Synology DS216+II (Intel processor) - DSM 6.0.2-8451 Update 9

All working fine with the exception of rrd4j graphs under the normal Synology account (if I start the service from “Package Center”) I get the valuates but the graph is showing a missing graphic icon. This happens on the demo install to.

But if I start the OpenHAB2 service from SSH with root access there is no issue and graph will be ok.
command is: “sudo ./start.sh” in the openhab directory (/volume1/@appstore/openHAB2)
I suspect a permission issue but I can’t figure it out.


(martiniman) #167

Hi, i try to update my Synology OH2 #723 using this tutorial.
But no luck, package center shows it running, but it not.
Is there another way to update Synology OH2?


(Andreas) #168

Hi, t try to upgrade my Diskstation using

2.1.0.002-SNAPSHOT-DSM6

The package center shows it running, but i can’t acces the webpage. The openhab2 folder only contain three *.sh files.

So i use the 2.0.0.001-DSM6 release and everything works out of the box.

Btw. I mount the openhab2 folder to /public/openhab2 on startup


(martiniman) #169

Hi @derandi I try it already - not works at all, and i create issue.


(Holger OpenhabUser) #170

Hi,

maybe I am stupid, but I don’t get OH running on my DS213.
I Installed Java 8 SE and the OH 2.1.0.003 snapshot. In the package center it says running. I can stop it and restart it, everything is ok.
But I cannot connect to OH!
As I understood, the installation should be in \volume1@appstore\openHAB2\ right?
But there I only see a start_runtime.sh, stop_runtime.sh and start_debug_runtime.sh. Noting else!
Where is the installation?
I am lost :nerd:


(jan) #171

@HolgerL,
this is because the installer script is not downloading the latest version of OH2. Use this link the download it your self en place is in the /volume1/public directory on your NAS.
OH2 latest files

Do you have the directory /volume1/public/openHAB2/conf/ and /volume1/public/openHAB2/addons/? If not make them that will make changing settings a lot easier. If so and these are empty directory copy the conf and addons directory from the zip file to the /volume1/public/openHAB2/conf/ and /volume1/public/openHAB2/addons/

Then run the installer.

If you’re going to use USB sticks whit your OH2 setup. Give the openhab2 user HTTP permissions in the DSM user configuration.
If you want your USB devices to have a fixed name.
mak a file in /lib/udev/rules.d/99-usb.rules and put something like this in it.

SUBSYSTEM=="tty", ATTRS{idVendor}=="0403", ATTRS{idProduct}=="6001", ATTRS{serial}=="A50285BI", SYMLINK+="P1EnergieMeter", MODE="0777"

the idVendor, idProduct and serial can be found with command “lsusb -v > /volume1/public/usb.log” and the search that file for your USB device and edit the above code


(Holger OpenhabUser) #172

Thanks very much, I will give it a try tomorrow.
I am wondering a bit, why the Synology paket center says that OH is running, but it can’t if the files are not there ?
Is it correct taht I need to have a “openhab2” user? Currently I have a user “openhab”! Then I need to change that also.


(jan) #173

@HolgerL, that is because it’s a state and i think the start script has maybe some updates to go :wink:

You need a openhab2 user but this is made by the installer script… ( don’t know what will happen if you already made a openhad2 users.)

Oh and if youre running USB sticks with FTDI, pl2303 en CPL210* chips look at this page http://www.jadahl.com// choose the correct “Miscellaneous SPK” link for your DSM version. Then select your model and download the UsbSerialDrivers spk. This provides you with a lot of drivers for serial devices and save a lot of time.


(Holger OpenhabUser) #174

@levers
I now copied the snaphot to the /volume1/public/openHAB2/ directroy.
Then I started from the SSH:

admin@DS213:/volume1/public/openHAB2$ sudo ./start.sh                           
Launching the openHAB runtime...
0
admin@DS213:/volume1/public/openHAB2$

Nothing else happens, and I can still not connect to OH.
Or do I need to start the SSH under the openhab2 user?
Should I see the Karaf window then in the SSH screen?


(jan) #175

@HolgerL, You must copy it to /volume1/public/ not /volume1/public/openHAB2


(Holger OpenhabUser) #176

You mean to copy the complete .tar.gz archive there?
I unpacked it and put it into the /Openhab2 folder as I do for the Windows installation.


(jan) #177

No the zip file.

If you want to use Karaf I think you need to alter the file /userdata/etc/org.apache.karaf.shell.cfg the standard port was used on my system. You will see this if you view /userdata/logs/openhab.log (use tail -200 openhab.log to view the last 200 lines) or if login in the the standard 8101 port will not work.

If you use a SSH client and you want to login as root… login first as admin then typ the command “sudo su -” and your ask for the admin password again. and then your root…
Watch out if you’re going to create files with the root users. afterwards you need to change the permissions. “chown openhab2:users filename” or “chown -R openhab2:users directory”


(jan) #178

The installer code line are… but somehow they do not work in the script.

DOWNLOAD_PATH="https://openhab.ci.cloudbees.com/job/openHAB-Distribution/lastSuccessfulBuild/artifact/distributions/openhab/target"
DOWNLOAD_FILE1="openhab-2.1.0-SNAPSHOT.zip"

(Holger OpenhabUser) #179

Only to be clear: What now exactly should be copied to the public folder?


(jan) #180

Go to https://openhab.ci.cloudbees.com/job/openHAB-Distribution/lastSuccessfulBuild/artifact/distributions/openhab/target download the file openhab-2.1.0-SNAPSHOT.zip

Copy this file to/volume1/public/ so you have a files /volume1/public/openhab-2.1.0-SNAPSHOT.zip


(Holger OpenhabUser) #181

ok, I did that.
I was a bit confused, because yout wrote above… not the zip file.

So with the zip file in the public folder, I installed the paket again the
OpenHAB-2.1.0.003-SNAPSHOT-DSM6-syno-noarch-0.001.spk.

But still no sucess :frowning: