Synology DiskStation

synology
Tags: #<Tag:0x00007f6ce6d51498>

(Christian Häussler) #142

Hi gays,

I released 2 new versions:

2.0.0.001-DSM6 (Final 2.0.0)
2.1.0.001-SNAPSHOT-DSM6 (SNAPSHOT 2.1.0)

Try it, please, Thank you!

One question: I think we need no new versions for OH 1.x and DSM < 6.0 Packages, or?

Chris


(ThomasK) #143

Hi Chris
just tried snapshot 2.1.0. It installs fine, the services run on my DS413, where - thanks to @§$%§& Oracle - only an old java8 version runs, as they do no longer support PPC architecture.
However, the openHAB2 directory on public does not seem to be discovered. Or must it be OpenHAB2 (capital O)? At least I have a sitemap in there, which is not seen by the classic UI.
btw it there a password for the openHAB2-user?
Thanks for the great work,
Thomas


(Kai Kreuzer) #144

It's my very first try to install ANY Synology package, so I am not sure if I missed something or if the package indeed lacks some signature?

I'm running DSM 6.0.2-8451 Update 9 on a DS716+II.


(Ferry) #145

sorry not in german :slight_smile:


(Kai Kreuzer) #146

Thanks, I just found that myself - this indeed solves my issue :thumbsup:


(Thx723) #147

I'm up and running on my DS916+. The only thing I also noticed is the user configuration files in /public/openHAB2 folder are not being picked up. Which .cfg file can we edit to re-reference the path?


(wolf_from_the_north) #148

Dear all,

Please bare in mind that all people running on XPENOLOGY which is a bare metal self build with SYNOLOGY OS will need a install version for 5.2 and not 6.0.
currently i am unable now to setup OPENHAB 2.0.

kindest regards


(Daniel Walters) #149

I tried the docker image on xpenology DSM 6.0 a few weeks ago - it worked fine. Although I haven't worked out how to get my xpenology DSM 6.0 to recognise my Z-Wave stick.


(wolf_from_the_north) #150

managed to install the package on my dsm by editing the install spk to my version of dsm so the check goes trough.
it installed fine exept i had to download the zipfile manually and place it in the public folder.
New problem , package is not starting as seen in many threads, can't find the karaf folder


(ThomasK) #151

Regarding the not discovered public folder:
If you know how to SSH into the NAS, best is to set the link by yourself:
- stop the service in the Syno UI
- safety first: save the contents of /volume1/@appstore/openHAB2/conf:
cp /volume1/@appstore/openHAB2/conf /volume1/@appstore/openHAB2/conf_orig
- or alternatively copy the content to your public folder:
cp /volume1/@appstore/openHAB2/conf /volume1/public/openHAB2/conf
(this is most likely the safest to get it running)
- then set a symbolic link from public to the openHAB2 folder:
ln -s /volume1/public/openHAB2/conf /volume1/@appstore/openHAB2/conf
- What I did is also to relocate the logs folder to the public dir, so you can easily from anywhere see what goes wrong:
ls -s /volume1/public/openHAB2/logs /volume1/@appstore/openHAB2/userdata/logs
- restart the server.
Then you can for example use the Eclipse Smart Home Designer for editing by simply letting it point in windows or osX to your public folder.
Regards
Thomas


(.) #152

Hi,

Would you mind running through how you modified the spk for xpenology dsm5.2?

I am running the same here and have yet to try and upgrade to dsm6, waiting for quicknick to release his installer..


(wolf_from_the_north) #153

You can open the spk with notepad++ in the first lines you will see a check for dsm 6 , just change to your version.

Kindest regards

Ps: let me know after the install if it works for you cause here i can't get it started


(Hoex) #154

looks like the most convenient way to overcome this issue, but mount bind needs root access. How did you login with or su to root? Does not work on my 216+II


(wolf_from_the_north) #155

when i try to start the openhab via start.sh i get ./runtime/bin/karaf: not found


Problems installing openHAB 2 on Synology DS 213
(wolf_from_the_north) #156

good i found a solution.

i downloaded the beta 3 spk and copied that to my pyblic folder:
then i downloaded the release zip from the openhab website so not the cloudbees.
i renamed the file to what beta 3 is looking for and placed it in the public.
now it runs.

this does mean that the package they now have is bogus and not working !


(Kristian Sons) #157

Has anyone experience with DS114? Installation is fine, but I can not access the webservice. Log has an error:

Caused by: java.lang.IllegalStateException: Could not load implementation object class org.eclipse.smarthome.io.javasound.internal.JavaSoundAudioSink


(jamac) #158

First post.

Hi, I'm moving to OpenHAB2 from Vera and am having some issues installing the Synology package (openHAB-2.1.0.001-SNAPSHOT-DSM6-syno-noarch-0.001) on my Synology DS214play.

I followed the installation instructions, installed Java SE 8, then installed OH2 (see http://docs.openhab.org/installation/synology.html#installation). The installation seemed to go ok and I can access OH2 via the Paper UI from my PC's browser. However, there doesn't seem to be any configuration files on my Synology!

The installation instructions state that "The configuration files are located at: /volume1/@appstore/openHAB2/userdata/config". And the OH2 app itself - when viewed from within the Synology Package Centre - states that: "If the directory /volume1/public/openHAB2/conf exists, the directory will be used for OH2 configuration files".

However, when I check the NAS directory structure I only see a directory called /homes/openhab2. And there are only two items in the directory - a 1kb file called .profile. and a sub-directory called .karaf, which contains a 0kb file called karaf.history.

I tried uninstalling the OH2 package, creating a shared directory call /volume1/public/openHAB2/conf, giving the openHAB deamon read/write access and re-installed the OH2 package but there are still no configuration files.

Is this normal? Have i done something wrong?


(.) #159

I had the same issue, :karaf not found.

Pulled the pin and upgraded to dsm6 patched up to 8, with the jun loader.

Installed easy.


(jamac) #160

I found the following, which explains why there is no config file:

One thing to be aware of is any configuration done in PaperUI or Habmin gets saved to a non-human readable database. See http://docs.openhab.org/tutorials/migration

But surely i should see more files than the couple of empty files referred to above?

I might have to retreat back to my Vera unless i can start making sense of this!


(Mark Lavercombe) #161

@jamac Is OH working? If yes, then you haven't done anything wrong.

My openhab files are in the @appstore location. Did you check there?