Synology DiskStation

synology
Tags: #<Tag:0x00007f6cf11bfef8>

(Neil) #122

I see from the github 'issues' that there's a 'working' snapshot package within the zip that's available here:-
https://github.com/openhab/openhab-syno-spk/files/521593/OpenHAB-2.0-SNAPSHOT_a-DSM6-syno-noarch-0.002.zip

I've installed it and it runs (with a bit of tweaking for the conf location) - tho it's only offering me the classic interface, which gives a not found. If i used the stored links I have to basic or PaperUI those also give a not found.

I'd really like to use an updated package, but it needs to work.


(Neil) #123

I take back that last post - I get all of the interfaces if I reboot my NAS after uninstalling Beta-3 asnd before installing the version I linked to above.

It appears to be properly working, so I'll continue setting it up. :slight_smile:


(Thijs) #124

I managed to install that same version @DSTM mentioned as well and can confirm it's working. For those performing an install for the first time and using Z-wave binding, here's a summary of the steps I took (I ran some commands as root, so make sure you know what you're doing). I've made a pdf of it: OpenHAB2.pdf (207.3 KB)

One of the issues in the beta3 release was that the state of Z-wave devices remained 'initialised' and as far as I can tell these are resolved in this 'snapshot' version.


(Neil) #125

hi Thijs

I had my z-wave devices working OK with beta-3, as well as with this snapshot - and this snapshot is running fine, too.


(Thijs) #126

Yes, it was working, but after restarting my Synology (and OpenHAB being restarted) the devices sometimes did not 'initialize' properly (one of the threads this is discussed in is https://community.openhab.org/t/z-wave-binding-things-initializing-after-restart/12173 or in https://community.openhab.org/t/binding-not-starting-consistently-since-6-19-build/11741/31).


(Christian Häussler) #127

Hi Neil,

I work on a new version!
Wait, please...

Thanks,
Christian


(Neil) #128

Thank you Christian. :slight_smile:

Tho I'm using the version I linked to above, which seems to work OK (tho I have an issue with a zwave device, which might be due to the included binding).


(Neil) #129

thanks for the new package Christian.

It installs and works on my system at least as well as any of the previous versions did. :slight_smile:


(Neil) #130

hi Christian, FYI:

OH2 Snapshot 5 works great, but i just tried snapshot 7 and it didn't seem to run properly so have reverted to snapshot 5.


(Neil) #131

and, i think, one of the reasons why snapshot 7 doesn't work is because it installs to

/volume1/@appstore/openHAB2/

instead of

/volume1/@appstore/OpenHAB2/ (which is where snapshot 5 and earlier installed to.


(Roman ) #132

Hello,

I am beginner with home automatization and I would kindly ask you for your help.
I have Synology DS214se with DMS 6.0.2.8451 Update 2, AeoTec USB Z-Wave stick and thermostat Heatit.
I need help with installation OH2 on Synology. I installed Java8 and OH2 2.00.007-SNAPSHOT-DSM6. To folder addons I copied habmin.jar.

I can start OH2 and get to startpage with Paper UI, Basic UI, Classic UI and Habmin UI. I choose some UI but when I select Paper or Habmin UI I´ll get error message "Error503 (Jersey is not ready yet!)".

What does the error message mean? How can I fix it? Can you help me?


(martiniman) #133

Just for info.
I have OH1 installed, i stoped it, and install 2.0.0.008-SNAPSHOT-DSM6 for first time, it installed and started normally.
I got access to paperUI on 8080 port.
Synology 214play DSM 6.0.2-8451 Update 4


(Trent D) #134

Hi,
I have just learnt about OpenHAB and am interested in getting the server up and running. I have a Synology and it’s always on, so thought that would be a great place to run it.

I feel like what I need to know is right in front of my face and I can’t see it, so I’m hoping someone can point me in the right direction (and it’ll help someone else).

I’m checking out the packages at https://github.com/openhab/openhab-syno-spk/releases, specifically OpenHAB-2.0.0.008-SNAPSHOT-DSM6-syno-noarch-0.001.spk and OpenHAB-1.8.3-syno-noarch-0.001.spk (both having the same issue).

After downloading, I went to the Synology (running DSM 6.0.2-8451 Update 4) > Package Center > Manual Install, I then select the package and get the error:

This package does not contain a digital signature.

To fix that I went to Package Center > Settings, and set the Trust Level to Any publisher.

Now when I go to upload the package I’m getting the error:

Port undefined configured for this package is either used by another service or reserved for system use. Please disable or modify the conflicting service, or contact the developer to modify the package configuration.

Obviously I don’t know what that port is, but I do have a number of other community packages installed which may well conflict with one of the ports.

Do you have any suggestions as to how I would investigate this further? Is there a Read Me or similar that outlines the correct steps to take to install it?

Thanks in advance!


(Starbucks Do) #135

I'm still on OHB 1.x, but the ports should be the same after a quick view in the installation docs.
HTTP_PORT=8080
HTTPS_PORT=8443
TELNET_PORT=5555
maybe a demo port for http=9080

In the synology control app --> security --> firewall --> profile --> defaults you can see all open and there obviously needed ports for synology. Just for the installation I would change it and free up the ports listed before. After that rechange and modify OHB 2 ports throough start.sh i.e.


(martiniman) #136

Hi.
@cniweb, :pray: please fix Synology package regarding to new changes and thank you for your work.


Synology DSM Package Center: Download Problem of openHAB2
(Christian Häussler) #137

I´m working on it!


(Christian Häussler) #138

A new release is finished!
Try it, please.


(martiniman) #139

It works!
Thank you.
DSM 6.0.2-8451 Update 8


(Neil) #140

hi Christian, I've just installed snapshot 9, and it works great - thank you. :smile:

However, it's not using /volume1/public/openHAB2/conf as the config location despite it existing and owned by the openhab2 user before I installed this version (it's never worked for me to that location in any of the previous versions). Instead it uses the conf directory in the program folder /volume1/@appstore/openHAB2/conf/.

Is there a specific thing I need to do so that the install will use /volume1/public/openHAB2/conf ?


(Andreas) #141

hi,

it works, accept that problem with the config location.
I have the same problem as @DSTM

Thx. :slight_smile:

System:
DS216+II
DSM 6.0.2-8451 Update 8

Update:
I followed these Instructions and mount the whole /volume1/@appstore/openHAB2 to /volume1/public/openHAB2

http://www.synology-wiki.de/index.php/Mount_Bind