Synology DiskStation

synology
Tags: #<Tag:0x00007f6cf3949b40>

(Dirty Devious) #102

I am VERY new to OpenHAB and trying to learn quick.

I have an issue with the OpenHAB synology package running on Synology DS2015xs with DSM 6.0.1-7393 Update 2.

I installed the OpenHAB-2.0.0-beta3-DSM6-syno-noarch-0.001.spk and it appeared to work. The website would load however it was very slow to install bindings, etc. But it all worked.

Then I decided to uninstall that package and install OpenHAB-1.8.3-DSM6-syno-noarch-0.001.spk to be on an official build instead of beta.

I now cannot get the website to load when using OpenHAB-1.8.3-DSM6-syno-noarch-0.001.spk alos I have uninstalled this package to go back to OpenHAB-2.0.0-beta3-DSM6-syno-noarch-0.001.spk which also does not work.

Are there some configuration files other than /volume1/@appstore/OpenHAB2 that need to be deleted to start from fresh?


(Dirty Devious) #103

Ok so a reboot of the NAS brought the OpenHAB-2.0.0-beta3-DSM6-syno-noarch-0.001.spk website back up.


(Dirty Devious) #104

And now its dead again. After uninstalling one more time. Even after a reboot it wont come back up.


(Aurelio Caliaro) #105

Hello. I just installed OpenHAB 2.0.0 beta3 on my Synology DS213. I managed to install Java and openHAB, but when I try to start it with "start_runtime.sh" it stops with "find: server: No such file or directory". It seems that it cannot find org.eclipse.equinox.launcher_*.jar.
Indeed, I did not install eclipse separately (and did not find any instruction that I need to do so). Do I have to install it separately and where from?
Thank you for any help.


(Sasha) #106

Hi,

I've got OH1.8.3 installed on Synology NAS.
It was working perfectly fine before yesterday.

And now I'm getting an error:
2016-08-25 07:22:09.816 [ERROR] [g.openhab.io.net.http.HttpUtil] - Fatal transport error: java.net.ConnectException: Connection timed out

I've tried to restart the package, restart NAS, reinstalled java, nothing helped.
Any ideas?

Cheers!
Sasha


(Igorrobertifoc) #107

Hi,
finally work for me. I installed chroot synology service and installed with deb file.

Bye


(martiniman) #108

Hi. Please help me with script for restart OH.
Sometimes mqtt binbing lost connection, only restart help.

I tryed:

Switch    OpenHABRestart    "OpenHAB Restart"    {exec=">[ON:sudo /usr/syno/bin/synopkg restart OpenHAB]", autoupdate="false" }

but this is non works.


(Igorrobertifoc) #109

Sorry I tried lot of time the package... but doesn t work for me.
I installed chroot on synology ad configured all with putty


(Neil) #110

Igor, are you sure you waited long enough for the service to fully start?

It takes a number of minutes rather than seconds, and when I first installed OH2 (on a DS214play) I thought it didn't work because I didn't give it enough time to start.


(Neil) #111

So, this timezone problem. I have OH23 installed on a 214play, and it runs very well - apart from having the wrong time, which is a pain when configuring rules.

In 'local time' in 'control' of Paper UI, it shows the right local (daylight savings) time (in the 'value' part), and the right GMT (in the 'date' part). I've also checked start_runtime.sh, and that already includes a "-Duser.timezone=Europe/London" part.

However, within my custom sitemap, the datetime returned by ntp:ntp:local:dateTime is the GMT time and not the local daylight savings time (British Summer Time).

Is there any way to get the correct local time, so that it displays correctly on the sitemap and is the time that is used by any rules?


It would also be nice if the config files it used were at public/OpenHAB2/conf rather than at /volume1/@appstore/OpenHAB2/conf.

Is there somewhere that the path to the config files can be changed?


(Igorrobertifoc) #112

Yes. I waited 15 minutes. Now it start on 30 sec :slight_smile:


(Igorrobertifoc) #113

When I istalled i created a soft link (ln) in linux


(Neil) #114

thanks Igor, I'll give it another try - I must have messed that up when I tried that before.


(Neil) #115

The version of OH2 that I installed recently created a softlink to public/OpenHAB2/conf - yet for some reason it just doesn't want to work on my system.

Oddly, if I rename that softlink and create a physical 'conf' directory at /volume1/@appstore/OpenHAB2/conf and then copy my working files from public/OpenHAB2/conf to it, it does work.

I've checked the ownership rights, and they're the same in both locations so that can't be the issue for why it doesn't work when located at public/OpenHAB2/conf, but i'm stumped for what else it might be. Does anyone have any suggestions please?


(orange waters) #116

I am not able to start OH2 spk on DSM 5.2 using start/run in the packages tab. I have installed the correct version. I can start OH2 spk by going to /Volume1/@appstore/OpenHAB2/ and typing sh start.sh. Can someone help start the package regularly ? That way, it restarts automatically with reboots.


(martiniman) #117

Hi.
Will work OH2 & OH1.8.3 together on SynologyNAS?
I want to try OH2.
Thanks.


(Neil) #118

hi Christian, I've just installed the new snapshot package for OH2 & DSM6, and it won't run and looks like it's not installed all of the files.

If it was meant to be installed over the top of the previous version, DSM6 says to uninstall the previous version.

What have I done wrong?


(Patrick Boch) #119

Hi - same here. It was a first install, though.
But the issues are the same: OH2 seems to be running (that's what it says in package manager), but no files in /public/Openhab2 (actually, there's no folder of that name) and no website reachable at port 8080


(Neil) #120

hi Patrick,

I can tell you that (at least, as far as the beta 3 package goes) the install package won't create the /public/OpenHAB2 (note the case!) directory, but will use it if the directory already exists... tho on my own system there's still some issues with it, see my post above from about a month ago for how i dealt with it (if you need further info, just ask).

If you want to use OH2 right now I can recommend the beta-3 as very usable. The only real issue I've had with it is that there's a bug somewhere within the rules processing, which throws an error msg into the log, tho the rule might still run properly (tho it might not do, too). It's for a fix to that rules problem that I'm keen to get the latest version installed.


(Neil) #121

I've just remembered that one of the issues with the latest OH2 snapshot is that it doesn't create the openhab2 user - so it's never going to work as an install.