Synology DiskStation

synology
Tags: #<Tag:0x00007f6ce4c9ee58>

(Vincent Ferreux) #82

Hi,

I'm not sure but you could find openhab start-stop-status script in /volume1/@appstore/Openhab/script. (or in var/package?)
I didn't change anything in github 'cause I'm not totally sure if it's work as excepted, I will try soon and tell you more.
I'm facing now other installation problem with DSM6... :slight_smile:

Regards,


(wolf_from_the_north) #83

just tried but did not change anything
just did a full reinstall on my synology of 1.8.2 which claims to have solved the issue.
still its not solved.
i believe that openhab is getting its timezone from another config file in synology


(Dominic Spatz) #84

What about manually setting the timezone to "Europe/Berlin" or whatelse you'd like to have.
Simply add the specific timezone to your start_runtime.sh located in /volume1/@appstore/OpenHAB/


(wolf_from_the_north) #85

can you give an example for 5.2 ? cause i allready tried something like that before and it did not work.
thnx allready for replying ? i'm living in belgium so berlin should be fine


(Dominic Spatz) #86

edit the file start_runtime.sh

add the following argument to the Java Runtime:

-Duser.timezone=Europe/Brussels

Could look like this:

#!/bin/sh

cd dirname $0
if [ ! -d logs ]; then
mkdir logs
fi

eclipsehome="server";

HTTP_PORT=8081
HTTPS_PORT=8443
TELNET_PORT=5555

cp=$(find $eclipsehome -name "org.eclipse.equinox.launcher_*.jar" | sort | tail -n 1);

echo Launching the openHAB runtime...
PROGRAM="java -Dosgi.clean=true -Declipse.ignoreApp=true -Dosgi.noShutdown=true -Duser.timezone=Europe/Brussels -Djetty.port=${HTTP_PORT} -Djetty.port.ssl=${HTTPS_PORT} -Djetty.home=. -Dlogback.configurationFile=configurations/logback.xml -Dfelix.fileinstall.dir=addons -Djava.library.path=lib -Djava.security.auth.login.config=./etc/login.conf -Dorg.quartz.properties=./etc/quartz.properties -Djava.awt.headless=true -jar $cp $* -console ${TELNET_PORT}"
$PROGRAM > logs/openhab.stdout &

PID=$!
echo $PID > ~/.daemon.pid


(wolf_from_the_north) #87

ok i will try and give feedback


(wolf_from_the_north) #88

many thanx for the example :slight_smile:


(wolf_from_the_north) #89

thnx the solution you suggested works
i now see this

2016-04-13 15:38:56.398 [INFO ] [.b.a.internal.bus.AstroBinding] - AstroConfig[latitude=51.0328973,longitude=4.4176682,interval=3600,systemTimezone=Europe/Brussels (CET +0200),daylightSavings=true]

thank you so much


(Christian Häussler) #90

Hi Vincent,

did you continue? A solution that dynamically depending on would work from the DSM version would be good.

Thanks,
Chris


(lysol) #91

Is anyone else having issues getting OpenHAB 1.8 on DSM 6.0 to see the sitemap file? I copied over the demo configurations and addons folders to a few locations with no luck:

/volume1/public//OpenHAB
/volume1/@appstore/OpenHAB

I see the symlinks pointing to the first path above, but i tried replacing the symlinks with actual folders. I verified openhab user in DSM has access to the shared public folder i created. ive stopped/started openhab multiple times and even uninstalled and reinstalled a few times. openhab 2.0 beta wont start at all so im back to working on 1.8.

im on a Synology DS213+ btw...


(lysol) #92

id like to add that my sitemap filename is demo.sitemap and my url is http://:8081/openhab.app?sitemap=demo


(lysol) #93

Here are the logs when refreshing the webpage

admin@DiskStation:/volume1/@appstore/OpenHAB/logs$ tail -f openhab.stdout


(Vincent Ferreux) #94

Hi,

Yes, I'm continuing :

With the start-stop-status script, we have now a .profile in /var/services/homes/openhab/ containing
export TZ='Europe/Brussels'
(in my case in France).
Why not passing this argument to the "start_runtime.sh" script :

DAEMON_ID="${SYNOPKG_PKGNAME} daemon user"
DAEMON_HOME="cat /etc/passwd | grep "${DAEMON_ID}" | cut -f6 -d':'"
TZ_OPENHAB = "somerule that catch what is next to "export TZ=" in ${DAEMON_HOME}/.profile
Maybe
TZ_OPENHAB="cat ${DAEMON_HOME}/.profile | grep "export TZ" | cut -d'=' -f2"

In PROGRAM, add
- Duser.timezone=TZ_OPENHAB

what you think ?

Regards,


(lysol) #95

...and I figured out my problem... So I now have 1.8 successfully working on my DS213+.

I first installed Java 8, then the OpenHAB 1.8, then I downloaded the following from the OpenHAB downloads page on their website.

Runtime core - copy .zip to "/var/packages/OpenHAB/target" on the Synology and then run "7z x zipfilename.zip
Addons - copy .zip to "/var/packages/OpenHAB/target" on the Synology and then run "7z x zipfilename.zip
Demo setup - copy .zip to "/var/packages/OpenHAB/target" on the Synology and then run "7z x zipfilename.zip

That should get you up and running with OpenHAB 1.8 on DSM 6.0...


(Christian Häussler) #96

Hi @veance,

I think, that looks good.
Can you make a PR?

Thanks,
Chris


(Brady) #97

I installed the 1.8.3 DSM 6.0 RC spk and was having issues where the demo sitemap could not be found. Managed to get it working by...

delete /var/packages/OpenHAB/target/addons/
delete /var/packages/OpenHAB/target/configurations/

create new symbolic links in for the locations that I deleted to /volume1/public/OpenHAB/addons & configurations folders.

I am just getting started with OpenHAB and I am toying with starting on 2.0 beta... but I haven't had any luck getting that running on the Synology yet.


(Christian Häussler) #98

I draft a new release:
https://github.com/openhab/openhab-syno-spk/releases/tag/1.8.3-DSM6
Try it, please!

Thanks,
Chris


(Thinqer77) #99

Hi all,

Struggling to get 1.8.3-DSM6 working properly. I was originally running 1.7.1 and it's been fine for a good few months and then I noticed today that the service was stopped (it's been a few days since I last used OpenHAB) and couldn't get it running again (clicking the button in DSM to start the service did nothing).

Anyway, bit the bullet and installed 1.8.3 manually. I've updated the addons to the matching 1.8.3 versions and the service now starts but checking the logs I can see a couple of lines saying:

16:59:19.235 [Component Resolve Thread (Bundle 98)] DEBUG o.o.config.core.ConfigDispatcher - Processing openHAB main configuration file '/volume1/@appstore/OpenHAB/configurations/openhab.cfg'.
16:59:19.236 [Component Resolve Thread (Bundle 98)] WARN o.o.config.core.ConfigDispatcher - Main openHAB configuration file 'configurations/openhab.cfg' does not exist.

I've checked and the openhap.cfg file is in that location. Once the service is up and running and I try to load a sitemap it says that it can't find the sitemap.

I've tried deleting the folders and re-creating the symbolic links as mentioned by Brady above but no joy. Does anyone have any further suggestions?

Many thanks,

Ben.


(Thinqer77) #100

Hi All,

Managed to fix my problem - it was because the user 'openhab' had lost its permissions on the public folder. Gave it R/W and now all is well (after restarting the service).

HTH,

Ben


(Christian Häussler) #101

Hi @Thinqer77,

can you open a Issue in GitHub, please?

Thanks,
Chris