Synology DiskStation

synology
Tags: #<Tag:0x00007f6ce4f350b8>

(Christian Häussler) #62

Yes :wink:
I released Ver. 1.8.1 and Ver. 2.0.0-beta2:
https://github.com/cniweb/openhab-syno-spk/releases
All with "Timezone" and "User Home Service" Patch!


(Oliver H) #63

This is something I would also like to know.


(Christian Häussler) #64

New location of openHAB SPK Packages:
https://github.com/openhab/openhab-syno-spk/releases
Now a official projeckt of openHAB! :checkered_flag:


(Simon Dylla) #65

Hi all, thanks a lot for the spk-Package!
Runs on my Rackstation RS815 without problems.
Just one Question to other users:
My configurationfiles are located in /volume1/@appstore/OpenHAB/configurations/
Unfortunately in cant access this directory directly through usual services (File Station).
As a result, I cant edit the configuration files in the Designer, so I edit the files in a "working-directory" (/volume1/daten/openhab/configuration) and copy the files manually by ssh-console after each change.
Is there any possibility to edit the "real" files directly in OpenHAB Designer?
Thanks a lot for every hint...

Greetz,
Simon


(Christian Häussler) #66

Hi Simon,

in my package:
If the directory /volume1/public/OpenHAB/configurations exists, this directory will be used for all OpenHAB2 configuration files. If the directory /volume1/public/OpenHAB/addons exists, this directory will be used for all OpenHAB addons (bindings) files.
The folder /volume1/public/ is over the network available!

Chris


(Tnn85) #67

Hi,
I have been trying to start openhab on my DS212+ for some time now. However, I have not been succesful at all.
I could succesfully install Java Embedded SE 8 and openhab 1.8.1 distro for synology , as well as openhab demo. In the DSM 5.2 package explorer it says openhab is running, but if I want to open the sitemap of any configuration (demo or heating doesnt matter), the page cannot be found in my browser. I use the following link "http://192.168.178.41:8081/openhab.app?sitemap=heating". The log output of openhab looks like this:

2016-02-18 18:30:14.441 [INFO ] [.o.core.internal.CoreActivator] - openHAB runtime has been started (v1.8.1).
2016-02-18 18:30:25.441 [INFO ] [o.o.i.s.i.DiscoveryServiceImpl] - mDNS service has been started
2016-02-18 18:30:26.518 [INFO ] [o.o.i.s.i.DiscoveryServiceImpl] - Service Discovery initialization completed.
2016-02-18 18:30:36.259 [INFO ] [c.internal.ModelRepositoryImpl] - Loading model 'db4o.persist'
2016-02-18 18:30:40.416 [INFO ] [c.internal.ModelRepositoryImpl] - Loading model 'exec.persist'
2016-02-18 18:30:40.513 [INFO ] [c.internal.ModelRepositoryImpl] - Loading model 'logging.persist'
2016-02-18 18:30:40.907 [INFO ] [c.internal.ModelRepositoryImpl] - Loading model 'rrd4j.persist'
2016-02-18 18:30:41.797 [INFO ] [c.internal.ModelRepositoryImpl] - Loading model 'Heating.items'
2016-02-18 18:31:02.812 [INFO ] [penhab.io.rest.RESTApplication] - Started REST API at /rest
2016-02-18 18:31:03.630 [INFO ] [c.internal.ModelRepositoryImpl] - Loading model 'Heating.sitemap'
2016-02-18 18:31:08.478 [INFO ] [.o.u.w.i.servlet.WebAppServlet] - Started Classic UI at /classicui/openhab.app

Can anyone help me? The configuration "heating" is working on raspberry pi as well as on the openhab windows runtime.


(Christian Häussler) #68

Try this: http://192.168.178.41:8081/openhab.app?sitemap=Heating


(Tnn85) #69

Nope, doesnt work either. It shows "ERR_CONNECTION_TIMED_OUT". I use Chrome but I have the same problem with Microsoft Edge. What can I expect to see if i just open "http://192.168.178.41:8081/openhab.app" ?

I want to add that I currently do not use the "public" folder for the configurations directory. I already deleted the "public" folder after I failed trying this solution as well. I meanwhile put my configuration files in the /volume1/@appstore/OpenHAB/configurations/ folder.


(Simon Dylla) #70

Hey Chris,

where can I get this kind of package from?
I thought there is only one 1.8-package!

Simon

edit: ok, ok, now I'm clear! It is the "User Home Service Patch", isn't it?
I will upgrade my packages and have a look...


(wolf_from_the_north) #71

https://github.com/openhab/openhab-syno-spk/releases


(Simon Dylla) #72

Hey alltogether,

I still need help getting openHAB running on my rackstation because I'm totally confused.
I think its all about the rights of files and folders.
This is what I do:
1) Setting up the new folder "public" on DSM
2) Mount it to my Laptop an generate "OpenHAB", then "configrations" and "addons" in it.
3) Installing Openhab SPK-Package. I see symbolic links in "volume1/@appstore/Openhab".
3) Putting all the demo files in the folders.
4) Nothing works. I also tried to set all the rights to 777 and the owner to openhab:users, still the same.
Can you please tell me what I do wrong?

Simon


(Dominic Spatz) #73

Seems that there is a problem with the latest DSM 6.0 release.
But i downloaded the zip file manually and compressed it as spk (tar format) using 7Zip.
The file might be corrupted.


(Henning F. Mettge) #74

Hi,

I am not so good on terminal. Could you please post the commands?

Thanks in advance!
HFM


(Starbucks Do) #75

The 1.8.2 spk for DSM 6.0 is packed with the install files in a folder. Just copy it out and then into the root of the spk package. No need for terminal actions, under win for example 7zip or linux an archivmanager which should be installed on your system already.
As a new user I'm not allowed to upload my fixed spk file for you :-/


(martiniman) #76

Today my synology updated to dsm 6 - openHAB stop working
I download OpenHAB-1.8.2-DSM6-RC-syno-noarch-0.001.spk, but synology says "invalid file format"
How to install this package?

ps
OpenHAB-1.8.1-DSM6-beta-syno-noarch-0.001.spk works well.

Thanks.


(Starbucks Do) #77

You could read just the last answer above your question....

edit: I got the rights to upload now. Attached the original file, just copied the content out of the folder insider the spk package. OpenHAB-1.8.2-DSM6-RC-syno-noarch-0.001.spk.pdf (87.5 KB)
save the file and rename it from .pdf to .spk then install on synology


(Vincent Ferreux) #78

Hi all.

Did you too have problems with timestamp and date with DST this night ?

If it could help, there is in the start-stop-status.sh

#set the current timezone for Java so that log timestamps are accurate
#we need to use the modern timezone names so that Java can figure out DST
SYNO_TZ=
cat /etc/synoinfo.conf | grep timezone | cut -f2 -d'"'
SYNO_TZ=
grep "^${SYNO_TZ}" /usr/share/zoneinfo/Timezone/tzlist | sed -e "s/^.*= //"
grep "^export TZ" ${DAEMON_HOME}/.profile > /dev/null \
&& sed -i "s%^export TZ=.*$%export TZ='${SYNO_TZ}'%" ${DAEMON_HOME}/.profile \
|| echo export TZ=\'${SYNO_TZ}\' >> ${DAEMON_HOME}/.profile

Thanks to MinimServer Syno Package author and Patter from pcloadletter, this could help :

#set the current timezone for Java so that log timestamps are accurate
#we need to use the modern timezone names so that Java can figure out DST
SYNO_TZ=
cat /etc/synoinfo.conf | grep timezone | cut -f2 -d'"'
#fix for DST time in DSM 5.2 thanks to MinimServer Syno package author
[ -e /usr/share/zoneinfo/Timezone/synotztable.json ] \
&& SYNO_TZ=
jq ".${SYNO_TZ} | .nameInTZDB" /usr/share/zoneinfo/Timezone/synotztable.json | sed -e "s/\"//g"\
|| SYNO_TZ=
grep "^${SYNO_TZ}" /usr/share/zoneinfo/Timezone/tzname | sed -e "s/^.*= //"
#Before DSM 5.1
#SYNO_TZ=
grep "^${SYNO_TZ}" /usr/share/zoneinfo/Timezone/tzlist | sed -e "s/^.*= //"
grep "^export TZ" ${DAEMON_HOME}/.profile > /dev/null \
&& sed -i "s%^export TZ=.*$%export TZ='${SYNO_TZ}'%" ${DAEMON_HOME}/.profile \
|| echo export TZ=\'${SYNO_TZ}\' >> ${DAEMON_HOME}/.profile

What you think ?
Works with DS710+ and DSM5.2.

Regards,

--
Vincent
Alter&Coop


(Christian Häussler) #79

Hi, I fix the new 1.8.2 Packages, try it, please!


(wolf_from_the_north) #80

I will test it cause i to still have the problem with timezone not beeing correct, even shen using astro and ntp binding. Grtz


(wolf_from_the_north) #81

can you please clarify what you mean with this ? i have allready 5 months an issue with timezone and can't get it solved.
can you tell us what needs to be changed and where in 5.2 dsm ?