Synology DiskStation

synology
Tags: #<Tag:0x00007f1824699158>

(martiniman) #41

Installing demo - Doesn’t help.


(Ivan Hörler) #42

Hi
Im a bloody newbie to this hole stuff. So please be patient if i don’t declare my problems quite as you wold suspect.
I Installed 1.5 as it was the only .spk file i found. (still currious how some people installed the 1.7.1**.zip **version)
The Installation worked, and i then installed also the demo on the syno and the App for OSX.
I then pasted the url i found in the installation, to the app internal browser and tata! there it is.
But now i tryed hard to find a way to access the config path. Over several ways, and nothing helps to find the config files…
I tryed FTP with root but that doesn’t let me connect.
So i tryed admin and there i can see the homes/openhab/.profiles but no config.
So i searched for solutions over the net and found OSXfuse, Installed it and used Macfusion to connect over sshfs. -What never worked, nether with admin or root or other users.
So i tryed to go in with terminal and there with ssh, i can reach the syno even with root, admin and a user without problem. But i have no idea how to use that terminal stuff…
So i tryed again with Fillezilla (as i did for FTP) with SFTP and that works again only with the admin not the root.

so im compleetly stucked and can’t access the Config files to get my openhab set up.
Can somebody help?

Regards, Novski


(Mark Lavercombe) #43

I use winscp for windows, there might be something similar for Mac.

The config files are in volume1/@appstore/OpenHAB/ on my synology. Have a look in the volume and find the @appstore.


(Ivan Hörler) #44

ok. i used a windows and i can access it with root there. i now know where the config is stored.
I have to search for a solution that lets me use the openhab.app on osx. i can’t configure my openhab config on on the windows i used now to test…
Or can i make openhab grab the config in a different folder on the syno?

And another question:
What is the password of the automaticaly generated openhab user?
Regards, Novski


(Ivan Hörler) #46

@Nicola_Reina, I don’t understand. Whats about a Flag?


(Nicola Reina) #47

does not matter… I deleted the post and cannot access it anymore.
The problem was solved and… cannot even remember … :smile:
thanks

I managed to install openhab on the synology but after a while I have the nas really going slow in terms of reactivitry
I have a 212 . too small?


(Will) #48

Since the recent updates of DSM, Synology allows running docker containers.
This is very sweet! You can take a good image or make your own, inject your config file and you are up and running.

I did not test yet with OpenHab but that should be trivial to get it to run. Docker is not available on all the Synology NAS though. I guess it is limited on the very small version as it would run too slow.

So far, the only issue I got with that is that you need to expose a device to the container is you want to use a USB device. That is unfortunately not supported by the DSM GUI so far and I did not find an alternate option yet.


(martiniman) #49

Hi! Please help with creation of bash script for Synology OH start-stop-restart.
Maybe anyone have this one?


(Federico) #50

Look at the memory consumption, that’s where the bottleneck is.


(Nicola Reina) #51

Hi (or ciao ?)

I am going to check.
If there is the hog does it depend only on OpenHab (I guess not) or on other packages too?
Where shall I tweak it?

TX


(Federico) #52

Packages might increase it a bit but the main package requirements are quite big. I think the ds212 only has 256MB of RAM, I don’t think it’s enough.


(Nicola Reina) #53

right 256MB


(Christian Häussler) #54

I updated my Synology DiskStation package to release 1.8.0:


(orange waters) #55

Just installed 1.8.0 spk. It works ! Thanks.


(Tom Lafleur) #56

OK, I’m missing something…

I updated my Synology DiskStation package to release 1.8.0:
https://github.com/cniweb/openhab-syno-spk/releases

points to a ZIP file, not a SPK file??


(SiHui) #57

Extract the zip und you will have a spk …


(Christian Häussler) #58

Has anyone else problems with the time zone?
See Issue: https://github.com/cniweb/openhab-syno-spk/issues/5
Please give me feedback on the Issue!

Thanks,
Chris


(Tom Lafleur) #59

when I unzip it , i get a directory of file… not a SPK…


(Tom Lafleur) #60

use a different tool, to unzip, NOW I get a .spk…

thanks for the pointer…


(orange waters) #61

@cniweb, any chance of getting the openhab2 beta2 spk. I see openhab2 beta1 spk in the releases on github.

Thanks a ton for your support to Synology community !!!