Synology DSM Package Center: Download Problem of openHAB2

Since a few days there are a problem to download the openhab2 installation package with
the Package Center of the DSM 6

I used the OpenHAB- from GitHub but get the following error message:

There was a probelm downloading from the official donwload link, wich was “

Should be because there is no offline snapshot anymore…


The new link is:

Synology package manager throws an error “Invalid file format” with the linked .zip file.

Discussion with some successful quick fixes, looks like the Synology build needs to be tweaked:

See the last two entries in this post


I released 2 new versions: (Final 2.0.0) (SNAPSHOT 2.1.0)

Try it, please.


Guys , just to mention , there are allot of persons on 5.2 and not on DSM 6.0
so we cannot join the openhab 2 for the moment.
any release planned for 5.2 ?

Tried yesterday, downloading still a problem as well as finding the zip in the public.
Also it does not start


i had the same Problem - and today i found the solution for me.

Please connect with Putty to your Synology and use the following command:

`sudo ipkg remove wget`

After i used this i had no more Problem to install openHAB2 on my 214play.

I hope, this works for you too.

Ah - and if you can´t open the XXX.XXX.XXX.XXX:8080 after installation - reboot your Synology.


@wolf_from_the_north yes, I plan it. Do you need 2.0.0 Stable or 2.1.0 SNAPSHOT? Or both?

I would like to see both as now i am using the beta installer script with latest stable zip
Kindest regards

Wath is this? Your own script? Can you post it?

Dear i believe its yours.
On the official downloadpage i found a beta spk for syno 5.2
I used that installer together witht the zipfile of the official release.
And that worked perfect.
Checking the files i saw that karaf was in a different map, so i believe thatthere must be a small difference.

Kindest regards

I had problems to reach the web interface. After deinstalling “webstation” on my synology nas it works.