Synology DiskStation

and, i think, one of the reasons why snapshot 7 doesn’t work is because it installs to

/volume1/@appstore/openHAB2/

instead of

/volume1/@appstore/OpenHAB2/ (which is where snapshot 5 and earlier installed to.

Hello,

I am beginner with home automatization and I would kindly ask you for your help.
I have Synology DS214se with DMS 6.0.2.8451 Update 2, AeoTec USB Z-Wave stick and thermostat Heatit.
I need help with installation OH2 on Synology. I installed Java8 and OH2 2.00.007-SNAPSHOT-DSM6. To folder addons I copied habmin.jar.

I can start OH2 and get to startpage with Paper UI, Basic UI, Classic UI and Habmin UI. I choose some UI but when I select Paper or Habmin UI I´ll get error message “Error503 (Jersey is not ready yet!)”.

What does the error message mean? How can I fix it? Can you help me?

Just for info.
I have OH1 installed, i stoped it, and install 2.0.0.008-SNAPSHOT-DSM6 for first time, it installed and started normally.
I got access to paperUI on 8080 port.
Synology 214play DSM 6.0.2-8451 Update 4

Hi,
I have just learnt about OpenHAB and am interested in getting the server up and running. I have a Synology and it’s always on, so thought that would be a great place to run it.

I feel like what I need to know is right in front of my face and I can’t see it, so I’m hoping someone can point me in the right direction (and it’ll help someone else).

I’m checking out the packages at https://github.com/openhab/openhab-syno-spk/releases, specifically OpenHAB-2.0.0.008-SNAPSHOT-DSM6-syno-noarch-0.001.spk and OpenHAB-1.8.3-syno-noarch-0.001.spk (both having the same issue).

After downloading, I went to the Synology (running DSM 6.0.2-8451 Update 4) > Package Center > Manual Install, I then select the package and get the error:

This package does not contain a digital signature.

To fix that I went to Package Center > Settings, and set the Trust Level to Any publisher.

Now when I go to upload the package I’m getting the error:

Port undefined configured for this package is either used by another service or reserved for system use. Please disable or modify the conflicting service, or contact the developer to modify the package configuration.

Obviously I don’t know what that port is, but I do have a number of other community packages installed which may well conflict with one of the ports.

Do you have any suggestions as to how I would investigate this further? Is there a Read Me or similar that outlines the correct steps to take to install it?

Thanks in advance!

I’m still on OHB 1.x, but the ports should be the same after a quick view in the installation docs.
HTTP_PORT=8080
HTTPS_PORT=8443
TELNET_PORT=5555
maybe a demo port for http=9080

In the synology control app --> security --> firewall --> profile --> defaults you can see all open and there obviously needed ports for synology. Just for the installation I would change it and free up the ports listed before. After that rechange and modify OHB 2 ports throough start.sh i.e.

1 Like

Hi.
@cniweb, :pray: please fix Synology package regarding to new changes and thank you for your work.

I´m working on it!

1 Like

A new release is finished!
Try it, please.

1 Like

It works!
Thank you.
DSM 6.0.2-8451 Update 8

hi Christian, I’ve just installed snapshot 9, and it works great - thank you. :smile:

However, it’s not using /volume1/public/openHAB2/conf as the config location despite it existing and owned by the openhab2 user before I installed this version (it’s never worked for me to that location in any of the previous versions). Instead it uses the conf directory in the program folder /volume1/@appstore/openHAB2/conf/.

Is there a specific thing I need to do so that the install will use /volume1/public/openHAB2/conf ?

hi,

it works, accept that problem with the config location.
I have the same problem as @DSTM

Thx. :slight_smile:

System:
DS216+II
DSM 6.0.2-8451 Update 8

Update:
I followed these Instructions and mount the whole /volume1/@appstore/openHAB2 to /volume1/public/openHAB2

http://www.synology-wiki.de/index.php/Mount_Bind

Hi gays,

I released 2 new versions:

2.0.0.001-DSM6 (Final 2.0.0)
2.1.0.001-SNAPSHOT-DSM6 (SNAPSHOT 2.1.0)

Try it, please, Thank you!

One question: I think we need no new versions for OH 1.x and DSM < 6.0 Packages, or?

Chris

Hi Chris
just tried snapshot 2.1.0. It installs fine, the services run on my DS413, where - thanks to @§$%§& Oracle - only an old java8 version runs, as they do no longer support PPC architecture.
However, the openHAB2 directory on public does not seem to be discovered. Or must it be OpenHAB2 (capital O)? At least I have a sitemap in there, which is not seen by the classic UI.
btw it there a password for the openHAB2-user?
Thanks for the great work,
Thomas

It’s my very first try to install ANY Synology package, so I am not sure if I missed something or if the package indeed lacks some signature?

I’m running DSM 6.0.2-8451 Update 9 on a DS716+II.

sorry not in german :slight_smile:

Thanks, I just found that myself - this indeed solves my issue :thumbsup:

I’m up and running on my DS916+. The only thing I also noticed is the user configuration files in /public/openHAB2 folder are not being picked up. Which .cfg file can we edit to re-reference the path?

Dear all,

Please bare in mind that all people running on XPENOLOGY which is a bare metal self build with SYNOLOGY OS will need a install version for 5.2 and not 6.0.
currently i am unable now to setup OPENHAB 2.0.

kindest regards

I tried the docker image on xpenology DSM 6.0 a few weeks ago - it worked fine. Although I haven’t worked out how to get my xpenology DSM 6.0 to recognise my Z-Wave stick.

managed to install the package on my dsm by editing the install spk to my version of dsm so the check goes trough.
it installed fine exept i had to download the zipfile manually and place it in the public folder.
New problem , package is not starting as seen in many threads, can’t find the karaf folder