Synology USB configuration (udev rules)

Following all the recent work that people have done to get the serial drivers working on the Synology, I’m moving my OH server back on to the Synology :smile:

Can anyone point me to a udev rule configuration for the Synology? The rules I’ve previously used on my odroid to configure filxed ports (which are similar to the udev rules on the OH wiki) don’t appear to work with the Synology…


Hi @chris ,
did you got this working ? if yes ,can you share the USB configuration on synology ?

No - I never got this working. Thankfully I don’t remove the stick very often so it doesn’t bother me too much (but I would still love to resolve it if someone knows how).


I got it working today ill update this post with the details in a few minutes.

I have created a group “homeautomation” and added the root user and openhab to the group.

created /lib/udev/rules.d/50-usb-zwave.rules with the following:
SUBSYSTEM==“tty”, ATTRS{idVendor}==“0658”, ATTRS{idProduct}==“0200”, SYMLINK+=“USBzwave”, GROUP=“homeautomation”, MODE=“0666”

** the IDs are for aeotec z-stick gen5 , if you use a different stick ,change to the correct ids .

add the following in openhab start script :

update the zwave binding port config :
zwave:port = /dev/USBzwave


I just struggled 2 hours with this udev rule. The problem was, that I copied the content from this post, but it did not worked.

The problem was that the quoation mark was not the ordinary quotation mark (“"” U+0022 Quotation Mark Unicode Character). It was the right quotation mark (“”” U+201D Right Double Quotation Mark Unicode Character).

Be aware of this, if you don’t want to waste a lot of time! :crazy_face:

Btw: I am using the ZME_UZB1 stick and it has the same attributes as the aeotec z-stick gen5.

I also noticed the fancy quote characters which won’t work, but I also wanted to share the settings I have found work very well on my Synology and Nortek card.

cd /lib/udev/rules.d #(where udev rules are stored)
sudo vi 99-openhab.rules #(create a new rule .rules is mandatory)
DRIVERS=="cp210x", ATTRS{interface}=="HubZ Z-Wave Com Port", SYMLINK+="zwave",OWNER:="root",GROUP:="root", MODE:="0666"
DRIVERS=="cp210x", ATTRS{interface}=="HubZ ZigBee Com Port", SYMLINK+="zigbee",OWNER:="root",GROUP:="root", MODE:="0666"

Then complete these steps/commands

# Every Synology update you need to recreate the 99-openhab.rules file
sudo udevadm control --reload
# disconnect and reconnect the device