Systematic un-installation of all bindings everytime I try to install a new one!

  • Platform information:
    • Hardware: RPi4
    • OS: Openhabian
    • openHAB version: 2.5 M4

Hi, I have a strange thing happening every time I try to install a new binding : The first consequent action seems to be to uninstall all other binding… Big mess and I don’t understand what can generate this behaviour.

See the traces below. Any hint would be greatly appreciated. Thanks,

2019-11-24 10:54:06.267 [thome.event.ExtensionEvent] - Extension 'binding-astro' has been installed.
==> /var/log/openhab2/openhab.log <==
2019-11-24 10:54:10.401 [INFO ] [core.karaf.internal.FeatureInstaller] - Uninstalled 'openhab-binding-http1'
2019-11-24 10:54:10.456 [INFO ] [b.core.service.AbstractActiveService] - HTTP Refresh Service has been shut down
==> /var/log/openhab2/events.log <==
2019-11-24 10:54:10.404 [thome.event.ExtensionEvent] - Extension 'binding-http1' has been uninstalled.
2019-11-24 10:54:13.892 [hingStatusInfoChangedEvent] - 'mihome:sensor_magnet_aq2:158d0002725b7d' changed from ONLINE to UNINITIALIZED
2019-11-24 10:54:14.829 [INFO ] [core.karaf.internal.FeatureInstaller] - Uninstalled 'openhab-binding-mihome'

And it goes on like this, unnstalling very consistently everything :frowning:

Does it still do this with Milestone 5?

did not try M5 yet. I had the impression that it was not yet as fully stable with some people having strange behaviours with zwave… I can try it.

Zwave works fine for many of us. I think some people have issues with some other bindings using serial interfering.
We are getting really close to Milestone 6 and then release on December 15. We need to work together to make sure this is well tested.

ok, will give it a try then. It is not easy to get a good feel of the how things are going when only reading the thread on issues:-) I’ll report back when done.

How are you installing the bindings? Have you ever used addons.cfg?

Hello Rich, thanks for chiming in. I was trying to install astro binding, from Paper UI.
I don’t think I used addons.cfg. My config is a recently rebuilt from scratch config.

Since then I tried to upgrade to M5 as per Bruce’s suggestion and then the startup of openhab stops at the dashboard launch and then nothing.

When running M4 I have a setup with zero errors when starting and running it, so was hoping I was on a good ground:-)

Double check that all the lines in addons.cfg are commented out. This behavior looks a lot like the addons.cfg is overriding what your do in PaperUI. If everything is commented out, try a Clear the Cache.

I just checked, all lines, except the empty ones in between are commented out. I did the clear cache thing but I need to check that I did it the right way for my openhabian config.

And this how I cleared the cache, but I read the topic a bit more and I see that it might not be the right way, so I’ll try again with the openhab-cli command.

sudo rm -rf /var/lib/openhab2/cache/*
sudo rm -rf /var/lib/openhab2/tmp/*

I did the right clean-cache and I still get those things:

2019-11-24 18:57:02.885 [ERROR] [org.openhab.core.ephemeris          ] - bundle org.openhab.core.ephemeris:2.5.0.M4 (143)[org.openhab.ephemeris(52)] : The activate method has thrown an exception
java.lang.IllegalArgumentException: No enum constant java.time.DayOfWeek.( "MONDAY"
2019-11-24 18:57:02.953 [WARN ] [org.openhab.core.model.script       ] - FrameworkEvent WARNING - org.openhab.core.model.script
org.osgi.framework.ServiceException: org.apache.felix.scr.impl.manager.SingleComponentManager.getService() returned a null service object
	at org.eclipse.osgi.internal.serviceregistry.ServiceFactoryUse.factoryGetService( ~[?:?]
	at org.eclipse.osgi.internal.serviceregistry.ServiceFactoryUse.getService( ~[?:?]
	at org.eclipse.osgi.internal.serviceregistry.ServiceConsumer$2.getService( ~[?:?]
	at org.eclipse.osgi.internal.serviceregistry.ServiceRegistrationImpl.getService( ~[?:?]

I get pages of them and finally openhab looks stuck:-( these are the last lines of the log

2019-11-24 18:57:14.414 [.ItemChannelLinkAddedEvent] - Link 'Popp7_BatteryLevel-zwave:device:afec7d1e:node2:battery-level' has been added.
2019-11-24 18:57:14.415 [.ItemChannelLinkAddedEvent] - Link 'Popp7_Setpoint-zwave:device:afec7d1e:node2:thermostat_setpoint_heating' has been added.
2019-11-24 18:57:21.951 [thome.event.ExtensionEvent] - Extension 'binding-astro' has been installed.

Not sure what to do from here. I’ll restore a backup, I have become expert in this now since I’m facing this problem;-)

ok, so, this is where I’m:

  • My current config with M4 is super stable and no errors in the trace
  • Everytime I try to add a binding, I destroy the config as per the first post of this topic
  • If I try to upgrade to M5, I also get into a mess, very similar to above case, lots of Java errors and openhab does not finish to start

My conclusion, as this stage: there must be something corrupted with my current config that does not show up at all while running with the current set of bindings & with M4.
Currently, on this setup when not challenged by a new binding or M5, i have this:

[23:07:14] openhabian@openhab:~$ sudo journalctl -u openhab2.service -b
-- Logs begin at Sun 2019-11-24 21:17:01 CET, end at Sun 2019-11-24 23:07:17 CET. --
Nov 24 22:33:59 openhab systemd[1]: Started openHAB 2 - empowering the smart home.
Nov 24 22:35:06 openhab karaf[479]: ipHost=
Nov 24 22:35:06 openhab karaf[479]: param2=9876
Nov 24 22:35:06 openhab karaf[479]: command=13 /param1=-1062705904 /param2=9876 /param3=0 /param4=0

I’m in the process of trying to replicate the setup on a different Pi so that I can let the current one run happily and I can spend more time looking for the cause of the problem without being stuck my openhab down the entire time.

1 Like

ok, so, it does not look any clearer I’m afraid. I have now built different additional environments to easily switch to a test environment and test and see where that gets, and switch back to the working one to avoid a too long down time…

  • attempt to install a new binding (astro) + stop, clean-cache, stop : openhab uninstalls all other bindings and does not restart - see above
  • attempt to upgrade to M5 via apt upgrade + stop, clean-cache, stop : openhab tries to restart but stays stuck in the restart process after many java errors - see above
  • attempt to ugrade to latest versions from openhabian-config + stop, clean-cache, stop : openhab tries to restart but stays stuck in the restart process after many java errors - same as above
  • I have tried a purge + re-install of 2.5 but gets again a bunch of java errors…
  • I have tried to reinstall 2.5 M4 on top of existing one (2.5 M4 as well) and get the same style of java errors

I can update all other packages than openhab without a single problem. Basically, anything related to openhab that I touch on this config seems to be super fragile and will not survive any type of change of the packages even if re-installing the same version over.

Any suggestion on where to look?

More info. Looking at the symptoms, I thought there might be a problem with Java itself, so tried to re-install it…
This is what I see:

[10:48:19] openhabian@openhab:~$ java -version
openjdk version "1.8.0_222"
OpenJDK Runtime Environment (Zulu8.40.0.178-CA-linux_aarch32hf) (build 1.8.0_222-b178)
OpenJDK Client VM (Zulu8.40.0.178-CA-linux_aarch32hf) (build 25.222-b178, mixed mode, Evaluation)

[10:48:31] openhabian@openhab:~$ sudo journalctl -u openhab2.service -b
-- Logs begin at Thu 2019-02-14 11:12:03 CET, end at Sun 2019-12-01 10:52:15 CET. --
déc. 01 10:47:18 openhab systemd[1]: Started openHAB 2 - empowering the smart home.
déc. 01 10:48:41 openhab karaf[478]: ipHost=
déc. 01 10:48:41 openhab karaf[478]: param2=9876
déc. 01 10:48:41 openhab karaf[478]: command=13 /param1=-1062705904 /param2=9876 /param3=0 /param4=0

Zulu does not appear in the list when I run dpkg --get-selections…
I can’t purge zulu because it says it is not installed ! I can’t re-install it because there seem to be no version available of zulu-embedded-8 on my system…
And yet, openhab is running just fine!

Just in case, i’m running openhabian on a Rpi4, if this could be relevant?

That is because Zulu was not installed as a package. OpenHABian can reinstall Zulu if you wish.

Thanks Bruce.
I tried to re-install zulu via openhabian, but I still jave the same symptoms. I give up trying to understand what the problem is and will rebuild a configuration from scratch, as I have no idea where to look and what can cause this strange behaviour…