Table of contents for lots of home services

This is pretty off topic but I’m frustrated with Google Chrome right now.

So my problem is no matter what I set my DNS setting to and no matter how I format my URLs, most of the time (not always) when I type in the URL for one of my internal services, like openhab, it treats the URL as a search instead of bringing up the service’s webpage.

Other browsers work fine but we’ve pretty much settled on Chrome for now. But that does show that the internal DNS is working just fine. And using the IP address works so the network access is just fine.

But if I try to bring up http://fafnir,,, or any other combination most of the time I end up with a Google search instead of my OpenMediaVault login page.

I’ve searched a bit and the only way to make it work is to completely turn off address bar search, which I may end up having to do.

But I’ve been planning for awhile to create a sort of home page with links to all of my services and then I can click from there.

So my question is, what do you all who are running lots of home services use?

I thought of adding everything to the OH Dashboard but I really have too many services to make that very user friendly. Counting my firewall and router and all the sonoffs and esp easys I’m looking at 30 or so URLs.

I’m not really interested in using a sitemap or habpanel for this. I don’t think it is well suited for this use, though could be convinced otherwise.

My first idea is to just set up an NGNIX and build a static web page, or maybe even just dump a static webpage in OH’s html folder. But I figure there might be some framework or JS library people may know of to make building something like this a little easier and/or look nicer than a list of hyperlinks.

Suggestions are welcome!

I cannot directly answer your question, but may help you to prevent your problem.

For me it is often the other way round.
I want to search for something (e.g. homie) and ent up at my web service homie-ota/.

What helps is to use different shortcuts to access the Adress bar.

If you use Ctrl+K you just jump to the omnibar and Chrome decides on its own whats best.
If you use Ctrl+L you jump to the same place, but it is only the address bar without the search feature.

To force a web search in the addres/omnibar you start the query with a ?


The key combos work great on the computer but it’s from the phone where I’m having the most trouble. One problem part is I tried to set up a Pi Music Box but I had to take it down because I couldn’t give my wife an easy to use link to access the UI.

But thanks for the hint on the key combos. That will help me on my computers for sure.

@sihui, is there an equivalent for the phone Chrome you know of? Doh, just needed to scroll down a bit further. Yes, there is an Android app. Also, I am finding that it and Workona don’t like to live together because they both want to control the new tab. But I think I’m going to play with it a bit more because this is exactly what I’m looking for, I just wish it were cross desktop and phone.

Thanks for the suggestions! They certainly help.

Hi Rich (@rlkoshak),

I run several services on various VMs and older systems here. From my phone I just tried hitting those that serve web pages and encountered no problems, even though I don’t usually access most of them from my phone.

One thought I had is your DHCP server’s DNS server configuration, does it provide more than one DNS server when a DHCP client connects? Some time ago I encountered some issues that resulted from my DHCP server’s configuration – it was providing both my LAN DNS server and a second DNS server address of (Google’s public DNS server.) When I changed the DHCP server’s configuration to hand out only my internal DNS server, life was good and has been since then, for both internal and outside DNS lookups.

Whenever I encounter odd DNS issues, one of the first things I do is look at the content of /etc/resolv.conf (I run linux almost exclusively here.)

Hope you get it sorted out.

EDIT: I should have noted that my browser of choice is Chrome on my primary desktop and other general usage PCs as well as on my wife’s and my phones (Android.)

Thanks for the reply. I am only serving out the one DNS server, my internal one. And I can ping these servers by name, just hostname or FQDN. I can access all the web pages without problem using Firefox or Edge without problem. And I’m finding when I use Christoph’s ctrl-L trick it works every time, at least every time I’ve tried it.

So despite a wonky DNS config being my first thought everything seems to check out. I’ll also note that I’ve tested this on Linux, Windows 10, OSX and Android (haven’t tried it from my wife’s iPhone yet). The problem is by far the worst on my Android phone’s chrome browser.

And it isn’t every server, just some that seem to cause problems which is weird as they are all pretty much configured identically in the DNS/DHCP with their only difference being their FDQN and IP address.

Rich I have found that in some chrome update on my phone this just started being a problem.

Prior to that I could type wifipi:8080 and hit my openHAB. It definitely appears that it is something that chrome did.

1 Like

Bookmarks :slight_smile:
Serious - I havn´t got this problem. And havn´t heard of it before. Are you using any kind a proxy or anything simular??

Chrome version:
Version 69.0.3497.100 (Officiel version) (64-bit)

As I have another VM with an apache2 installed, I use a static html file (well, three files…) :slight_smile:

1 Like

No proxy or anything wired. Just DHCP serving out static IPS to all of my devices and a local and server.

The weird thing is it isn’t consistent. For example, I can get to my OH without fail. I can almost never get to my Pi Music Box unless I use IP. I can get to my openmediavault about half of the time.

I know that hassle, too, and maybe I didn’t catch the point, but what’s wrong with using good ol’ bookmarks ?
Using Firefox and a Mozilla service, it replicates these to all devices I’m accessing from. Not sure but Chrome should be able to do the same.
You could also export bookmarks to some webserver to have them as a landing page.

WIth DNS i recnetly had the Problem, that i was not able to resolve internal names if i am connected to the wlan.

But if i understand you question right, you are looking for a way to have some kinde of dashboard to simply access all services.

I jsut build a folder with bookmarks for that. works on the pc and my mobile

That´s weird, I agree.
I wonder if it could be the ARP cache in your OS, in your router or perhaps maybe even in your switch…
If it´s windows you could try clear the ARP cache. I have no idea in other OS´s.

Nothing is wrong with it and it certainly is an option. But I was hoping for an approach where I wouldn’t have to set up the book marks twice, once for me and once for my wife. It would also be nice to set something up I can point guests to to access some of the services like Plex and the Pi Music Box. So from that perspective, a static webpage or pages would work better than bookmarks.

That is possible and I’ve not really looked into it that thoroughly. But if I remember my networking I think the entries in the ARP table clear themselves out after a not too long amount of time (60 seconds by default on Windows I think).

Playing with the default DNS suffix or default domain suffix search order might help… you can push them as DHCP options. Have you tried adding a trailing slash to the URL?

I’ll have to look into this a bit more. I use pfSense which is pretty configurable. More to follow if I figure something out.

Yes, and adding http:// to the front by hand and adding /index.html to the end as well. Sometimes once in a blue moon that will work but the rest of the time I end up with a google search.

Well it’s based on profiles so your wife can have her own, plus another dummy account for guests.
Dunno if that still works but I used to have “file:///path/to/bookmarks.html” as my browser home page for a long time. Instant landing page. Even if not you can automate exporting the saved bookmarks to a static web page.

It can still get corrupted and needs to be flushed.
What worries me is, that you say it´s only when using chrome… Thats weird.

I put a “/” after the server name which seems to stop the search, e.g. “openhab/” will take me to my openhab server without the search, or “openhab:7070/” etc. On the default port 80, I have a simple page with links to various local services, e.g. CCTV cameras, openHAB, Evohome heating control etc.

Hi, I use a reverse proxy (traefik) & DNS Server (pihole) to get an own toplevel domain. So all my services are below this domain (openhab.loc, chronograf.loc, …). Chrome has no problem with that :sunglasses: