[TapoControl] - Control Tapo Smart WiFi-Devices with Openhab - Official Support Thread

I highly recommend you to set up a backup that does a full copy of the sd card. In case of anything fails, you just copy the backup over your sd card and boom you’re back to your working version again.
I’m doing automatic backups once per week and it’s been useful more than once in the past : sd card failure, update gone wrong, …
Just be sure to test your backup with another sd card the first time to be sure it’s consistent :wink:
With that sort of backup, you’re never afraid of testing anything.

The fix has been there since October and it works. I’m also curious to know when will it be merged and why isn’t it yet merged.

How have you got it working then would love to know I’m using windows

I downloaded the binding from the description and uploaded it to the /usr/share/openhab/addons/ folder. I deleted the official binding and configured the KLAP protocol for the devices with the latest firmware.
I use Linux (CentOS) and only have P115 plugs and a P300 power strip, so your issues may be device or Windows-related.

My Tapo things or the binding doesn’t go offline

@Bigdesaster,

Any news on when the PR would be merged?

Thanks for the feedback

This is not in my hands.
Can’t do more than create a PR and resolve reviews.
Already pinged the OH-Maintainers but got no response.

2 Likes

hello @Bigdesaster, i’m trying to update the binding using the jar from repository, but all of them are not working.
i’ve compared the jar i download some months ago (4.1.0) and the size is around 480kb, but if i download again the 4.1.0 from the repo, the size is around 200 kb. in fact if i put this into the addons folder, openhab replies with a package error. same for 4.2.0.

2024-02-01 14:25:10.972 [ERROR] [Events.Framework                    ] - FrameworkEvent ERROR
org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.tapocontrol [27]
  Unresolved requirement: Import-Package: com.google.gson; version="[2.10.0,3.0.0)"

	at org.eclipse.osgi.container.Module.start(Module.java:463) ~[org.eclipse.osgi-3.18.0.jar:?]
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel$2.run(ModuleContainer.java:1847) ~[org.eclipse.osgi-3.18.0.jar:?]
	at org.eclipse.osgi.internal.framework.EquinoxContainerAdaptor$1$1.execute(EquinoxContainerAdaptor.java:136) ~[org.eclipse.osgi-3.18.0.jar:?]
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1840) ~[org.eclipse.osgi-3.18.0.jar:?]
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1783) ~[org.eclipse.osgi-3.18.0.jar:?]
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1745) ~[org.eclipse.osgi-3.18.0.jar:?]
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1667) ~[org.eclipse.osgi-3.18.0.jar:?]
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1) ~[org.eclipse.osgi-3.18.0.jar:?]
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:234) ~[org.eclipse.osgi-3.18.0.jar:?]
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:345) ~[org.eclipse.osgi-3.18.0.jar:?]

i’m running OH on raspy and the version is: openHAB 4.0.0-SNAPSHOT - Build #3479.
could be this the problem?

Hi @Bigdesaster
I really appreciate your work.

Please keep us informed about any news.

Thanks.

On my openHAB Instance i only have the ability to change ip adress and refresh interval

Have you flagged the check box for advanced options?


yes but there are not more options

This still means that I have to upgrade my system to OH4 to get the latest binding? (fixing 1003 error)

The official release has the same issue. You could try manually installing the jar, but that didn’t work for me also.