The APT/RPM 'testing' (Milestone) repository has moved

Hi all,

Due to some space restrictions on the Bintray repository, we are now using Artifactory as our main testing (milestone) repository. Don’t worry, all previous milestones are available in Artifactory if you need them, so downgrading will still work after the move if you need it.

The following is only relevent to those wanting the latest milestone releases.

If you’re on the old Bintray repo for testing, simply run the commands: You’ll need to update your source lists to accomedate the change:

openHABian

From the openhabian-config menu select option 40, then select the testing option.

Standalone APT (Debian/Ubuntu etc)

Simply run the commands:

echo 'deb https://openhab.jfrog.io/openhab/openhab-linuxpkg testing main' | sudo tee /etc/apt/sources.list.d/openhab2.list
sudo apt update

RPM

Replace the file /etc/yum.repos.d/openhab.repo with the following contents:

[openHAB-Testing]
name=openHAB 2.x.x Testing
baseurl=https://openhab.jfrog.io/openhab/openhab-linuxpkg-rpm/testing
gpgcheck=1
gpgkey=https://bintray.com/user/downloadSubjectPublicKey?username=openhab
enabled=1

As always, please let us know if you run into problems. :slight_smile:

Kind Regards,
Ben

9 Likes

Have we updated the key for signing, i.e. we are not using the old expired one?

The public key was updated yes, but it looks like Bintray won’t take the private key now, I do not have this so will take this through PM with the relevant people.

Artifactory (which stages the testing and stable releases) is working however, so for those who really need the M2 release can use, we will probably make this the main testing repo soon anyhow:

deb https://openhab.jfrog.io/openhab/openhab-linuxpkg testing main
4 Likes

I have just update to m2. Let see how it spins.

so edit the
/etc/apt/sources.list.d/openhab2.list
change
deb https://dl.bintray.com/openhab/apt-repo2 testing main

to

deb https://openhab.jfrog.io/openhab/openhab-linuxpkg testing main

Regards S

Well this milestone build is a test of the new build chain too. Some minor hiccups are to be expected.

1 Like

It may take time for that repo to be sorted, but we will now be using Artifactory for future Milestone builds anyhow.

Anyone using APT/YUM should move to it..

Mmh, the old repo is hardcoded in openHABian.
I know this was not the intention but that was not the best choice for a last minute change really.
My own box fails to complete installation ATM because a) the old repo ain’t signed and b) the new one is not yet patched in.
@elias_gabrielsson https://github.com/openhab/openhabian/pull/661

Really? I just updated fine with openhabian-config last night. It used the new repo.

Hi, I just tried upgrading my OH2.5 M1 -> OH2.5 M2. (Not using openhabian)

I’m using Ubuntu VM and my configuration is 100% written my hand.

The pushbullet binding has been updated and Openhab cannot install it. I tried to remove the old binding and adding it again. Reconfigure it according to the new documentation. But I keep get an error it can’t install/start pushbullet But I have to look more into it. Maybe I missed something

Also a lot of my items is also broken. Sitemaps can’t show them correctly and I see a lot of errors in the log like cannot be resolved to an item or type. But again I just upgraded and haven’t looked into it too much.

I will try to create a new installation and restore my configuration. And will give an update of my findings :slight_smile:

I updated the openhabian repo and urls before I announced the change. I think you forgot to pull the latest changes before you made that PR.

The stable repo not being signed is a related, but different issue.

1 Like

Here is what I found so far about Pushbullet:

Error message:

2019-08-10 15:19:20.679 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-action-pushbullet'

When moving Pushbullet in 'runtime.cfg' from an action-addon to an binding-addon in: '/etc/openhab2/services/runtime.cfg'

The action configuration line in: '/var/lib/openhab2/config/org/openhab/addons.config'

action="pushbullet"

Is not cleaned up. Also after an cache/tmp cleanup it is still there

I removed the line and Pushbullet got installed and it works again :slight_smile:

Hope this helps :slight_smile:

Same thing with the REST API docs. They are now an addon under ui, not misc.

Hi again

With a new installation and making sure the rights for all files are correct

/bin/chown -R openhab. /etc/openhab2/*

Everything seems to work great again :slight_smile:

You are right, I did not think about it.

The installation are coming with a warning when upgrading :slight_smile:

Warning:  REST Docs: This add-on is now part of the UIs. When installing it using textual configuration, update 'services/addons.cfg' by removing 'restdocs' from 'misc' and add it to 'ui' instead.

Many people are ignoring the warnings.
Perhaps the installation should STOP until people acknowledge they have read the warnings.

You are quite right.
But sometimes the messages coming up are not always very helpful or for “normal” users incomprehensible.
And often, when one post a topic of such warnings, you get the answer from the cracks: “You can ignore it.It’s just a warning” :wink:.

I got this Warning too, when upgrading to M2. So I looked into “services/addons.cfg”
And what I saw was this:

# The installation package of this openHAB instance
# Note: This is only regarded at the VERY FIRST START of openHAB
# Note: If you want to specify your add-ons yourself through entries below, set the package to "minimal"
# as otherwise your definition might be in conflict with what the installation package defines.
#
# Optional. If not set, the dashboard (https://<yourserver>:8080/) will ask you to choose a package.
#
# Valid options:
#   - minimal  : Installation only with dashboard, but no UIs or other add-ons. Use this for custom setups.
#   - simple   : Setup for using openHAB purely through UIs - you need to expect MANY constraints in functionality!
#   - standard : Default setup for normal users, best for textual setup
#   - expert   : Setup for expert users, especially for people migrating from openHAB 1.x
#   - demo     : A demo setup which includes UIs, a few bindings, config files etc.
#
# See https://www.openhab.org/docs/configuration/packages.html for a detailed explanation of these packages.
#
#package = minimal

# Access Remote Add-on Repository
# Defines whether the remote openHAB add-on repository should be used for browsing and installing add-ons.
# This not only makes latest snapshots of add-ons available, it is also required for the installation of
# any legacy 1.x add-on. (default is true)
#
#remote = true

# Include legacy 1.x bindings. If set to true, it also allows the installation of 1.x bindings for which there is 
# already a 2.x version available (requires remote repo access, see above). (default is false)
#
#legacy = true

# A comma-separated list of bindings to install (e.g. "binding = sonos,knx,zwave")
#binding = 

# A comma-separated list of UIs to install (e.g. "ui = basic,paper")
#ui = 

# A comma-separated list of persistence services to install (e.g. "persistence = rrd4j,jpa")
#persistence = 

# A comma-separated list of actions to install (e.g. "action = mail,pushover")
#action = 

# A comma-separated list of transformation services to install (e.g. "transformation = map,jsonpath")
#transformation = 

# A comma-separated list of voice services to install (e.g. "voice = marytts,freetts")
#voice = 

# A comma-separated list of miscellaneous services to install (e.g. "misc = myopenhab")
#misc = 

As you can see, every line is commented out, means never used by the system. But I also found a solution in another topic here. So I looked into

openHAB-share\openhab2-userdata\config\org\openhab\addons.config

:org.apache.felix.configadmin.revision:=L"2"
action="mqtt"
binding="ntp,samsungtv,sonos,exec,network,astro,mqtt1,avmfritz,http1,openweathermap,homematic"
felix.fileinstall.filename="file:/var/lib/openhab2/etc/org.openhab.addons.cfg"
legacy=B"true"
misc=
package="expert"
persistence="mapdb"
remote=B"true"
service.pid="org.openhab.addons"
transformation=",regex,exec,map,jsonpath,javascript,scale"
ui="paper,basic,restdocs"

and found there the place to change.

But after upgrading I’m fighting with some other problems too.

The first one seems to be no problem as it’s an INFO on OH-Start, but I’d never had this before and I do not understand what is meant:

// Infomeldung beim Start M2 für Paper UI
2019-08-13 13:36:11.906 [INFO ] [org.openhab.ui.paper                ] - FrameworkEvent INFO - org.openhab.ui.paper
org.osgi.framework.BundleException: The bundle class path entry "patch/" could not be found for the bundle "osgi.identity; type="osgi.bundle"; version:Version="2.5.0.M2"; osgi.identity="org.openhab.ui.paper""
    at org.eclipse.osgi.internal.loader.classpath.ClasspathManager.findClassPathEntry(ClasspathManager.java:174) ~[?:?]
    at org.eclipse.osgi.internal.loader.classpath.ClasspathManager.buildClasspath(ClasspathManager.java:152) ~[?:?]
    at org.eclipse.osgi.internal.loader.classpath.ClasspathManager.<init>(ClasspathManager.java:81) ~[?:?]
    at org.eclipse.osgi.internal.loader.EquinoxClassLoader.<init>(EquinoxClassLoader.java:43) ~[?:?]
    at org.eclipse.osgi.internal.loader.BundleLoader.createClassLoaderPrivledged(BundleLoader.java:316) ~[?:?]
    at org.eclipse.osgi.internal.loader.BundleLoader.getModuleClassLoader(BundleLoader.java:233) ~[?:?]
    at org.eclipse.osgi.internal.loader.BundleLoader.searchHooks(BundleLoader.java:503) ~[?:?]
    at org.eclipse.osgi.internal.loader.BundleLoader.findResource(BundleLoader.java:600) ~[?:?]
    at org.eclipse.osgi.internal.loader.buddy.DependentPolicy.loadResource(DependentPolicy.java:82) ~[?:?]
    at org.eclipse.osgi.internal.loader.buddy.PolicyHandler.doBuddyResourceLoading(PolicyHandler.java:157) ~[?:?]
    at org.eclipse.osgi.internal.loader.BundleLoader.findResource(BundleLoader.java:649) ~[?:?]
    at org.eclipse.osgi.internal.loader.buddy.DependentPolicy.loadResource(DependentPolicy.java:82) ~[?:?]
    at org.eclipse.osgi.internal.loader.buddy.PolicyHandler.doBuddyResourceLoading(PolicyHandler.java:157) ~[?:?]
    at org.eclipse.osgi.internal.loader.BundleLoader.findResource(BundleLoader.java:649) ~[?:?]
    at org.eclipse.osgi.internal.loader.ModuleClassLoader.getResource(ModuleClassLoader.java:200) ~[?:?]
    at org.eclipse.osgi.internal.framework.EquinoxBundle.getResource(EquinoxBundle.java:532) ~[?:?]
    at org.apache.servicemix.specs.activation.Activator.register(Activator.java:58) ~[?:?]
    at org.apache.servicemix.specs.locator.Activator.start(Activator.java:70) ~[?:?]
    at org.apache.servicemix.specs.activation.Activator.start(Activator.java:46) ~[?:?]
    at org.eclipse.osgi.internal.framework.BundleContextImpl$3.run(BundleContextImpl.java:779) ~[?:?]
    at org.eclipse.osgi.internal.framework.BundleContextImpl$3.run(BundleContextImpl.java:1) ~[?:?]
    at java.security.AccessController.doPrivileged(Native Method) ~[?:?]
    at org.eclipse.osgi.internal.framework.BundleContextImpl.startActivator(BundleContextImpl.java:772) ~[?:?]
    at org.eclipse.osgi.internal.framework.BundleContextImpl.start(BundleContextImpl.java:729) [?:?]
    at org.eclipse.osgi.internal.framework.EquinoxBundle.startWorker0(EquinoxBundle.java:933) ~[?:?]
    at org.eclipse.osgi.internal.framework.EquinoxBundle$EquinoxModule.startWorker(EquinoxBundle.java:309) ~[?:?]
    at org.eclipse.osgi.container.Module.doStart(Module.java:581) ~[?:?]
    at org.eclipse.osgi.container.Module.start(Module.java:449) ~[?:?]
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1634) ~[?:?]
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1614) ~[?:?]
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1585) ~[?:?]
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1528) ~[?:?]
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1) ~[?:?]
    at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230) [?:?]
    at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340) [?:?]
2019-08-13 13:36:18.678 [INFO ] [.core.internal.i18n.I18nProviderImpl] - Time zone set to 'Europe/Berlin'.
------------------------------------------------------------------------------------------------------------------------------------------

I have a made a workaround for it, in the karaf-console

openhab> log:set warn org.openhab.ui.paper

setting the log to WARN. But now all Infos are suppressed (not the best way).

Even in the karaf-console I get this

openhab> bundle:list | grep -i paper
253 x Active x  80 x 2.5.0.M2              x openHAB UI :: Bundles :: Paper UI
openhab>

So I’m asking me what this INFO in the start-sequence stands for. I don’t know :innocent:. Do you ?:wink:

Cheers,
Peter

It appears you are running OpenHAB on Windows. The development & testing generally occur on Linux.

I hate to add complexity, but perhaps the new bulid system should include tests on Windows if it does not already do so. @Kai would know for sure what dev & testing occurs for Windows users.

Thx for reply. Sorry I forgot to say that I’m running OH on a RPi 3b

###############  openHABianPi  ################################################
###############################################################################
##        Ip = 192.168.178.49
##   Release = Raspbian GNU/Linux 8 (jessie)
##    Kernel = Linux 4.14.77-v7+
##  Platform = Raspberry Pi 3 Model B Rev 1.2
##    Uptime = 0 day(s). 1:17:14
## CPU Usage = 1.51% avg over 4 cpu(s) (4 core(s) x 1 socket(s))
##  CPU Load = 1m: 0.02, 5m: 0.08, 15m: 0.18
##    Memory = Free: 0.54GB (57%), Used: 0.41GB (43%), Total: 0.95GB
##      Swap = Free: 0.09GB (100%), Used: 0.00GB (0%), Total: 0.09GB
##      Root = Free: 24.54GB (87%), Used: 3.45GB (13%), Total: 29.21GB
##   Updates = 0 apt updates available.
##  Sessions = 1 session(s)
## Processes = 101 running processes of 32768 maximum processes
###############################################################################

              Welcome to            __  _____    ____  _
            ____  ____  ___  ____  / / / /   |  / __ )(_)___ _____
           / __ \/ __ \/ _ \/ __ \/ /_/ / /| | / __  / / __ `/ __ \
          / /_/ / /_/ /  __/ / / / __  / ___ |/ /_/ / / /_/ / / / /
          \____/ .___/\___/_/ /_/_/ /_/_/  |_/_____/_/\__,_/_/ /_/
              /_/
                  openHAB 2.5.0~M2-1 (Milestone Build)


Looking for a place to get started? Check out 'sudo openhabian-config' and the
documentation at https://www.openhab.org/docs/installation/openhabian.html
The openHAB dashboard can be reached at http://openHABianPi:8080
To interact with openHAB on the command line, execute: 'openhab-cli --help'

[15:43:30] hab@openHABianPi:~$
[15:43:56] hab@openHABianPi:~$ java -version
openjdk version "1.8.0_152"
OpenJDK Runtime Environment (Zulu Embedded 8.25.0.76-linux-aarch32hf) (build 1.8.0_152-b76)
OpenJDK Client VM (Zulu Embedded 8.25.0.76-linux-aarch32hf) (build 25.152-b76, mixed mode, Evaluation)
[15:45:38] hab@openHABianPi:~$

Sorry.
Windows is the only OS I am aware of that uses backslashes \ in path names. Most all other operating systems use slashes /. That is why I assumed Windows.
You are running Raspian 8 (jessie) which, I believe is now unsupported. I do not know if that relates to your log issues though,
I use 9 (Stretch) oldstable and 10 (Buster) is now current stable,

:+1: You have eyes like an eagle. I was just to lazy to enter the path, so I made it by copy and paste out of my editor (from the windows-side via samba-share).

But the news you gave me,are shocking me :scream:. I always made my updates and upgrades via openhabian-config and never found a hint to upgrade OS and how to do it. I only know that Buster is the OS for RPi4, but not for RPi3 :thinking: