Thermofloor/Heatit pushbutton4

Still no response to this problem.

Openhab 3.0 and 3.0.1 did not solve the problem. Still no communication with the switch.

After upgrading Openhab to version 2.5.9 the pusbutton is not in the database anymore.

Z-Wave Node 018 (019B:0300:A306:1.26)

Unknown Device

This device has not been fully discovered by the binding. There are a few possible reasons for this -:

  • The device is not in the database. If the device attributes show that this device has a valid manufacturer ID, device ID and type, then this is likely the case (eg. you see a label like " Z-Wave node 1 (0082:6015:020D::2.0) ").

Tried to add this device manually bit it conflicts with the faulty information in the database.
Anyone a solution for this, will there be a database update (or downgrade for this device, as it worked in the previous version).

Hi Pieter,
did you solve your problem? I have a similar problem with a brand new device on openhab 3.0.0 release build. see Heatit Z-Push Button 4 - Device discovery could not resolve to a thingType! 019B:0300:A306::1.26

Hi Kai, no, I could not resolve this yet. I’ve seen the switch once after a complete fresh installation from OH inclusive the initial new installation of the Aeotec controller.
The switch was properly discovered as the thing as it should be.
After adding another Thing (removing the Aeotec stick, including the new node and placing the stick back).
After restart the Heatit push button was again an unknown device.