Things > + sign in bottom right corner > Z-Wave Binding (NOT LISTING?)

  • Platform information:
    • Hardware: _Rpi 4
    • OS: openhabian
    • Java Runtime Environment: which java platform is used and what version
    • openHAB version: openHAB 3.4.0 Build #3072
  • Issue of the topic:
    In the ui I go : Things > + sign in bottom right corner > Z-Wave Binding (NOT LISTING?)
    z wave binding is not showing in the choose binding list on the add thing page so I can not put the binding in inclusion mode?

uninstalled the binding, cleared the case, reinstalled the binding, no result?

any ideas? or am I overseeing the obvious?

thanks!
Wannes

Do you see the binding using openhab-cli console?

yup :slight_smile:
openhab> bundle:list |grep ZWave
274 │ Active │ 80 │ 3.4.0.202209010348 │ openHAB Add-ons :: Bundles :: ZWave Binding
openhab>

binding perfectly loaded up and running…

Odd- No real answer

Do all your other bindings show up with the “+”?

Does anything else on the UI look odd?

Do you need the latest snapshot? Could you try to revert to 3.4M1 and see if the same?

Same here, tried to add a new Z-Wave device but no Z-Wave binding entry in “add thing” (+ sign). Run on latest 3.4.0-SNAPSHOT on Win10.
ReInstalling the binding did not help.

The zwave binding has really only had DB updates since the 3.4 M1 version (which I have been running for 3 weeks without a problem) I’m suspecting something in the core UI might be different with the snapshot version, hence my advice above to back off to that version.

edit: @J-N-K there seems to be an issue with a few people about the zwave binding not showing up. The only non- database change between 3.4M1 (which I have working) and the last build is #1798 PR. Could this be a problem?

Edit #2 - also this person on OH3.3 release

Could be. Probably it should be reverted and merged together with the core changes after 3.4 released. I can‘t do that.

Thanks for quick reply. @chris is on holiday with no internet access. Do you know anyone with merge/revert authority on the binding?

Do all your other bindings show up with the “+”?

  • yes

Does anything else on the UI look odd?

  • no

Do you need the latest snapshot? Could you try to revert to 3.4M1 and see if the same?

  • i will try that if i can find the time :slight_smile:

Thanks !!
J.

I have the same problem.
As a workaround its possible to use the URL.
http://XXXX:8080/settings/things/add/zwave.

Greetings

1 Like

Thanks!

@Agio - thanx a lot, didn’t know that workaraound!

I have the same issue. While the work around works it would be nice on how to fix this. I may not remember this URL each and every time a ZWave decides to go offline and I have to add it back in.

It was fixed about 5 days ago by the developer. Zwave snapshot 181 and beyond. Should be in the recent OH snapshot too, but IMO I would wait until OH3.4M3 unless you have some other pressing reason.

2 Likes

Thanks to the OP and contributors for this post. Bad timing on my part that I crashed into this bug. If I’d tried to debug my totally unrelated ZWave issue at a slightly different moment, I’d not have wasted a time figure out what was causing both zwave problems. :slight_smile:

If you have an aeotec zwave stick 5+ , unplug the stick , include the device and put the stick back to the controller. When the stick is online again, go to the thing + page and wake up the Batterie running device. The new device pops up on the screen ready for use. Works even better with power supplied devices .

This is not really the recommended approach. While it will probably work ok for most devices, it can cause routing issues, and will absolutely not work if you are using security in your system.

Is it the „offline inclusion“ you don‘t like? What is your recommendation for people who start with OH having a zwave stick full of included devices from other projects?

It’s not that I don’t like it - it will not always work. Specifically, this will not work for secure devices.

Again, it will work fine, but not for secure devices. If the devices were already included, then the mesh should be ok, and the binding will discover the attributes during the interview. However this will simply never work for any devices that use security.

I fully agree with you. I just thought of users running milestone and not having access to the z-wave binding.