Tip and Tricks to include devices that ... are against it

Due to upgrading and failing to find a viable path from a gen 5 stick to a gen 7 stick, I decided to rebuild my z-wave network.

I have a fair amount of devices but they are all accessible so it should not be that hard… so did I think…

Some devices do include failry easy and quick. For some however, I started scratching my head.

First of all, due to the lack of feedback in OH (there may be a way to tweak the logs ?), I decided to focus on the pure z-wave part, using PC Controller 5.

I have some non battery devices such as some Everspring AN158 that are VERY hard to include.
I suspect the reson being simply their switches and the difficulty to line up those 3 clicks, fast enough, but not too fast, often enough but not too often…

One may think that PC Controller 5 provides nice logs… well:
image

Here you go… so you know it did not work.
By chance I did get one to include, after lining up probably 10 clicks after waiting for the Add node failed to dequeue.

I would REALLY like to find a realiable way to include some of those devices.
It is easy to open some of the battery powered ones, but I am reluctant to open a 220V device to play with the micro switch on its PCB…

This post is a call to gather information and tricks related to inclusion…

Navigate to Settings → Zwave (may be hidden in the right most column under Add-on Settings, click “Show All”. You can change the logging level there to DEBUG or TRACE level logging. There’s an analysis tool for zwave logs at Z-Wave Log Viewer which can make reviewing the log easier.

But beyond that I don’t have much to offer. All I can say is to make sure that the device is either reset or excluded from the old network before trying to include it on the new controller. Note that you can actually do the exclude using the new controller, which is nice. Click “Exclude Devices” and do what ever the device says to do to include it (three clicks of the button I guess) to exclude it. Then try including it.

1 Like

Navigate to Settings → Zwave (may be hidden in the right most column under Add-on Settings, click “Show All”. You can change the logging level there to DEBUG or TRACE level logging. There’s an analysis tool for zwave logs at Z-Wave Log Viewer which can make reviewing the log easier.

Nice thanks !
Honnestly, my strategy is atm to troubleshoot “outdside” of OH to ensure the issue does not come from caching, needing a reboot, or such a ahrd to troubleshoot issue.

But beyond that I don’t have much to offer. All I can say is to make sure that the device is either reset or excluded from the old network before trying to include it on the new controller.

Yes, I do reset the device and that works. So I guess my triple-skills are acceptable.

Note that you can actually do the exclude using the new controller, which is nice.

Ist that so ??? Woo that’s good to know indeed. I did not expect that to work.
Although at that point, I prefer the reset option.

I am really trying to pin an option that “works no matter what” but so far it looks like I need to spamm the device button like that for a few hours (I am not even kidding…) to get a chance to include. Those device work fine otherwise… once included…

Thanks for your attempt to help. I ran into lots of trouble with Everspring devices those are again from the brand (AN158). It is a pitty b/c other than that, they are pretty good.

I slowly start thinking the network is spammed now and needs to dequeue…

I am not doing anything and I see:

The issue with that is that I tried to let my system sit overnight as well and woke up with the same issues. I really wish I’d find a way to CLEARLY see the issue.

I doubt there is any caching that would be relevant and the Zwave binding is very detailed. I wouldn’t skip giving it a try with TRACE level logging.

It was a revelation when I learned that too years ago.

How close is the device to the controller? Particularly with older Zwave devices, they need to be pretty close to complete inclusion. Maybe they are just too far away… I think the logs might show if that’s the case.

Of course if there are all of these include messages still floating around, maybe that’s part of the problem too. Assuming these eventually peter out, maybe you can do the inclusion with the logs up and stop spamming the button as soon as you see inclusion has started.

I’ve never had a device that is so finicky to include, but it’s also been awhile since I’ve included anything new with my Zwave network. New devices I purchase tend to be Zigbee.

Ah ah, yeah I am doing my 3rd Zigbee order right now :slight_smile:

I don’t think the range is the issue. I am so close, I even tried moving further away…
My gen 67 dongle is less than 2m away from the AN158 I am trying to include.
I even got it include then reomved it due to confusion about which device was included (I have 2 to include).

This is so painful I start thinking a fallback serial connector would be handy… Something like tag connect would be great… Plug inlcude and forget…

There are a couple of ways to migrate the network from a 500 to 700 or 800 controller without including, excluding. One is here. Migrate 500/700 Z-Wave Controllers to the ZST39 800 Series Controller (youtube.com). I also wrote something earlier that i’ll add when I find it.

Edit: also just use Debug with Zwave binding and viewer, Trace adds no value IMO.

Edit: found it. I have used all three methods. The include/exclude like you are using was in the basement (unfinished) so most of the devices were easily exposed.
Transitioning a network from 500 chip.pdf (235.8 KB)

1 Like

Oh nice, more options, thank you @apella12.
I already had a “ohhh” moment, when you or the youtube starts 2 controller, one with each stick…
Luckily, I do have backups as I manged to upgrade my gen and then back it up.

So beside having my network down for now, I can pretty much restore any previous state, making it friendly to experiment. I am not worried about the ids very much as I can update OH very quickly since I declare my items as files (precisely for that reason…).

My ideal plan would be to go from:

  • network with gen 5 as id 1

to:

  • network with gen 7 as main controller with id 1
  • and the gen 5 as secondary to benefit from the “remote” inclusion offered by carrying the stick around

I ran an additional test and the outcome suprised me:
I took my reset gen 5 stick and tried to include the uncooperative device.
It worked right away.
I excluded it, right away.
I switched back to the gen 7 stick… no way.

I do keep track of the ids and devices but just in case, I put to use a fonction from PC Controller 5: switch all ON. That is nice to check that you don’t ALREADY have the device included which your knowledge… But no, my device (unless all the others) did not turn on.

So the issue really lies in the gen 7 stick. I will have to chat with Aeotec… They have been helpful so far… I hope they can help further solving yet another z-wave-mystery :wink:

I started thinking that my config maybe the issue since NWI/NWE never worked on any stick.

I was able to make a VNI include for the first time, after I used a USB extender to get the zwave stick “away” from the RPi and other metal parts. So I think my main issue was RF related.
Bringing the stick around did help as it ALSO brought the stick away from the RPi, some other devices and also a ZigBee dongle.

I think I did not take seriously enough those remarks I read here and there about using Powered USB hub of extension cables. This seems to be much more relevant than what I thought.