Tradfri 1.8.25 - offline - communication_error

Hi,

Starting today my Tradfri gateway went to OFFLINE - COMMUNICATION_ERROR.

It was working perfectly for last two years and no changes were made on network nor configuration level recently.

The only thing I have noticed is that my tradfri gateway is updated to the latest version 1.8.25 which brings support for HomeKit and support for two switches on one bulb announced by Apple 7 days ago (11.04.2019).

It seams that for this reason binding is not working anymore.

Just for the record, I rebooted all devices multiple times and can ping everything.

Is this a known issue or should I look for some other reason? Does anyone else has similar issue?

Please help.

Thanks in advance.

Same issue here, already restarted all related devices.

Any advice?

Best regards,
Sebastian

Same for me…
Tried to restart every device, no success.

Hi there,

It’s a known isseu that after an update or restart of the tradfri hub the communication stop to Openhab.

For me it normally works to restart Openhab and when it’s started reboot the tradfri hub ( power on / off )

Hope this helps.
I block the auto update from Ikea, so will update tomorrow. A friend of mine had the same issue today and for him this restored the communication.

Best regards.
Olaf

I have been having some serious instability since the tradfri update.

I had not posted yet as I was unable to spend time to debug it it was my openHAB install or tradfri.

I know it happened when I received the update!

I just did a little debug and it looks as if I configure in Paper UI it works. But configuring in the files It does not.

Definitely happened after firmware update, my system has been running for 1.5years.

I just run the update. All seems to work for know. If I run into something will let it know.

After an update it also seems to work to disable / enable the tradfri gateway ‘thing’ ( it’s the clock on the right of the thing ) to get it back online. It took a few minutes.

I just did a little debug and it looks as if I configure in Paper UI it works. But configuring in the files It does not.

I tried this initially but it didn’t help in my case :frowning:

Update: I also tried latest updates for OpenhabianPI openHAB 2.4.0 Release Build but it didn’t help either.

Not sure what to do next… :frowning:

New update:
@Thedannymullen You were absolutely right. After further debugging, I finally managed to fix Tradfri Gateway problem.

  1. Rename extension of all Tradfri related config files.
  2. Reboot Openhab
  3. Using PaperUI you will find Tradfri Gateway inside Inbox
  4. Finish setup of gateway providing necessary Security code (from the back of gateway)
  5. This will set value in Pre-Shared security key automatically and what is new: Identity value
{
  "statusInfo": {
    "status": "ONLINE",
    "statusDetail": "NONE"
  },
  "editable": true,
  "label": "TRÅDFRI Gateway",
  "configuration": {
    "host": "x.x.x.x",
    "preSharedKey": "P2hjxxxxxxxxx",
    "port": 5684,
    "identity": "849xxxxxxxxxxxxxxxxxxxxx"
  },
  "properties": {
    "serialNumber": "gw-b07xxxx",
    "firmwareVersion": "1.8.25",
    "vendor": "IKEA of Sweden"
  },
  "UID": "tradfri:gateway:gwb07xxxxxxxx",
  "thingTypeUID": "tradfri:gateway",
  "channels": []
}
  1. You can now set the config file with these values and rename back all configuration.
  2. You are Tradfri Online again. :slight_smile:
3 Likes

Solved it for me. Thank you for your help!

Best regards,
Sebastian

Where do you find the file with the new config settings and identity value?
Many thanks

It will automatically populate inside PaperUI thing config. By editing the thing setting in PaperUI you can see necessary details

You can get details by going to Rest API panel if you go to root URL of your Openhab instalation (ver 2.4.0)

https://youropenhabip:port/doc/index.html#!/things/getByUID

You need to insert thingUID :: “tradfri:gateway:gwb07xxxxxxxx” and you will get full details.

I have all my Tradfri stuff in PaperUI, not in Things files.
I have tried quite a few different things, including removing and readding the gw from the inbox. But I have not been able to get it online after the Tradfri update :frowning:

Hey, it just came online again, and all is working! :smiley:
I think (?!?!) that what did it was:

  1. delete the gw from PaperUI
  2. restart OpenHAB
  3. the gw should appear in the inbox, add it and enter the security code (for me the gw came online after a while but all the Tradfri unit did not come online)
  4. restart OpenHAB again
  5. be patient for 10-20 minutes, then all comes online
    Good luck to you all :smiley:

Restart is necessary step after removing gateway from Things…

Did wonder why it was json. I really shoukd use the api more!
Thanks for your help.

Got it working (after a fashion)
I can’t get the gw to work if I set it manually in a.things file, but the detected gw works and all my items are back online
Thanks again for your help

So for those that only live in .config files, how do we fix this?
Using 2.4.0 release build.

2 Likes

@digital I setup in paper ui just to get back working. A little confused on what I need to change in my things file?

I got it working.
You need to change the name of the gateway thing add the identity to the config file.

For me it was:
Bridge tradfri:gateway:gw1 [ host=“xxx.xxx.xxx.xxx”, code=“xxxxxxxxxx” ] {
and the new config is:
Bridge tradfri:gateway:gwb07xxxxxxxx [ host=“xxx.xxx.xxx.xxx”, identity=“849xxxxxxxxxxxxxxxxxxxxx”, preSharedKey=“P2hjxxxxxxxxx” ] {

I also had to change all items that use this gateway as the UID has changed (from “tradfri:gateway:gw1” to “tradfri:gateway:gwb07xxxxxxxx”).

2 Likes