Trane Thermostat Temperature Not Displaying Correctly

  • Platform information: RaspberryPi

I have a Z-Wave Trane Thermostat that is bound and has items set for Set Cooling Temp, Set Heating Temp, Set Fan Mode, Set Fan State, Set Mode, Set Operating State, and Display Temp.

Everything seems to function and display properly in BasicUI, PaperUI, and HabMin except the current temp. For some reason, it seems stuck on 69.8F regardless of what’s displayed on the thermostat screen. It stays at that number almost continuously, but occasionally will display the correct temp, only rarely, and I can’t determine what initiates that.

I’ve rebooted the RaspberryPi and the OpenHabian operating system, but it doesn’t seem to resolve the issue. I’m new to this program and learning as I go. Any thoughts as to what might be occurring here and what I can do to resolve it?

What do the logs show for the t-stat as the setting change?

I just tried to change the settings from one temp to another and also changed the setting from Heat to Auto, but nothing displayed in the Openhab.log file. The thermostat state and temp changed appropriately. The temp reading still says 69.8F even though the thermostat screen says 72F.

Is the openhab.log file the right log file for this? Is there another log file you’re referring to? Sorry for my newbie-ness.

Open a browser and use the frontail log.

Can you tell me how to do that? I haven’t heard of the frontail log. Is there a document on this site describing how to access it?

Wait, I might have found it. Stand by.

Okay, found it, installed it, and opened it. When I changed temperature and setting states, I got this:

2020-01-02 11:21:11.698 [ome.event.ItemCommandEvent] - Item 'FF_Thermostat_Set_Heat' received command 73

2020-01-02 11:21:11.750 [nt.ItemStatePredictedEvent] - FF_Thermostat_Set_Heat predicted to become 73

2020-01-02 11:21:11.788 [vent.ItemStateChangedEvent] - FF_Thermostat_Set_Heat changed from 72 °F to 73.0 °F

2020-01-02 11:21:12.815 [ome.event.ItemCommandEvent] - Item 'FF_Thermostat_Set_Heat' received command 64

2020-01-02 11:21:12.868 [nt.ItemStatePredictedEvent] - FF_Thermostat_Set_Heat predicted to become 64

2020-01-02 11:21:12.895 [vent.ItemStateChangedEvent] - FF_Thermostat_Set_Heat changed from 73.0 °F to 64.0 °F

2020-01-02 11:21:13.393 [vent.ItemStateChangedEvent] - FF_Thermostat_Set_Heat changed from 64.0 °F to 73 °F

2020-01-02 11:21:13.505 [ome.event.ItemCommandEvent] - Item 'FF_Thermostat_Set_Heat' received command 75

2020-01-02 11:21:13.538 [nt.ItemStatePredictedEvent] - FF_Thermostat_Set_Heat predicted to become 75

2020-01-02 11:21:13.592 [vent.ItemStateChangedEvent] - FF_Thermostat_Set_Heat changed from 73 °F to 75.0 °F

2020-01-02 11:21:16.669 [vent.ItemStateChangedEvent] - FF_Thermostat_Operating_State changed from 1 to 4

2020-01-02 11:21:16.865 [vent.ItemStateChangedEvent] - FF_Thermostat_Fan_State changed from 1 to 0

2020-01-02 11:21:23.872 [ome.event.ItemCommandEvent] - Item 'FF_Thermostat_Mode' received command 3

2020-01-02 11:21:23.910 [nt.ItemStatePredictedEvent] - FF_Thermostat_Mode predicted to become 3

2020-01-02 11:21:23.937 [vent.ItemStateChangedEvent] - FF_Thermostat_Mode changed from 1 to 3

Please use code fences when posting logs, things/items files, etc… It’s the paper icon to the left of the gear icon.

The log shows everything changing, is that correct?

I do not see temp reading (from display) please post the thing/item configuration for this. Also check in PaperUI Thing that the display channel (blue button you click) is clicked and linked. If you do not see this option look for “show more” and click it to see if there is more channels available.

I’ll use that, sorry.

Yes, the log is showing the changes correctly, but as you mention, there’s no temperature displayed, even when allowing the log to continue.

Here are the configs:

Number:Temperature FF_Thermostat "Temperature [%.1f °F]" <Temp> { channel="zwave:device:80457dfb:node7:sensor_temperature" }

The channel button for the parameter is checked and it’s linked to Temperature(FF_Thermostat)

Okay, to add to before, here’s one of those random times it actually showed the temp properly:

2020-01-02 11:49:41.731 [vent.ItemStateChangedEvent] - FF_Thermostat changed from 69.80 °F to 71.60 °F

2020-01-02 11:49:41.825 [vent.ItemStateChangedEvent] - FF_Thermostat_Operating_State changed from 1 to 4

2020-01-02 11:49:42.024 [vent.ItemStateChangedEvent] - FF_Thermostat_Fan_State changed from 1 to 0

Good, we know it does work.:+1:

Is there a setting for how often the sensor is polled or does it just update when it changes? May be in PaperUi setting under the advanced mode.

I’ll check. Meantime, after almost exactly 4 minutes ( 11:49:41.731 when the temp registered correctly to 11:53.41.739 ) the temp display in OpenHab reset itself to 69.8F:

2020-01-02 11:53:41.739 [vent.ItemStateChangedEvent] - FF_Thermostat changed from 71.60 °F to 69.80 °F

Stop OH and clean the cache.

From the command line use:

sudo systemctl stop openhab2

sudo openhab-cli clean-cache

sudo systemctl start openhab2

The only polling parameters I see are under “Device Configuration” where the Polling Period is set to 15 seconds and the Command Poll Period is set to 100 (no designation on that one whether it’s seconds or not).

Okay, done. Reset and cleared.

I don’t have a Trane t-stat to test with so I’m not sure what other parameters to look for. Did you ever have simple mode turned on in PaperUI? Perhaps there could be a duplicate item for the temp display.:thinking:

After clean the cache and reading is not working I would try deleting all the Things/Items for the t-state, clean caceh again then rediscover again.

I have simple mode on now.

I’ll try the rediscovery mode idea and see if that helps. I’m wondering this myself. I had tried to set this system up over a year ago and stopped, then picked it back up again over the holidays. I did find some clashes with the cache before and multiple .items and .sitemap files that may have been conflicting with each other. I renamed them all and just went with one .items and .sitemap file and cleared the cache and rebooted. That cleared up some of the other issues, but this one seems to persist.

Thanks for the help so far! I’ll post back with some results.

I do not recommend using simple mode as you may find yourself with duplicate items and lots of headaches, especially if using items file.:wink:

I had simple mode off, but my son turned it back on. Should I turn it off and start over with everything? What does having it on do to the system settings and configs?

(I’m hoping I don’t have to do everything over again, because setting up my Schlage door locks was a major bitch).

Yes turn it off. No with start over on everything just be aware you may have duplicate items at this point. Use the console to check your items.

Nothing for the setting but if you have items in files and simple mode on it may try and create another item and OH can get confused.

Do you have a backup of your configuration?