Trouble setting Thermostat HeatingCooling Mode via HomeKit Add-on

thermostat
homekit
nest
Tags: #<Tag:0x00007f51da3df760> #<Tag:0x00007f51da3df620> #<Tag:0x00007f51da3df4e0>

(Brian Tillman) #1

Hello!
I’ve recently installed the HomeKit integration service in OpenHab 2. While Lighting, Switchable, CurrentTemperature, and TargetTemperature HomeKit item tags are working well for me, I’m having trouble specifically with Thermostat HeatingCoolingMode tagged items.

When attempting to set the mode via the “Home” app on my iOS device, I receive a “No Response” error in the UI.

My item from the .items file.

Group gHomeKit_Hallway_Thermostat “Hallway Thermostat” [ “Thermostat” ]
//Working
Number HomeKit_Hallway_Thermostat_CurrentTemp “Hallway Thermostat Current Temperature” (gHomeKit_Hallway_Thermostat) [ “CurrentTemperature” ]
//Working
Number HomeKit_Hallway_Thermostat_TargetTemperature “Hallway Thermostat Target Temperature” (gHomeKit_Hallway_Thermostat) [ “TargetTemperature” ]
//Not working.
String HomeKit_Hallway_Thermostat_HeatingCoolingMode “Hallway Thermostat Heating/Cooling Mode” (gHomeKit_Hallway_Thermostat) [ “homekit:HeatingCoolingMode” ]

In the HomeKit Integration PaperUI configuration, I’ve set strings for Heat, Cool, Auto, and Off Modes to “heat”, “cool”, “auto”, and “heat-cool”. While unrelated to this problem, my intent was to match the strings used by the Nest binding.

I have rules in place to mirror the state of HomeKit_Hallway_Thermostat_HeatingCoolingMode and another item from the Nest binding representing the HeatingCoolingMode of my thermostat. I did disable these rules for troubleshooting.

What is interesting is that the proper state is shown in the iOS “Home” UI if the item (HomeKit_Hallway_Thermostat_HeatingCoolingMode) is manipulated in the Karaf console (openhab> send HomeKit_Hallway_Thermostat_HeatingCoolingMode heat) or via the aforementioned rules to keep in synch with the item from the nest binding.

It feels as if this is a permissions issue, whereby the iOS “Home” app can read the state of the HomeKit item (HomeKit_Hallway_Thermostat_HeatingCoolingMode) but cannot set it.

I’m not seeing additional logging after setting the log level to trace (openhab> log:set TRACE com.beowulfe.hap).


(Alpesh Dave) #2

@BrianTillman Brian,
I am also facing the exact same issue. Did you find the resolution? Appreciate your help.


(Womble) #3

+1 more


(Adam) #4

Did you find an answer to this? I too am having difficulty setting the heating mode using Nest thermostats.


(m17) #5

Does anybody fix “heatingCoolingMode” problem?


(Shuwen Xia) #6

I have the same issue.


(Hesstobi) #7

Same issue here.


(Ccaramel) #8

Exactly same issue with KNX.
Changing the mode from iOs is doing nothing and not be logged.


(Panos) #9

I still have the same problem with you @BrianTillman . Target and Current Temp are showing but when trying to change modes , Heat or Off, I get no response. I am running the unstable version. @adw, @m17, @gesbaby and @hesstobi have you found a solution yet ?


(Alex Martin) #10

Did anyone resolve this? I’m having the same issue on the latest stable build.


(Tobias) #11

Dear all,

I have a related issue. I have no clue how to find the right replacements (if needed) for matching the Homekit mode strings with the ones fitting to my thermostat:

If the issue here was resolved: Could you recommend a solution in that thread? Thanks.