Troubles getting Fibaro Smoke Detectors connected to Openhab2

Tags: #<Tag:0x00007faed9eabc28> #<Tag:0x00007faed9eaba98> #<Tag:0x00007faed9eab8b8>
  • Platform information:
    • Hardware: Raspberry Pi 3 Model B Rev 1.2
    • OS: Raspbian GNU/Linux 9 (stretch), Linux 4.14.98-v7+
    • Java Runtime Environment: openjdk version “1.8.0_152”
    • openHAB version: 2.4.0

Hi all,
I’m actually trying to connect this beautiful small Fibaro smoke detectors to my openhab system.
First, I tried to get the Razberry board up and running and did not succeed and now switched to ZME UZB1.
Installation worked fine, I can have a look both at Z-Wave Smart Home and at Expert UI. But I cannot get this inclusion mode started to get a smoke sensor connected to the Z-Wave Platform.
Do I need that platform or can I directly connect to openhab?
Which binding do I have to use, Zway or zwave? The topic at Zwave or ZWay binding? did not state that clear for me. Do both interfere with each other or with the zwave-me-platform?
Any help is really appreciated.
Thanks a lot in advance,
Carsten

Not sure what the Z-Wave Platform is you are talking about, but you can include the devices by first installing and setting up the Z-Wave binding, and subsequently including your devices via the inbox of Paper UI, or via Habmin if you prefer that.

Hej Rolf, hi all,
thanks, I know added a Z-Wave Serial Controller via the Z-Wave binding. After that, the state of the controller is “offline - Bridge_offline”. It does not matter if I choose /dev/ttyACM0 or /dev/ttyAMA0.
That makes me think that something with the UZB-Stick is not working correctly yet.
DO you have any other idea?
Thanks so far,
Carsten

you installed serial binding right?
Things to make sure you do:
add openhab user to tty and dialup
edit /etc/default/openhab2 to add EXTRA_JAVA_OPTS="-Dgnu.io.rxtx.SerialPorts=/dev/ttyUSB0:/dev/ttyUSB1"
SSH in or open terminal and run
lsusb
post result
run dmesg | grep tty
post result
try restart system & openHAB

This is not necessary, but it helps when manually installing the binding, as you do not need to manually install the openhab-transpoirt-serial feature (and resinatll after every update). Note, xstream is also required when manually installing the latest version of the binding…

I’m not sure if the bindings interfere with each other, but the zway server component interferes with the zwave binding because they are competing for use of the controller. I’m not very familiar with the issue, but others have reported it in the forum. Follow Andrew’s advice, but you should also take a look in openhab.log after starting the binding.

1 Like

Hi Andrew,
ah ok, thanks.

What I did now:

  • sudo chown :openhab /dev/ttyAMA0

  • Edited /etc/default/openhab2 and added -Dgnu.io.rxtx.SerialPorts=/dev/ttyAMA0 to the extra Java options.

  • installed serial binding 1.13.0. Is this the correct one for openhab 2.4.0 or do I have to install Serial Button Binding 2.4.0?

  • Uninstalled zway-binding.

Here are my outputs:

[13:42:06] openhabian@openHABianPi:~$ lsusb
Bus 001 Device 007: ID 0658:0200 Sigma Designs, Inc.
Bus 001 Device 004: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
[13:42:58] openhabian@openHABianPi:~$ dmesg | grep tty
[    0.000000] Kernel command line: 8250.nr_uarts=1 cma=256M bcm2708_fb.fbwidth=1824 bcm2708_fb.fbheight=984 bcm2708_fb.fbswap=1 vc_mem.mem_base=0x3ec00000 vc_mem.mem_size=0x40000000  dwc_otg.lpm_enable=0 enable_uart=1 dtoverlay=pi3-disable-bt console=tty1  root=PARTUUID=866712bd-02 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait quiet splash plymouth.ignore-serial-consoles
[    0.000284] console [tty1] enabled
[    1.719935] 3f201000.serial: **ttyAMA0** at MMIO 0x3f201000 (irq = 87, base_baud = 0) is a PL011 rev2
[    4.800215] cdc_acm 1-1.3:1.0: ttyACM0: USB ACM device
  • Rebooted the system.

Nothing at all changed, I still do not find any things via PaperUI, and still cannot get the device in this inclusion mode via its own UI: http://192.168.178.60:8083/smarthome/#/zwave/inclusion. I had the same problem with the Razberry board as now with the UZB stick.

Any ideas how to get the smoke sensors included via the zwave-me-portal. I assume, that if it does work there, the things can be found via PaperUI as well.

Hi Carsten
That is the OH1 serial binding (I’m guess because 1.13.0) I use the OH 2 version of the serial binding with the zwave binding, sorry for not being more explicit.
Although Scott said the serial binding should not be needed.

not 100% sure but I think there is your zwave stick

there is your usb port

sorry, I don’t know anything about it. I use the zwave binding and the OH2 serial binding to do my zwave and it works a treat. Here is a link to the documentation which will have the minimum info needed to get started and examples

Hi again,
sorry, sometimes I feel being really stupid regarding openhab things. It’s always like at the very interesting and unclear point, in the descriptions happens some magic.
Again, my questions, hopefully as precise as possible:

  1. Where do I find the serial binding for 2.4.0? I only find these:

  2. I’ve installed the Z-Wave Binding following your advices:


    What to do next? Following the Z-Wave-binding-doc, I first have to add a serial adapter. Where do I have to do that and why is that not explained in the doc? What I got managed to do with some trial and error was the following thing:

  3. Why does that Z-Wave Serial Controller tell me that it is offline “BRIDGE_OFFLINE”?

  4. Does the UZB Stick have any light flashing when it is in inclusion mode? The Razberry board had a red led, that was never lit in my system, thats why I returned it back and why I am testing now with the UZB Stick. If that does not work either, I will turn back all the stuff and go with KNX. Zwave fees actually like real pain, with or without openhab.

  5. Zwave.me: Do I have configured the Z-Wave Network Access correct:

  6. What is my USB-Port? What does that mean? What is my Z-Wave-Stick plugged into one of the four USB Ports? ttyAMA0? ttyACM0?
    ttyAMA0 or am I wrong?

  7. Why does the zwave-me-page state that there are problems:

Sorry, but I am a very beginner to zwave and have to say that it is somewhat complicated. Is there a good doc somewhere explaining a basic concept for beginners?

Thanks for all your help and patience,

Carsten

This is not required. Uninstall it.

Adding/removing Things is not specific to the zwave binding and is found in the documentation and tutorial.

It is offline because you have other software that has locked the serial port. As I have already said, you cannot use Zway/Zwave.me and the Zwave binding at the same time. There are ther posts in the forum discussing the conflict.

Hi all,
thanks so far, @5iver :slight_smile: . Ok, I uninstalled the serial binding and the zway-binding and disabled the zwave.me-software. Still the same: BRIDGE_OFFLINE
Deleted the serial controller and added it again => the same.
Any hints how I get it ONLINE?
Thanks a lot,
Carsten

Are you using zwave.me on the same raspberry and at the same time as openhab?
Then either zwave.me or openhab occupy the UZB. So make sure that when you start openhab, zwave.me is not running.

Hi Sascha,
thank you, but as I stated before:

To be more precise: I stopped the z-wave server and disabled its autostart. After that, I rebooted the raspberryPi and the z-wave UIs were not reachable.
Thus, I assume, there can be no ressource conflict be the cause any longer.
Any other ideas?
Regards,
Carsten

Sorry, i’ve just quickly read the posts here and must have missed that part.
I think you just have the wrong port. On my system ttyAMA0 is being used by the Rarzberry board.
Since you’ve changed to UZB, I think the port is different (i think it should be /dev/ttyACM0)

Can you use puTTY to connect to your raspberry?
What does

ls /dev/

report?

Hi, no worries.

Here is some output I got via putty:

[18:23:36] openhabian@openHABianPi:~$ ls /dev/
autofs           cuse       gpiochip1  kmsg   loop6             mmcblk0p2           pts    ram15  ram9     snd     tty11  tty19  tty26  tty33  tty40  tty48  tty55  tty62      ttyS0    vcs   vcsa1  watchdog
block            disk       gpiochip2  log    loop7             mqueue              ram0   ram2   random   stderr  tty12  tty2   tty27  tty34  tty41  tty49  tty56  tty63      uhid     vcs1  vcsa2  watchdog0
btrfs-control    dri        gpiomem    loop0  loop-control      net                 ram1   ram3   raw      stdin   tty13  tty20  tty28  tty35  tty42  tty5   tty57  tty7       uinput   vcs2  vcsa3  zero
bus              fb0        hidraw0    loop1  mapper            network_latency     ram10  ram4   rfkill   stdout  tty14  tty21  tty29  tty36  tty43  tty50  tty58  tty8       urandom  vcs3  vcsa4
cachefiles       fd         hidraw1    loop2  mem               network_throughput  ram11  ram5   serial   tty     tty15  tty22  tty3   tty37  tty44  tty51  tty59  tty9       usb      vcs4  vcsa5
char             full       hwrng      loop3  memory_bandwidth  null                ram12  ram6   serial0  tty0    tty16  tty23  tty30  tty38  tty45  tty52  tty6   ttyACM0    vchiq    vcs5  vcsa6
console          fuse       initctl    loop4  mmcblk0           ppp                 ram13  ram7   serial1  tty1    tty17  tty24  tty31  tty39  tty46  tty53  tty60  ttyAMA0    vcio     vcs6  vcsm
cpu_dma_latency  gpiochip0  input      loop5  mmcblk0p1         ptmx                ram14  ram8   shm      tty10   tty18  tty25  tty32  tty4   tty47  tty54  tty61  ttyprintk  vc-mem   vcsa  vhci
[18:23:54] openhabian@openHABianPi:~$ lsusb
Bus 001 Device 007: ID 0658:0200 Sigma Designs, Inc.
Bus 001 Device 004: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
[18:24:31] openhabian@openHABianPi:~$ dmesg | grep tty
[    0.000000] Kernel command line: 8250.nr_uarts=1 cma=256M bcm2708_fb.fbwidth=1824 bcm2708_fb.fbheight=984 bcm2708_fb.fbswap=1 vc_mem.mem_base=0x3ec00000 vc_mem.mem_size=0x40000000  dwc_otg.lpm_enable=0 enable_uart=1 dtoverlay=pi3-disable-bt console=tty1  root=PARTUUID=866712bd-02 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait quiet splash plymouth.ignore-serial-consoles
[    0.000284] console [tty1] enabled
[    1.719275] 3f201000.serial: ttyAMA0 at MMIO 0x3f201000 (irq = 87, base_baud = 0) is a PL011 rev2
[    4.606560] cdc_acm 1-1.3:1.0: ttyACM0: USB ACM device
[18:24:48] openhabian@openHABianPi:~$

Configuring the Z-Wave Serial Controller only offers me one serial port: /dev/ttyAMA0, nothing else.

In other forum posts I learned that I have to switch off Bluetooth and so on, what I did:

Was that the wrong way?

I remember only one port in the drop down list being the issue in another zwave thread. Please search zwave threads, I am on my phone right now sorry

Ok, finally I got the serial controller ONLINE after changing the Port from AMA0 to ACM0. For that, I replaced

-Dgnu.io.rxtx.SerialPorts=[...]/dev/ttyACM0:/dev/AMA0

with

-Dgnu.io.rxtx.SerialPorts=/dev/ttyACM0

(got that idea while reading

fixed the permissions as suggested in

But now, I still cannot get the smoke detector connected. How can I now start the inclusion mode of the UZB stick? Do I see that with some light flashing?

What I tried was to search for things in Inbox and than pressed the button on the smoke detector three times, but no success.

Trying to add a thing manually brings me back to add a serial controller.

Sorry, seems I’m a little bit blinded at the moment.

Thanks so far to everyone helping me to get the serial controller online. :ok_hand:

Regards,

Carsten

Hi again,
I now installed HABmin and tried to connect the smoke detector there, but again no success.
But after clicking the + icon, I get the message that the inclusion mode was started. Anyhow, pressing the button on the smoke detector three times as described does not connect the detector.
Still, no LED on the stick is flashing or lit indicating that the inclusion mode is active.
Is that normal that no LED is flashing or lit?
Thanks again,
Carsten