Unable to boot

  • Platform information: RPi4
    • Hardware: CPUArchitecture/RAM/storage RPi4 8
      I flashed openhabian-pi-raspbian-201908050414-gitca0976f-crc6a66b5a1.img.xz to 32gb SD card
      Plugged in Ethernet cable turned on - I got the following msg:

Raspberry Pi 4 - 8GB
bootloader: 940f978d Mar 19 2020
board: de3114 2c6b7dc dc:a6:32:b8:48:1b boot: mode 6 order Ox00000001 rsts Oxe0001000
SD CID: 00035344534333324780eof78b670146
part: O mbr (Oxoc:00002000 0x83:00084000 exe0:00000000 Ox00:00000000] tw: start4.0lf fixup4.dat
net: down 1p: 0.0.0.0 sn: gw: 0.0.o.o tftp: 0.0.0.0
Partition:
lba: 8192 oem: ‘mkfs. fat’ volume: ’ boot
rsc 32 fat-sectors 4033 C-count 516191 c-stage 1 r-r 2 r-sec Read config.txt bytes 1735 hnd ex0000029f hash 564723ab5538422a
recovery 4.elf not found
recovery.of not found
Read start4.elf bytes 2759172 hnd exe0009280 hash 2691df2baa2d24dc Read fixup4 .dat bytes 6068 hnd exe00002b2 hash dab44fd1oc87ae51
Oxood 3114 Ox 00000000 ex 00000000 start4…elf: 1s not compatible Os
This board requires newer software. Get the latest software from: https://www.raspberrypi.org/downloads/

What am I doing wrong - please don’t assume too much expertise!!

Hi

I don’t have a raspberry pi, so the following is purely guess work.

Can you expand on the following :

  • If you only plugged in the power and LAN cable, where did you see the text you’ve pasted?

  • Can you humour us and explain exactly which software and routine you used to “flash” the memory card. (If only to confirm the correct steps, so we don’t try to help fix something that isn’t broken)

  • Did the flash process include a verification stage?

  • Have you tried starting over with a fresh download of the Openhabian Image? (Just to eliminate any possible corruption issues)

I plugged the HDMI cable into a monitor to find out what was happening.

I used Etcher to flash openhabian-pi-raspbian-201908050414-gitca0976f-crc6a66b5a1.img.xz onto the SD card

I did try reformatting and re flashing the SD card

Okay then :slight_smile:

That’s covered those details.

Keeping in mind that I don’t use raspberry pi hardware, the following is purely my own approach to fault finding.

I would say that you’ve got 3 things left to try, given that what you’re describing is a fairly low level failure.

  • A fresh download of the donor image, maybe test a basic OS (Armbian / DietPi / Debian) image, just to prove the following two elements are good.

  • A different SD card

  • A different Raspberry Pi

Thanks - I will try the first 2 when I get a chance. I don’t have another RPi so that option is out!

One more option that used to be recommended by Raspberry Pi. Format your card with the official SD Card Formatter tool first. Some people have seen that help cards they thought were dying.

You bought the 8GB RPi4 model without reading the recommendation.
It does not work with older kernels such as the one the openHABian image is based on.
You could try the beta image from https://github.com/openhab/openhabian/actions/runs/186050129 .

2 Likes

Thanks - but it says “overkill”, not that it won’t work. I will try your recommendation. Thanks

Because it does work with the proper OS and because we expect to release the image soon.
But 8GB remain to be overkill and anyone who follows the 2GB recommendation does not have that problem.

The Beta version seems to have worked. Your help is appreciated.

1 Like

If anyone choose the 64bit setup, I guess Rpi4 2GB ram can become a sligth problem, as 64bit OS consumes quite alot more memory.
I tested the 64bit setup last night. I had 1.7GB available memory when openHAB is up running (just openHAB,nothing else). When running the 32bit setup, I have aprox 2.9GB available memory.

My Rpi4 is a 4GB.

1 Like