Unable to disable serial port for RaZberry Hat

After a fresh install of openhabian 1.6.1 on raspberry pi 3b+, I can’t disable Bluetooth while in openhab-config. is there another way to do this or a way to fix it? every time I try it just brings me back to the main screen of the config tool and Updating Linux package information… OK is what runs when I hit enter.

What is the content of your /boot/config.txt ?
Does it contain: dtoverlay=pi3-disable-bt ?

1 Like

It does not should I add that to it?

You don’t have to disable BT you just need to use make your Pi use mini-UART for this so the fullsize serial port is available to your hat.
Did you use menu option 35 ? If yes and it didn’t work open a Github issue
Set debugmode=maximum in openhabian.conf and also show your /boot/config.txt

here is my config, menu option 35 does’t work when I try it brings be strait back to the main menu. Ive never had to open a github issue before

For more options and information see


Some settings may impact device functionality. See link above for details

uncomment if you get no picture on HDMI for a default “safe” mode


uncomment this if your display has a black border of unused pixels visible

and your display can output without overscan


uncomment the following to adjust overscan. Use positive numbers if console

goes off screen, and negative if there is too much border


uncomment to force a console size. By default it will be display’s size minus



uncomment if hdmi display is not detected and composite is being output


uncomment to force a specific HDMI mode (this will force VGA)


uncomment to force a HDMI mode rather than DVI. This can make audio work in

DMT (computer monitor) modes


uncomment to increase signal to HDMI, if you have interference, blanking, or

no display


uncomment for composite PAL


#uncomment to overclock the arm. 700 MHz is the default.

Then now you do.
Include the debug log as I told you in my last post.

Ok here is the debug log I’m also posting it on the github issue but before I do are you sure it’s not something I’m doing wrong on my end? I know enough to break everything but I am very much a beginner in all of this. I did change the debug log to maximum
2020-12-09 03:38:41.800 [INFO ] [.dashboard.internal.DashboardService] - Started Dashboard at 2020-12-09 03:38:41.836 [INFO ] [.dashboard.internal.DashboardService] - Started Dashboard at 2020-12-09 03:38:44.215 [INFO ] [thome.model.lsp.internal.ModelServer] - Started Language Server Protocol (LSP) service on port 5007 2020-12-09 03:39:22.554 [INFO ] [.dashboard.internal.DashboardService] - Stopped Dashboard 2020-12-09 03:39:22.853 [INFO ] [.dashboard.internal.DashboardService] - Started Dashboard at 2020-12-09 03:39:22.855 [INFO ] [.dashboard.internal.DashboardService] - Started Dashboard at 2020-12-09 03:41:14.985 [INFO ] [.dashboard.internal.DashboardService] - Stopped Dashboard 2020-12-09 03:42:25.328 [INFO ] [thome.model.lsp.internal.ModelServer] - Started Language Server Protocol (LSP) service on port 5007 2020-12-09 03:42:27.193 [INFO ] [.dashboard.internal.DashboardService] - Started Dashboard at 2020-12-09 03:42:27.199 [INFO ] [.dashboard.internal.DashboardService] - Started Dashboard at 2020-12-09 03:46:46.900 [INFO ] [thome.model.lsp.internal.ModelServer] - Started Language Server Protocol (LSP) service on port 5007 2020-12-09 03:46:51.288 [INFO ] [.dashboard.internal.DashboardService] - Started Dashboard at 2020-12-09 03:46:51.301 [INFO ] [.dashboard.internal.DashboardService] - Started Dashboard at 2020-12-08 21:52:07.914 [INFO ] [thome.model.lsp.internal.ModelServer] - Started Language Server Protocol (LSP) service on port 5007 2020-12-08 21:52:12.918 [INFO ] [.dashboard.internal.DashboardService] - Started Dashboard at 2020-12-08 21:52:12.927 [INFO ] [.dashboard.internal.DashboardService] - Started Dashboard at 2020-12-09 05:47:58.910 [INFO ] [.dashboard.internal.DashboardService] - Stopped Dashboard 2020-12-09 05:49:39.277 [INFO ] [thome.model.lsp.internal.ModelServer] - Started Language Server Protocol (LSP) service on port 5007 2020-12-09 05:49:44.652 [INFO ] [.dashboard.internal.DashboardService] - Started Dashboard at 2020-12-09 05:49:44.661 [INFO ] [.dashboard.internal.DashboardService] - Started Dashboard at 2020-12-09 05:51:45.571 [INFO ] [openhab.ui.paper.internal.PaperUIApp] - Started Paper UI at /paperui 2020-12-09 05:51:46.580 [INFO ] [panel.internal.HABPanelDashboardTile] - Started HABPanel at /habpanel 2020-12-09 05:51:47.039 [INFO ] [ebuilder.internal.HomeBuilderServlet] - Started Home Builder at /homebuilder 2020-12-09 05:56:16.333 [INFO ] [zwave.handler.ZWaveControllerHandler] - Attempting to add listener when controller is null 2020-12-09 07:46:37.667 [INFO ] [openhab.ui.paper.internal.PaperUIApp] - Stopped Paper UI 2020-12-09 07:46:37.813 [INFO ] [ebuilder.internal.HomeBuilderServlet] - Stopped Home Builder 2020-12-09 07:46:37.855 [INFO ] [panel.internal.HABPanelDashboardTile] - Stopped HABPanel 2020-12-09 07:46:38.015 [INFO ] [basic.internal.servlet.WebAppServlet] - Stopped Basic UI 2020-12-09 07:46:38.341 [INFO ] [.dashboard.internal.DashboardService] - Stopped Dashboard 2020-12-09 07:48:26.333 [INFO ] [thome.model.lsp.internal.ModelServer] - Started Language Server Protocol (LSP) service on port 5007 2020-12-09 07:48:30.965 [INFO ] [.dashboard.internal.DashboardService] - Started Dashboard at 2020-12-09 07:48:30.974 [INFO ] [.dashboard.internal.DashboardService] - Started Dashboard at 2020-12-09 07:48:32.765 [INFO ] [panel.internal.HABPanelDashboardTile] - Started HABPanel at /habpanel 2020-12-09 07:48:33.075 [INFO ] [ebuilder.internal.HomeBuilderServlet] - Started Home Builder at /homebuilder 2020-12-09 07:48:33.525 [INFO ] [openhab.ui.paper.internal.PaperUIApp] - Started Paper UI at /paperui 2020-12-09 07:48:50.042 [INFO ] [zwave.handler.ZWaveControllerHandler] - Attempting to add listener when controller is null

that is openhab debug log that’s irrelevant
what I need is the output you get in the terminal where you run openhabian-config

I’m sorry I am not sure what you are looking for exactly, are you looking for the commands that are run when I try to hit menu 35?


this is what happens when i try to enter menu 35
[11:57:52] openhabian@openhab:~$ sudo openhabian-config
[sudo] password for openhabian:
2020-12-09_12:30:28_EST [openHABian] Checking for root privileges… OK
2020-12-09_12:30:29_EST [openHABian] Loading configuration file ‘/etc/openhabian.conf’… OK
2020-12-09_12:30:29_EST [openHABian] openHABian configuration tool version: [stable]v1.6.1-963(1fa8959)
2020-12-09_12:30:30_EST [openHABian] Checking for changes in origin branch stable… OK
2020-12-09_12:30:47_EST [openHABian] Switching to branch stable… OK
2020-12-09_12:31:07_EST [openHABian] Updating Linux package information… OK
2020-12-09_12:31:12_EST [openHABian] We hope you got what you came for! See you again soon :wink:
[12:31:12] openhabian@openhab:~$

Enable debugmode=maximum first in openhabian.conf

I already did. that is with it set to maximum

no it isn’t

sudo nano boot/openhabian.conf

# Modify your openHABian settings
# Handle with care, only touch if you need to!!
# This file will only be used on unattended initial install.
# If you want to change anything after unattended install completed, use menu in openhabian- 

# Hostname to set this one to
# the default user (with its working environment) will be renamed to this username given here ...
# ... and given this password. The password will be removed from this file after completion for 
security reasons.

# Language and timezone. See Debian documentation for valid values.

locales="en_US.UTF-8 de_DE.UTF-8"

# WiFi settings. An ethernet connection is recommended.
# If you have a RPi4, RPi3, RPi0W or a supported external WiFi dongle, the WiFi
# interface can be setup and used for the initial installation.
# Fill in your SSID and password below, leave empty or put comment in front to
# have your WiFi remain unchanged/uninitialized. Make sure your Ethernet works.
# ATTENTION: you need to escape these special characters: $, `, ", \, (newline)
# 'Escaping' means to put an additional \ in front of that character

# Wi-Fi setting. Select a two-letter country code suitable for your location
# E.g. US (default), DE, AU, NZ...
# You may infringe on local legislature otherwise
# See https://en.wikipedia.org/wiki/ISO_3166-1_alpha-2 or /usr/share/zoneinfo/zone.tab

# Eventually disable all IPv6 e.g. on installation problems
# values: "enable", "disable"

# repo to clone from (if not master for build and test)

# debug verbosity mode
# off, on (verbose output in log) or maximum (show every command)

sudo systemctl reboot

There is an extra backtick (`), delete that
No need to reboot

same thing
[18:25:35] openhabian@openhab:/$ sudo openhabian-config
2020-12-09_18:25:40_EST [openHABian] Checking for root privileges… OK
2020-12-09_18:25:40_EST [openHABian] Loading configuration file ‘/etc/openhabian.conf’… OK
2020-12-09_18:25:40_EST [openHABian] openHABian configuration tool version: [stable]v1.6.1-
2020-12-09_18:25:41_EST [openHABian] Checking for changes in origin branch stable… OK
2020-12-09_18:25:49_EST [openHABian] Switching to branch stable… OK
2020-12-09_18:25:56_EST [openHABian] Updating Linux package information… OK
2020-12-09_18:26:06_EST [openHABian] We hope you got what you came for! See you again soon :wink:
[18:26:06] openhabian@openhab:/$

possibly you have messed up the conf file? It works with anyone else. Without debug output I can’t help sorry.

I have a openhabin pi at my parents house to control some tp link stuff that I have also been trying out openhab 3 on I never touched the openhabin.conf file or done anything other than change the system local, time zone and the upgrade to openhab 3 option and tried to go to menu option 35 and same thing I then installed the older openhabian 1.6 on a 3rd pi and disconnected it from the internet to keep it from updating and menu option 35 works properly and I was able to disable the Bluetooth for the hat that way. Then did the same thing on the first pi and it worked again. But as soon as it updates the problem is back

I meant openhabian.conf. If you don’t turn it into debug mode I cannot help you.
Try to copy /boot/openhabian.conf over to /etc
When you have a working system show /boot/config.txt of that