Unable to parse ip

I can SSH into my Raspberry Pi but none of the links work.

Is openhab running?

sudo systemctl status openhab2.service

You get nothing at http://openhab/

Can you post your log?

SSH - cat /boot/first-boot.log

NONO stop

Its a RPI4 8gig their will be a problem with zram install

Open the

sudo openhabian-config

System Setting

Uninstall Zram

Restart openHAB

sudo systemctl status openhab2.service

I have a PI4 8gig also and to get zram to work you need a 64bit kernel but its untested and not recommended.

This is what happened when I tried to type in the commands you listed in your reply

This is what happened when I tried to uninstall Zram

It says on PuTTY that there are 2 connections however I get nothing at http://openhab/

And on PuTTY it says unable to parse ip

FireMotd should just be the output and give some information about your system like IP and number of session.
The command that is being used to determine the hosts ip address is:

/sbin/ip route get | head -1 | grep -Po '(?<=src )(\d{1,3}.){4}'

What is the output of

/sbin/ip route get

If that already does not work then catching the local IP address from the output also will not work.
Sessions is the number of logged in sessions for the current user:

who | grep -c "$USER"

What is the output of

sudo netstat -tulpe --numeric-ports |grep java

Dear Wolfgang,

it seems to me I have a similar problem…

I setup a brand new PI 4/8 with 128GB SD and the recommended “openHABian-OS”.
… I was wondering about changing HDMI settings after the first reboot :wink:

Anyhow I have the same “error” --> unable to parse ip. please debug!
Different to the topic of SamH1999 I’m able to access the server via SSH and HTTP…
But im to sure to proceed with installation because it seems to me bug (and you never know…)

I followed your instruction but I can’t identify any “issue”:

/sbin/ip route get | head -1 | grep -Po ‘(?<=src )(\d{1,3}.){4}’

/sbin/ip route get
–> via dev eth0 src uid 1000

arp -a
pi.hole ( at dc:a6:32:53:75:3c [ether] on eth0
SecurityGatewayUSG ( at 80:2a:a8:cd:e1:69 [ether] on eth0

who | grep -c “$USER”
–> 2

sudo netstat -tulpe --numeric-ports |grep java
tcp6 0 0 localhost:43993 [::]:* LISTEN openhab 17079 781/java
tcp6 0 0 [::]:8443 [::]:* LISTEN openhab 18177 781/java
tcp6 0 0 [::]:8101 [::]:* LISTEN openhab 18175 781/java
tcp6 0 0 [::]:5007 [::]:* LISTEN openhab 19092 781/java
tcp6 0 0 [::]:8080 [::]:* LISTEN openhab 17088 781/java
udp6 0 0 [::]:5353 [::]:* openhab 18211 781/java


[12:31:37] openhabian@openhab:~$ ifconfig
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet netmask broadcast
inet6 fe80::54e9:3810:a552:e59 prefixlen 64 scopeid 0x20
ether dc:a6:32:d5:ef:e7 txqueuelen 1000 (Ethernet)
RX packets 26178 bytes 4501701 (4.2 MiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 9963 bytes 1869219 (1.7 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet netmask
inet6 ::1 prefixlen 128 scopeid 0x10
loop txqueuelen 1000 (Local Loopback)
RX packets 140 bytes 11328 (11.0 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 140 bytes 11328 (11.0 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

Any idea how to fix?

Best regards

… brand new member :slight_smile:

First, provide proper information if you want help:

Second, your system is severely screwn up when it doesn’t even know the systemctl command.

Third, your DHCP/DNS setup is probably bad which is why your box didn’t obtain a proper IP or cannot use your DNS resolver.
@bauerpower same for you, but don’t invade others’ thread please.

Read the debug guide for things to try.

Your best bet is to fix your router first and then to install again from scratch using the openHABian image. You seem to be using a RPi4/8GB (not a good choice as the docs tell you) which does not work with ZRAM but the install routine should recognize that and not install ZRAM in the first place.

Dear Markus,

thank you very much for your advice … very much appreciated.

Should I create a new topic?

Regarding your recommendation… I reinstalled from scratch already 5 times :slight_smile:
I’m using a UNIFI Network and I never had any problems with my DHCP-Server
From my DHCP Server it seems the IP-request was handled correctly.

Do you think I should switch to P3 (I have one)?

Thank you for your help (appreciated)


Should I create a new topic?

normally yes but no

No point in that as now you have one :expressionless: but please don’t expect me or others to debug your setup.
Follow the debug guide, try disabling IPv6.
openHABian is standard Raspi OS w.r.t. networking so you can google that up in a Raspi or networking forum.
Don’t get mislead by the ‘Unable to parse ip’ output, it’s just the output of the FireMotD script.

Firstly I’ve provided information clearly showing the issue is that it says unable to parse IP and that I get nothing at http://openhab/ even though it says they’re are two active connections

Secondly you saying my systems screwed up is in no way helpful at all in terms of helping me solve the issue

Thirdly I haven’t changed any DNS/DHCP settings on my router

Also I have already tried reinstalling it from scratch twice now as it was working properly 3 days ago then stopped working and that hasn’t fixed anything and that hasn’t solved the issue.

If it was working 3 days ago clearly it isn’t a problem with the router.

1 Like

Sorry for coming across as rude but I am just trying to help. As @rlkoshak mentioned I’m no native speaker so please attribute this to cultural differences and us (or me) being just another ‘harsh’ German.
For comprehensiveness, though: your posts are perceived by me as also somewhat rude: you ignored several of the items from the ‘how to post’ post I referenced, you didn’t provide any of the information it would take to help you, and still expect a no less than “helpful” answer (a solution as per your standard I presume) from volunteers like me spending their little spare time to help you for free.
And your response to them trying to is to complain with the moderators … not quite a move motivating me or others to help you in the future.
(and just for a fun comparison, see @bauerpower’s completely different reaction to the albeit very same post of mine).

Ok I suggest we stop the blaming here and try getting your box to work instead.

“unable to parse IP” is only the output of the FireMotD tool which does not necessarily represent the
state of the system. Obviously you can login so a fair amount of IP connectivity is there.

Well I thought it is but eventually I still wasn’t explicit enough then.
On the fact side of things, the little information you gave indicate your box is currently so broken that it does not make sense to try debugging, it would turn out to be a waste of time on everyone’s part. Yours, mine, everyone else’s.
When systemctl isn’t there as it shows it isn’t on your box, the openHAB service is also (very likely) down. Which explains why you cannot connect to it on port 8080.
This is why the probably fastest path to a solution is to reinstall right away … which is what I advised you to do next. If you asked me, I would call that ‘helpful’. I admit I should have explained better, but I was a bit in a hurry, sorry.

These sort of problems are very hard to figure out, even more so from remote.
There’s no IFTTT like template how to cope with the situation.
Have you read the debug guide I referenced ? It tells you how to enable extensive logging on automated image installs and what else you could try.

As already advised, reinstall from scratch. Read the docs how to re-parametrize your next install run before you start.
Use clonebranch=master, debugmode=maximum, ipv6=disable and zraminstall=disable
in openhabian.conf. Post the logfile /boot/first-boot.log here (spell it correctly, boot vs bot as you typed it) then we can have a look at what’s going wrong along the (installation) way.

with this output I would expect to see the IP address in the FireMotd output as this is the code that is being used in the FireMotd script.

Forget about the ‘unable to parse ip’. It’s probably just output of a broken script (FireMotD) and not necessarily a real issue with your system. That being said, do you have a route to ?
Is there any other symptom or maybe you don’t have any problem at all ?

BTW you used wrong quotes when you quoted the /sbin/ip command

If your being rude of course I’m going to complain to an administrator as this forum has a if you see a problem flag it policy.

Frankly saying English is not my native language is no excuse for being rude. I regularly interact with lots of non native English speakers and they are no where near as rude as you.

And while I was more than willing to give you the benefit of the doubt after talking to the administrator it’s clear from your response that you don’t deserve the benefit of the doubt as your rudeness is a common issue

As is evident by the fact the administrator said Markus in particular comes across as blunt and sometimes blunt to the point of rudeness.

This makes me believe that many people have reported you for being rude in the past and that speaks volumes about you.

I have provided the thread with all the information I have which is screenshots showing it saying unable to parse IP, screenshots showing I can’t access my openhab even though it says I’m connected and screenshots showing the commands I was asked to enter didn’t work. I also mentioned how it was previously working 3 days ago.

You could have politely said I need more information and given me a list of the some of information that would be required to help me be able to solve my problem like the administrator did but you didn’t

Frankly your “apology” if you can even call it that clearly isn’t an apology it is just you complaining that I reported you as I had every right to do and effectively making a threat that you and others won’t help me in the future as I reported you.

This forums policy is if you see a problem flag it and your reaction is precisely the reason people stay silent.

After talking to the administrator I got some helpful advice on what I should try next which was that it might be a hardware issue and to try replacing the SD card and if the problem still persists to try a raspberry pi forum.

Helpful suggestions don’t always have to be the solution to a problem.

For example one person offered a helpful suggestion saying try looking at the logs which while it didn’t solve my problem, it was still a helpful response whereas your advice was your system is severely screwn up.

As you can see there is a clear difference between the advice I got from someone else and the advice you gave.

You also said I come across a rude for ignoring several items from the guide you linked when I haven’t as I will demonstrate below

  1. Did you search

yes I did and there were no similar questions as you can see from the screenshot below

  1. Did you search correctly

Yes I did as I searched only for the specific error which is unable to parse IP as you can see from the screenshot below

  1. I found a similar topic but it’s already solved and I still have a problem. Should I post in it?

This was not relevant to my search as there were no similar topics as you can see from the screenshot below

  1. Did you read and search the docs ?

Which I did

  1. choose a category

I chose setup configuration and use and beginners which are the appropriate categories

  1. Title

The title clearly states my issue so it is a good title

  1. Tags

The tags I used were openhab2 ssh and debug which are appropriate tags for my question I would have used more but you are limited to 3

  1. describe you goal

It’s very clear from the screenshots my goal is to access openhab on the internet and I clearly said that this is the issue that I’m facing so it’s obvious the goal is to not be facing this issue

  1. show effort

There were no similar posts to mine so I couldn’t have posted similar links

I described what I have tried for example when I tried entering the commands given to me and when I tried installing and uninstalling zram as suggested and when I tried reinstalling openhabian from scratch

  1. describe your environment

It clearly says in the screenshot what version of raspberry pi and openhabian I am using

  1. describe what you changed and what’s happening now

I did this when I said I’ve tried uninstalling zram and when I said I’ve tried reinstalling openhabian from scratch and the problem is persisting

  1. Use proper formatting

I have used proper formatting

  1. Attach examples

This was not possible for my thread

  1. reread it

Which I have done

  1. Should I mention people in the post?

Which I haven’t done like it says. However you have 3 times through the thread even though it says not to.

You also accuse me of blaming which I’ve not done at all. All I have said to the moderator is you came across as rude and the moderator assured me that it was just because your not English and I gave you the benefit of the doubt then you reply to the thread accusing me of being rude for not following a guide I followed and say how that me reporting you validly will make you and others not help me in the future

It’s also clear that you haven’t read my response fully as otherwise you would be aware that I’ve already tried reinstalling openhabian from scratch which is what you suggested to do in your last reply.

1 Like

There isn’t an administrator. There is a group of moderators, and Markus is among them. That’s what the little grey shield icon indicates next to the user name.

No, not frequently. I can’t remember any other reports frankly. But I’ve seen cases where his (and other) posts have devolved into accusations of rudeness and such. Having worked with him and other similar posters for years, I know that rudeness is not the intent.

I didn’t ask for information. I just confirmed that you didn’t provide enough information. I didn’t provide a list of what information would be needed.

We can continue wasting all our time being angry at each other and accusing each other of rudeness, or we can let it go and move on. It’s not productive.

Thanks Rich for setting the record straighter. As you can imagine I was tempted to answer all the accusations and correct a number of improper statements (just one for the record: the search function of the forum is broken at the moment, which is pretty unfortunate in this context).
I tried getting productive instead with my last post by giving detailed instructions on how to proceed.
But as that also wasn’t valued I decided to let go and cease wasting my efforts and time here.

I tried getting productive instead with my last post by giving detailed instructions on how to proceed.
But as that also wasn’t valued I decided to let go and cease wasting my efforts and time here.

Facts don’t care about feelings.

Mr Storm is one of the go to people when I have a problem with openhaian. Mainly I just read the manual. I work for a Mc massive company onsite every day at client’s facility’s fixing issues the client dosen’t know the terminology to ask me to fix the issue. I am use to the 100 questions to get 1 answer.

Now @SamH1999

Without being to blunt.
Where are we at?

As the forum search option is having a problem - I tracked down the issue for the “Unable to parse ip”-message with another user some days ago. The problem was an outdated version of FireMotD. Please have a look here:

You can try to run:

/usr/local/bin/FireMotD --version

The version I am using is:
FireMotD v12.05.191019

Additionally you can run:

sudo /usr/local/bin/FireMotD -S
sudo /usr/local/bin/FireMotD --theme Gray

This should at least solve the display-problem of the IP.


I have the same issue with “Unable to parse ip” in the SSH startup. I just installed openHABian 2 days ago from the latest stable version on github. I am running on a Raspberry Pi 3B, Raspbian GNU/Linux 10 (buster), OpenHAB 2.5.10-1 (Release Build). The FireMotD version comes back as:

FireMotD v12.05.191019

I tried using Flip’s last suggestions:

sudo /usr/local/bin/FireMotD -S
sudo /usr/local/bin/FireMotD --theme Gray

That did display the IP properly when it ran the last command but on rebooting the same “Unable to parse ip” came back up again. Everything else seems to be working properly. I am just a bit concerned since it says “Please debug.” Any suggestions? Just ignore the message?

Sometimes FireMotD is installed in 2 locations:


Please check the .bash_profile and .profile in your openhab-users home-directory.

Additionally you can run:

which FireMotD

as openhab-User to see which path is used…