Unable to update things parameters

Hello all,

I am encountering an issue while trying to update the “thing” parameter after is included to the z-wave network. I did find a few other posts in the forum but they are quite old and I did not find a solution which works for me. This seems to be only happening to z-wave things as I am able to update label and parameters of other things in my openhab. I am getting a 500 server error when I press the save but on the UI.

> app.js:7 PUT http://10.2.2.65:8080/rest/things/zwave:device:319223662b:node14/config 500 (Server Error)

If I try to update form the API explorer, I get the following error:

“error”: {
“message”: “class org.openhab.binding.zwave.handler.ZWaveSerialHandler cannot be cast to class org.openhab.binding.zwave.handler.ZWaveControllerHandler (org.openhab.binding.zwave.handler.ZWaveSerialHandler is in unnamed module of loader org.eclipse.osgi.internal.loader.EquinoxClassLoader @1a5052c; org.openhab.binding.zwave.handler.ZWaveControllerHandler is in unnamed module of loader org.eclipse.osgi.internal.loader.EquinoxClassLoader @2a56c)”,
“http-code”: 500
}
}

I am currently running openHAB 3.1.1 - Release Build and hoping this has been noticed by another member of the community.

So I really do not understand.

What thing(s) and parameters are we talking about? i.e things

Are they battery? or main powered?

What specific parameters?
Have you checked the database to make sure that parameter exists or your update is in the range?

If you are trying to change

zwave:device:f1c4372132:node14

it is linked to the controller ID and can’t be changed after inclusion.

Bob

Bob,

I am trying to edit the label for any zwave thing or its configuration parameters for example, change temperature scale of this temperature sensor.

image

It doesn’t matter whether it is battery or main powered and the things are online and working properly but changing the parameters of any zwave thing does not work. On the other hand I am able to edit any linked channel and items.

Thank you

Are the devices defined from a thing file or were they discovered via scan?

They are discovered via scan, this used to work but I have a feeling it stopped working after I ran an update.

It took me a bit but I figured out that I am able to edit the label of a thing via API explorer but I am still unable edit any other parameters via API explorer or the UI.

To answer your original question, I have not observed the behavior you describe. I can’t answer for everyone, however.

The only times I have been unable to edit in the UI is if there is a Lock because the thing was defined as a file.

Also, sometimes there are transitory issues when the device is not fully configured. Are there XML files for these nodes in userdata\zwave? A long shot idea would be to reinitialize the device.
Five Lines of configured node

Sorry I could not help more, maybe someone else can.

Bob

Bob,
I appreciate the help, my things are not locked at all and I do have the xml file locate in /var/lib/openhab/zwave which is created automatically. Unfortunately I see plenty of REST error in my logs and unable to change any parameters from the UI.

Noticed this; Maybe related?

Please check which ZWave bundle is installed, see:

1 Like

I see there is the same error: 500 Server error.

@pguima Is it possible to do changes to other Things that are not Z-wave?

@Ap15e, you’ve done it, hit the nail on the head. I had two versions of ZWave bundles installed.Once I uninstall the older version things started to work again. @vegarroe, yes this was only affecting zwave things.

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.