Unelvent ventillation Modbus configuration

Tags: #<Tag:0x00007efecb125428> #<Tag:0x00007efecb125310>

It took me a bit of time to find the correct information and have the correct configuration to get all the information from an Unelvent ventillation so I though it might be worth sharing.

Tested only with the Domeo 210 FL but should be compatible with following versions:

  • Domeo 210 FL
  • Domeo 210 + hygro sensor
  • Domeo 210 constant airflow FL
  • Domeo 210 constant airflow radio
  • Domeo hygro
  • Flexeo 210 FL
  • Flexeo 325 FL
  • Flexeo 210 constant airflow radio
  • Flexeo 325 constant airflow radio
  • Ideo 300 constant airflow
  • Ideao 450 constant airflow
  • Ideo 300 constant pressure
  • Ideo 450 constant pressure
  • Ideo 300 constant speed
  • Ideo 450 constant speed

This configuration is based on the Modbus binding version 2.
Installation of the Modbus binding is enough, not need to create a thing in the paperUI.

All the files: .items, .sitemap, .things and transformations can be found on GitHub

(the sitemap is basic, and needs to be adapted depending on your ventillation version).

1 Like

Hi Fabian,
i’ve been trying to connect a domeo 210fl with modbus, but it seems to not work at all, i tried with a waveshare usb to 485 adapter and also with a max485 and arduino :slight_smile: …(not using yet your openhab integration) in all cases i get a timeout or an error communicating with the device .

I see in the docs of your integration that jp1 should be in place to enable it, and i did exactly that, the physical remote was disabled as expected but still nothing on the modbus side, can you tell me what you have done to enable it ?

Thanks!

Once you install jp1 you have to restart the device to enable the communication.
Also do you use the correct settings for the modbus?
baud=19200
stopBits=“1.0”
parity=“even”
dataBits=8
encoding=“rtu” ?

i tried restarting the unit after the change and i got the same result, im using those parameters to connect and i tried already with a waveshare to rs485 usb device and also with an arduino and a max485 (both work on other modbus devices)

I even tough that maybe my model does not have modbus, but i see that in my model it is indicated as functional (i attach the manual pictures) i have the domeo 210 fl 3v

Thanks a lot for your help, i really appreciate it !

Sorry that it doesn’t work.

I am using a basic Modbus to USB connector and could connect both with a windows computer and now a raspberry without difficulties.
For information, I am not using the RJ45 connection for the Modbus, but the A and B wire connection next to it.

Also Unelvent have a good after sales service, you might want to try to contact them.

i tried the rj45 port and also the other one, that does mention modbus bellow, but instead of A B 0 it has D1 D0 COM…
can you just tell me if your board is similar to mine ?

Also any idea what that female USB port is for ? (maybe a wifi pen )

It seems that I have a earlier version of the board. Mine is showing A B 0…
And doesn’t have the female USB port.

Second connector down on righthand side is marked for A / B / 0 (and 12V).
I think you’re on the wrong connector.

The D0/D1 connector might be RS232 Modbus port or suchlike.

No the D1 D0 COM connector next to the RJ45 is the good one. As you can see below the connector it is marked as Modbus.
And it corresponds with the board description given in the manual.