Unifi Binding Openhab 3.0

thanks i will try new bridge again. otherwise new installation openhab3.0

Not sure here, but I have a new install of OH3, and the UniFi binding doesn’t work for me. I found this in another thread re: controller version 6.0.43:

Unfortunately, they changed the way how to communicate with the Controller
The binding is also not reflecting the new two-factor authentication :frowning:

Hopefully, the author of this binding can help to get it back to work

do something for it to work?

so is it a particular configuration on the cloud key because I run 6.0.43 and binding working fine. I never enable remote access or have any integration of it to the web for example.

I was mistaken, I went in, reconfigured my read-only user, and resetup the controller connection and it is working.

So, @jcosta46, maybe try to build a new one, and see if you get any errors in either the openhab or events log files.

1 Like


I don’t get, how this can work. With the new interface my Unifi-Controller (Unifi-Cloud-Key2) is not accessible through port 8443 but only 443…
Port 8443 is closed and Port 443 does not work…
So there must be some adjustment necessary.


Mine also fails on a UCK2p. I think there was a change in paths and authentication when the firmware bumped to 2.x and UniFi OS that has broken this.

More info in this thread: Ubiquiti Unifi Binding Feature Discussion - #1128 by pagm

Hi Daniel - there is currently limited to no support for the most recent versions of the Unifi OS. I had to backport some 6-month old work that was never merged into main to get it to work. Looks like there has been some progress in the last couple of weeks but I don’t know the full status. See Ubiquiti Unifi Binding Feature Discussion - #1136 by Crispin for discussion.


I was hoping, that the docker container was not yet updated… as I understood the discussion in your link there is already a configuration variable (cloudkey) to address the issues, but at least for me with the latest docker version I am still out of luck.


Hi, i had a similar issue with my unifi binding, but i just solved it by chance:

In the bridge thing settings, I activated in UniFi OS setting and disabled/enabled the thing several times because i was interested in the log output.
After that exercise a deactivated the UniFi OS setting and by chance the bridge thing status became online.

Hope that this info helps some of you and that the bridge stays online.

openHAB 3.1.0.M2 and Unifi Controller 6.0.45_14358 on rpi4

1 Like

My Problem is, that I cannot upgrade to 3.1 because I am on docker. Secondly, the unifi bridge thing dialog looks like this and there is no configuration possible.

Had a similar problem here. New OH 3 “server to be” worked already with the UniFy binding, then constantly problems with establishing the SSH connection. Remembered that I upgraded the controller in between. Todyay a new version (6.2.23) of the controller was announced. Installed it, and everything works again.

1 Like

I concur :slight_smile:

Could someone please post the configuration? This is not working:

Bridge unifi:controller:home3 "UniFi Controller" [ host="", port=8443, cloudkey="true", username="openhab", password="password", refresh=30 ] {
	Thing wirelessClient 1stiPhone "Daniels iPhone" [ cid="f0:xxx:02", site="default", considerHome=180 ]
    Thing wirelessClient 2ndiPhone "2nd iPhone" [ cid="90:xxx:08", site="default", considerHome=180 ]    


this is the error with 3.1.0 M3:

2021-05-22 11:41:18.244 [ERROR] [.handler.UniFiControllerThingHandler] - Unknown error while configuring the UniFi Controller
org.openhab.binding.unifi.internal.api.UniFiException: Unknown HTTP status code 404 returned by the controller
	at org.openhab.binding.unifi.internal.api.model.UniFiControllerRequest.getContent(UniFiControllerRequest.java:167) ~[bundleFile:?]
	at org.openhab.binding.unifi.internal.api.model.UniFiControllerRequest.execute(UniFiControllerRequest.java:131) ~[bundleFile:?]
	at org.openhab.binding.unifi.internal.api.model.UniFiController.executeRequest(UniFiController.java:207) ~[bundleFile:?]
	at org.openhab.binding.unifi.internal.api.model.UniFiController.login(UniFiController.java:114) ~[bundleFile:?]
	at org.openhab.binding.unifi.internal.api.model.UniFiController.start(UniFiController.java:97) ~[bundleFile:?]
	at org.openhab.binding.unifi.internal.handler.UniFiControllerThingHandler.initialize(UniFiControllerThingHandler.java:92) [bundleFile:?]

After upgrading from OS 3.0.2 to 3.1.0, the UniFi Controller thing was not initializing anymore.
I have UniFi Controller 6.3.51.
I was able to fix that by enabling the new setting “UniFi OS”, saving, disabling it again and saving.
Now the Controller thing is working again.


Thanks, this helped my uninitialized Controller Thing to be online again, after my upgrade to 3.1.0

Wow … basically there’s a bug in the binding were it is not correctly setting default value for “unifios” parameter (and it is not documented as well). Five seconds fix is “unifios=“false”” or “true”:

Bridge unifi:controller:home "UniFi Controller" @ "Whole House" [ host="xxx", port=8443, unifios="false", username="xxx", password="xxx", refresh=20 ] {
	Thing wirelessClient ....

Thanks for pointing in the right direction.


I hope someone can help me with oH3.2 and Unifi Binding:
(The Unifi controller software is running on Proxmox VM)

The log says:

2022-02-17 20:04:58.784 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'unifi:wirelessClient:home:phoneDirk5G' changed from INITIALIZING to ONLINE
2022-02-17 20:04:58.811 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'unifi:wirelessClient:home:phoneDirk4G' changed from INITIALIZING to ONLINE

But there is nothing in the sitemap:


Bridge unifi:controller:home "UniFi Controller" [ host="192.168.YYY.XXX", port=8443, unifios=false, username="wifiadmin", password="qwertz", refresh=10 ] {
	Thing wirelessClient phoneDirk4G "Smartphone 4G" [ cid="XX:XX:XX:0D:61:CC", site="default", considerHome=180 ]		
	Thing wirelessClient phoneDirk5G "Smartphone 5G" [ cid="FF:FF:FF:61:AA:DD", site="default", considerHome=180 ]		


// Smartphone 4G @Unifi

    Switch     SmartphoneDirk4G_Online       "Redmi Note 8pro 4G: Online [MAP(unifi.map):%s]"           (Gunifi)      {channel="unifi:wirelessClient:home:phoneDirk4G:online"}
     DateTime   SmartphoneDirk4G_LastSeen     "Redmi Note 8pro 4G: Last seen [%1$tH:%1$tM:%1$tS]"                            (Gunifi)      {channel="unifi:wirelessClient:home:phoneDirk4G:lastSeen"}

// Smartphone 5G @Unifi

    Switch     SmartphoneDirk5G_Online       "Redmi Note 8pro 5G: Online [MAP(unifi.map):%s]"			(Gunifi)      {channel="unifi:wirelessClient:home:phoneDirk5G:online"}
    DateTime   SmartphoneDirk5G_LastSeen     "Redmi Note 8pro 5G: Last seen [%1$tH:%1$tM:%1$tS]"                            (Gunifi)      


sitemap test label="Test" {

    Frame label="Unifi" {
        // Switch   	item=SmartphoneDirk4G_Online
        // Switch     	item=SmartphoneDirk5G_Online
		Text   		item=SmartphoneDirk4G_Online
        Text     	item=SmartphoneDirk5G_Online
        Text        item=SmartphoneDirk4G_LastSeen
        Text      	item=SmartphoneDirk5G_LastSeen