Unknown Device Eurotronics Spirit Z-Wave Plus

Tags: #<Tag:0x00007f4337feab88> #<Tag:0x00007f4337feaac0> #<Tag:0x00007f4337fea890>

Had the same problem, as a result rolled back to 2.5.10
Cheers,
r.

Acording to this openHAB 2.5.11 there were no changes to z-wave binding.

Maybe someone can help with it.

@rsobiczewski,

thanks for this information. So you are conforming it was fine in 2.5.10.

@kristofejro,

I found this also discussed in an oh3 thread: https://community.openhab.org/t/oh3-z-wave-is-it-possible-to-force-reinitialise-devices-without-re-pairing/107556/58
Seems more like a database problem, than an binding problem, as far as i understand it.

@chris wrote there was a new build this night. I had no chance to check it so far. I will try later.

Yes, it works fine with 2.5.10. Also note that the 2.5.11 for the already configured devices does not allow to set any configuration parameters - neither via PaperUI nor Habmin…

@kristofejro, @rsobiczewski,

I could confirm, that (@chris) tonights build of the Z-Wave binding solved the problem. With Snapshot 2.5.12.202012160333 the Eurotronics Spirit are working as expected.

2 Likes

There were database updates. They have quit listing them in the Release Notes.

Thanks @icsat for that information.

Could you tell me how to implement snapshot version of the binding?
Did you you get it from: openHAB2.5.x-ZWave ?

Is it [SOLVED] Link to Zwave binding SNAPSHOT 2.5 correct way to upload it?

Thanks

The easiest way is usually this script.

1 Like

@kristofejro,

Could you tell me how to implement snapshot version of the binding?
Did you you get it from: openHAB2.5.x-ZWave ?

Yes, that is where i got it from.

Is it [SOLVED] Link to Zwave binding SNAPSHOT 2.5 correct way to upload it?

I would prefer the way @Bruce_Osborne pointed at.

Personally I uninstall the Z-Wave binding by Paper UI manually and put the jar-File into the “/usr/share/openhab2/addons” folder on my Raspberry Pi using my own restart-script.

That works unless there are uninstalled dependencies. For instance if somebody uses the script to install the 2,5 snapshot on .4, it also installs the missing dependencies automatically.

@Bruce_Osborne,

you are right. Thats why I answered:

I would prefer the way @Bruce_Osborne pointed at.

1 Like

Thank you guys for your help. It is working now on snapshot binding.

Now binding is present in karaf console but not in PaperUI.
How it will look like when new version (2.5.12) of OH will come out?
What steps should I take when upgrading?

That is expected for manually installed bindings.

How it will look like when new version (2.5.12) of OH will come out?
What steps should I take when upgrading?

Delete the jar file from addons, upgrade, install zwave binding.

If history holds true it may be wise to restart OH enough to get it stable before installing the binding.

If you used the script to install the binding, then use the script to uninstall too, so that the dependencies are removed. These are additional jar files downloaded to the adfons directory, so you could just manually delete them too, but that usually requires at least a reboot, but you may need to clear the cache too.

2 Likes

Any chance this will make it to a stable build anytime soon? Since I´m a OH beginner I´m trying to avoid messing around with snapshots. Thanks for your help!

Best, Micha

It can only make it inot a stable build when there is a release - but it will be in the next release.

Hi,
solved for me with update 2.5.12.
Thanks!

For me as well BUT only for one device. When I tried adding a second one (same model) it told me “unknown device” again.

Sometimes manufactures change the device identity though. Please post the xml file created by OH in the zwave folder of userdata. If there is no file, the binding did not complete device discovery. The information in that file comes from the device itself.