Unknown device with Linear NGD00Z-4

Yikes, so I would need to downgrade to OH1.x, assuming it supports security?

Until security is integrated into OH2, yes, this might be your best bet if you need this. You can run the OH1 binding under OH2.

Oh okay. So I’m still a newb at this, starting off with OH2. I assume I have to enable 1x compatibility and copy the org.openhab.binding.zwave-1.9.0.jar file from OH1’s addon release into the /addons directory.

After doing so, is the 1x Z-Wave binding suppose to be selectable/enabled via Paper UI? If not, what guide should I follow to add and access Things via this OH1 binding?

You need to treat it like it was running under OH1 - so everything needs to be configured the same way as in OH1 (ie refer to the OH1 wiki for item configuration etc).

I see that OH2 z-Wave binding now supports security (Update from: OH2 Z-Wave refactoring and testing... and SECURITY)

I was able to securely include the Linear NGD00Z-4 into OpenHab2, however, I still see only the “BARRIER_POSITION” number channel. I don’t see the switch the operate the Garage Door opener.

Was this ever integrated into OH2 ?

I am running the latest Z-Wave OH2 binding that includes security. Security is working with my other locks, but I am also struggling to get a good secure pairing. I get a lot of “SECURITY_INC State=FAILED” which I believe means that secure pairing failed - and if I understand correctly, I won’t see the channel for actual door control. @chris is this true?

Yes - that’s correct.

OK, I will keep trying to exclude and reinclude until I get a “secure” pairing. What a pain!

I’m happy to take a quick look at a log (debug of course ;)) if you want to send it (create a ticket on my website - it’s more secure for security logs). It may not show too much, but I’m happy to look.

I’d really make sure it’s reset - excluding it should be enough I would think, but if there’s another way to reset it I’d give that a go too…

Sounds good, I will probably send over logs in the next couple of days. Exclude and full reset of the device then pairing with less than an inch between them isn’t getting me far enough. I’ll get debug logging enabled, read them, and if it isn’t clear what’s going on I’ll send them your way.

Submitted a ticket with log.

I added this device (the Lowe’s Iris flavor) using the security enabled zwave binding on oh2 (though not the latest binding) and after waiting some minutes it pulled in the barrier position channel just fine on the first try. I also see zwave_secure true in the thing properties. Not sure if I’m missing a switch for control as I haven’t had time to fiddle with it.

No switch is needed. Sending 0 to barrier_position channel will close the door. Sending 255 will open the door.

I have finally upgraded up to Version and am now trying to re-add the NGD00Z. It finds it as Node 7. But, it doesn’t seem to add securely and comes up as an unknown device. I don’t even see the barrier_position channel.

I have attached my logs for Chris to look at please. I hope I am missing something simple.

node7.xml (119.1 KB)

Are you running the standard snapshot version, or the development binding downloaded directly from my site? I think the standard snapshot, which doesn’t support security.

If you want to use security, then you need to use the version described in the following link -:

I believe the standard from the openhab unstable apt repo. I will dl this jar. What directory does it go in, and do I need to exclude / include the device again?

Take a look at the installation instructions and some discussion - it starts 5 or 6 messages into the thread.

You won’t need to exclude/include, but you will need to delete the things and add them back in. The exception is if you want to use security on a device - these will need to be excluded and re-included…

Thanks @chris. I have updated to the binding that has security from your link. I deleted all the items and added them back as they were no longer working as you mention. I also excluded / reincluded the NGD00Z device. But it still says its : zwave_secure = false. What do I need to do to get it to securely add the device?

I figured it out. For all the other clueless people out there using a USB stick from AEON Labs: DO NOT unplug the stick from your pi to include the device!! Use the exclude / include functionality built-in to OH2 that I totally missed before. Then it will include securely. I have a working garage door controller now.

Nice one - I’m glad it’s working. :slight_smile: