Unknown Z-Wave device: How to proceed?

I recently bought a “Cyrus Door/Window Detector” and I try to include it to my OpenHAB setup. I previously successfully set it up with Z-Way but switched to OpenHAB in the meantime. The sensor shows up as “Unknown Device”. According to documentation, there are two reasons for this: Either the interview is not complete or it’s not in the binding database. How do I find out what the problem is? It already included it two weeks ago and also manually woke it up several times which did not solve anything.

Check the database if the device is listed:


If not, add it:


If you have problems, shout :grinning:

You may need your thing id and device type from your /userdata/zwave folder to properly identify your device and find a match in the db.

It seems like the device is in the database: Cyrus Door Window Sensor

In my /userdata/zwave folder (I presume its “/var/lib/openhab2/zwave” on my openHABian) the XML with the node ID matching the one in the UI actually looks like it describes my already working thermostat (specificDeviceClass>THERMOSTAT_GENERAL_V2</specificDeviceClass>) - and not that door sensor. Why is that?

Please identify your devices via manufacturer, device type and device id:



That’s strange, indeed. If you

did that properly and it is still not working I suggest excluding and re-include it again. Maybe just to make sure do a factory reset after excluding.
As you can see I have the same device and it is working properly.

@chris, it looks like we have three devices, which are the same, in two database definitions:

Should we combine them into one database definition? I have some spare time and could take the best out of the two :grinning:

Yes - you’re right. Pick the best (ie most complete) definition and copy over the IDs to that. I think you should be able to delete the other one (it just marks it deleted - there’s no actual removal of data).

Thanks @sihui.



Thanks @sihui

I’ve changed the channels slightly - I re-added the sensor_door to the Alarm command class (this was in one of the two entries previously). I checked one of the XML files that was previously loaded and it showed that this is reported.

From the XML, we have events 22 and 23 which are the door/window events -:

              <outer-class reference="../../../.."/>

Tamper is not actually shown here, but I’ve left it in the database definition.

We now have -:

1 Like

Thx. I picked the one with the channel definitions from your last change, assuming those are the correct ones. :grinning:

1 Like

I did as instructed, excluded that device, reset it to factory defaults and included it again. Unfortunately things are messed up now:

  • The previously excluded “Unkown Device” node returned, but it reads “Node not found in Z-Wave network”
  • A new “Unkown Device” node appeared

I tried excluding the new node, doesn’t seem to work. I tried marking the old node as failed, it displayed an error message saying something about “Node not found” or so. I also tried removing the node from the controller, same issue. In the meantime (sorry, have been busy) the new node also reads “Node not found in Z-Wave network”.

I have no idea what I’m doing wrong.

I assume you did not let the device initialize: after including you need to wake the device up manually (there is a button for that, check your manual). This may have to be done several times for battery operated devices.
If you exclude/reset the device this has all to be done again. So just be patient and wake it up :grinning:

I excluded, reset and included the device again and spent some time pressing that one button - now it is properly recognized. Thank you for your assistance!

1 Like

Hi there,

I’m trying to add my MCOHOME PM2.5 air quality monitor (Z-Wave) to OpenHAB. It’s not in the database.

network_d0294c80__node_26.xml (8.2 KB)

I found this thread, saw the database links above, created an account and opened a ticket on cd-jackson.com, now just waiting for @chris to let me in, please. :slight_smile:

I’ve updated your access. The ticket you opened this morning somehow seems broken, but you should be good to go :slight_smile:

1 Like

Thanks, Chris!

Working on it. Not easy (it’s my first time) but doing my best.

I’m afraid I’ve made a bit of a mess of things, though.
I mistakenly modified the channel list on device #115. Please disregard this edit.
I also mistakenly added a new device #1055 when in fact device #244 already existed with different IDs. I don’t know how I didn’t find it the first time, because I did search… I thought I did, anyway. Please delete device #1055. Sorry for the mess, I’ll get the hang of this eventually.

No worries Leif, we’ll make it thru yes!!

1 Like

Okay, having a few problems.
Every. Single. Page. is labeled simply “Device List”. That doesn’t help.

Useful BACK button, yes? :roll_eyes:

Anyway. I can’t seem to delete things when I’ve added something by mistake, nor can I seem to cancel a request. Might be a privilege issue.

I’m seeing a red exclamation point on parameter 255 (which I added), with no explanation or tooltip or other error message. 255 is correct – it’s listed as FF in the manual, I tried making it FF in the device list but it came out as 0, so I the field must be decimal, not hexadecimal.

Anyway… phew. I’ve made my submission now, device #244.
Please delete device #1055, I did not mean to add it.
Please also disregard the change to #115.

Will now try to add the updated device into openhab manually, hopefully that is a thing. :slight_smile:

Looks like that’s NOT a thing – I found the following thread:

Alright, I will wait patiently for an update, and add my device back to Fibaro HC2 in the mean time, since I really need the ventilation system automation to work. :slight_smile:

Here we go, that wasn’t so bad.

Fibaro HC2 LUA scene (script) to feed a parameter from a Z-Wave device (in this case id 301) directly to OpenHAB through the REST API.

%% properties
310 value
%% events
%% globals

payload = fibaro:getValue(310, 'value');

-- fibaro:debug('value ' .. payload) 

local http = net.HTTPClient()

http:request('', {

options = {

method = 'POST',

headers = {},

data = payload,

timeout = 5000

This will hold me over until openHAB supports my device.


I think your initial thought (adding a new device) was the right one: the existing database entry
is a non plus device without the configuration command class.
Your device is a zwave plus device and has the configuration command class.

@chris could you take a quick look, please?
Existing database entry is a non plus zwave device, @leif 's device is a zwave plus device (firmware version 2.3), should we separate the two devices in the database (I have some spare time today to do that).

Correct, database users with normal access rights can only add and edit entries, not delete them.


It’s hard to tell how best to handle this. There are two options -:

  1. The devices are the same, but the original device wasn’t properly filled in - possibly because manufacturer data was inadequate.
  2. The devices are actually different.

I found a newer manual which still doesn’t mention the configuration command class, but does list config parameters.

I also tried to find this device in the zwave alliance database, but couldn’t.

Given that the new manual specifically mentions ZWave Plus Technology, where the old one only says ZWave Technology, they are probably different, and probably it’s therefore best to split them.

Thanks @sihui

This just means that this is marked as a critical parameter so in the UI there should be an “Are you sure” question raised.

1 Like

Ah wow! Nice attention to detail there @sihui, I didn’t think to compare the manuals, especially since the devices are identical externally. I saw that the command class was missing, but I actually assumed that the original poster had been lazy and deleted the command class (to get rid of the database warning that there’s a command class but no defined commands) rather than fill out the commands! My bad.

So, it looks like I added a whole bunch of information to 244 which really only applies to #1055 then.
Do you need me to do anything else or will you take it from here?

@chris, I checked the manual you linked to and found the following on page 5:

Isn’t that it?
My version of the manual (the one I uploaded) has it too.