Unknown zigbee device, cant delete from inbox

Recently I tried to add a GE zigbee light bulb. This is a bulb that has been in my network before without issue. (I’ve had to re-add all my lights after the 2.4 update) when I reset the light and then scanned in the inbox, the light showed up as an unknown zigbee device. Usually it does this and after a few seconds it recognizes it as the GE light and I add it as normal. This time however it refused to complete the discovery and it remained as “unknown”. I deleted it from my inbox and reset the light again. When I searched for zigbee devices, the result was the same. I tried adding other lights, and they had no issue. No matter how many times I reset this light, it remains unknown and unusable. I also noticed that when the light is off completely (no power, physical switch on the lamp is off) the light still comes up in my inbox as unknown. I’ve tried deleting it dozens of times. I’ve rebooted the system half a dozen times. It continues to show up even with the light off. I feel like this “phantom” version is blocking the system from actually talking to the real light when it is on. Any suggestions?

Did you clear the cache?

I’ve tried deleting the cache as you suggested. The problem persists unfortunately. Thank you for the suggestion.

Still looking for help. Ended up finally getting rid of the original “unknown” mysteriously only to have two other pop up for two of my crew lights. So it’s not specifically a particular bulb or brand

Same problem here. Device without battery, cleared the cache, physically disconnected the coordinator, deleted xml file on /var/lib/openhab2/zigbee/zigbee_coordinator_ember_xxx directory but the item continue to be discovered. Is it a bug?

Please provide details of your environment - eg what binding are you running? Are you running the latest snapshot, or 2.5, or something else? It’s important to know this.

If you delete the XML, and restart the binding (ensuring that the XML is really gone) then there is nothing left and the device will not be discovered. Ensure that when you delete the XML, that the binding is STOPPED otherwise it will save it again when the binding stops.

I’m on openHAB 2.5.1-2, Ember stick (Bitron Video ZigBee USB Funkstick).
There are 2 devices I’m trying to delete without success. An Aqara motion sensor and a unbranded door contact I bought on Amazon. I also have a Gledopto RGBWW LED driver and a Osram Smart+ lamp that work fine.

I delete the xml files after I stopped openhab via console (with the command sudo systemctl stop openhab2.service). Is it correct?

Yes, that should be fine. Is the device still on the network? ie is it still working? If so, that is another reason for it to continue to be discovered.

Now I’m focusing on the Aqara motion sensor.

It’s without battery, so it can’t work.
I stopped openhab service, deleted the file again and restarted openhab

During openhab boot I checked with ls command that the file was really deleted.
When I read the first zigbee binding log lines on the log viewer I checked the /var/lib/openhab2/zigbee/zigbee_coordinator_ember_01380F03 directory for the file and it’s in. I really can’t understand

I guess you’ve checked the logs to find out what’s happening? If not, that would be a good place to start - otherwise we’re guessing.

I also assume there is no thing defined?

Please provide the log, and the XML and I’ll have a look.

I’m trying to understand what’s happening from the log.
This is the first line where the device appear

[DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - RX CMD: IeeeAddressResponse [66EB/0 -> 0000/0, cluster=8001, TID=2E, status=SUCCESS, ieeeAddrRemoteDev=00158D0004514C4B, nwkAddrRemoteDev=23321, startIndex=null, nwkAddrAssocDevList=[]]

Could you please let me know where I can send you the files, one is a little more than 1024kB and I can’t upload

This means that the device is sending a response to the coordinator, the binding is receiving this and will then add it to the list of devices.

My guess is that this is a different device than you think (since you have removed the batteries - right?).

Most people use something like DropBox or GitHub.

I’m quite sure it’s the right one because with the battery on, if I push the button on the device I read the address “00158D0004514C4B” on the log.

Here the files

So I think that the likely issue here is that the device was not removed from the network. The response is being received from the devices parent rather than from the device which is normal for ZigBee End Devices. Since ZEDs sleep most of the time, their parent will respond in their absence, and that’s what we’re seeing here.

So I just have to wait the Child Age Timeout (that it’s 1 day in my coordinator settings)?

That setting is for the coordinator - I’ve no idea what the router that is the parent for this device will do. It could stay there forever as child ageing and removal from child tables was not mandatory in ZigBee until recently.

The binding attempts to remove the device from the network when you delete the thing. So, you could add the thing back in, and then delete it. This should remove it from the parent as well but I’m not 100% sure. If it doesn’t work, please send me a log and I’ll have a look.