Update 3.0.0 to 3.2.0 does not work with update.ps1 on WIN 10

Powershell disappears after starting update.ps1?
Where has the new Version 3.2.0 to be stored?

Commands I used in the Powershell:

cd C:\openHAB
. .\runtime\bin\update.ps1
Update-openHAB -OHVersion 3.2.0

Did you run your powershell window as administrator?

Yes, I run it as administrator.

As 3.0.0 is from times of before sunset of bintray it could be that the links that are used in update.ps1 point to a location that is not available any longer.
From your description it is not clear if the download successfully completed or if it is aborted.
What are the links that are used in the update.ps1 file ? Where do the DownloadLocation variables point to ?

Running command to extract rows containing string http:
grep http runtime/bin/update.ps1

results in:

        $DownloadLocation="https://ci.openhab.org/job/openHAB3-Distribution/lastSuccessfulBuild/artifact/distributions/openhab/target/openhab-$OHVersionName.zip"
        $AddonsDownloadLocation="https://ci.openhab.org/job/openHAB3-Distribution/lastSuccessfulBuild/artifact/distributions/openhab-addons/target/openhab-addons-$OHVersionName.kar"
        $DownloadLocation="https://www.openhab.org/download/milestones/org/openhab/distro/openhab/$OHVersionName/openhab-$OHVersionName.zip"
        $AddonsDownloadLocation="https://www.openhab.org/download/milestones/org/openhab/distro/openhab-addons/$OHVersionName/openhab-addons-$OHVersionName.kar"
        $DownloadLocation = "https://www.openhab.org/download/releases/org/openhab/distro/openhab/$OHVersionName/openhab-$OHVersionName.zip"
        $AddonsDownloadLocation = "https://www.openhab.org/download/releases/org/openhab/distro/openhab-addons/$OHVersionName/openhab-addons-$OHVersionName.kar"
        Write-Host -ForegroundColor Green "Check https://www.openhab.org/docs/installation/windows.html"

Hey,
sorry but I can not copy my http lines or a file with my search resulte because I am a new user? Till now Icould not find a difference.
The update was not succsessfull. The powershell disepears short after I start the last order. I can not read what was writen in the last moment. It disepears too fast.

Is it possible to redirect the output to a file.

How can I do that?


I got a foto from the end.

As stated earlier the URL points to bintray which is not longer available.
Make sure to replace the URL with the corresponding one that I listed in my earlier post.

https://www.openhab.org/download/releases/org/openhab/distro/openhab/
is the base URL for the stable release. This URL is shortended compared to the above ones.
To run the powershell script you need to use the URL from the previous post.

1 Like

Hey. Thank you. That was it. Now the update worked.

1 Like